Page MenuHomePhabricator

Flow: browser tests should assert changes appear in Topic history/board history/RecentChanges/Special:Contributions
Closed, ResolvedPublic

Description

Flow's "paper trail" of changes often breaks, e.g. recent T75153: Flow: Special:Contributions missing recent Flow content and T75238: Flow: Topic moderation after moderating one of its post does not appear in the topic's history. It would be nice if one test (each, probably) that adds and moderates content go on to assert

And I see {the change} in board history 
And I see {the change} in topic history 
And I see {the change} in Special:RecentChanges
And I see {the change} in my Special:Contributions

the wording is slightly different in each but for moderation is roughly "{moderated} the topic/a comment on "{topic title".


Version: master
Severity: normal

Details

Reference
bz73239

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:47 AM
bzimport set Reference to bz73239.
bzimport added a subscriber: Unknown Object (MLST).

s/all tests/one test/

I see these not as "And" statements but as "Then" statements

Given (some initial conditions)
When (I take some action)
Then I see the change in board history

Given (some initial conditions)
When (I take some action)
Then I see the change in topic history

etc.

I think it would be valuable to have such a test. If you Flow people who know the details would write the feature file/Scenarios, I'd be happy to work on automating those.

Mattflaschen-WMF set Security to None.
Spage triaged this task as High priority.Dec 16 2014, 10:23 AM

High since this would have caught some regressions.

I looked into this, Special:RecentChanges looks like a reasonable target, but it may not be possible to check Special:Contributions on beta labs.

I will write a test for Special:RecentChanges today.

Special:Contributions for Selenium_user takes a very long time to load and then displays the message "Due to high database server lag, changes newer than 81 seconds may not appear in this list." I'll see if I can get this addressed.

Quiddity removed a subscriber: Maryana.Dec 19 2014, 1:25 AM
Cmcmahon closed this task as Resolved.Jan 5 2015, 4:54 PM

This was merged