Page MenuHomePhabricator

Can't scroll in edit mode
Closed, ResolvedPublic

Description

A change in the last short time, perhaps couple of weeks, means that when I go into edit mode I cannot scroll down the page - so my editing is restricted to changing the first few lines of any section of a page. This was not previously the case.

I can scroll down pages to read them with no problem, it's only in edit mode that scrolling fails.


Version: unspecified
Severity: normal
OS: other
Platform: Smartphone

Details

Reference
bz73255

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:48 AM
bzimport set Reference to bz73255.
bzimport added a subscriber: Unknown Object (MLST).
PamD created this task.Nov 11 2014, 9:35 AM

bingle-admin wrote:

Prioritization and scheduling of this bug is tracked on Trello card https://trello.com/c/mkVQaFJO

On which page(s)? On which device(s)? Steps to reproduce welcome. :)

PamD added a comment.Nov 11 2014, 4:59 PM

Device: Samsung Galaxy Fame smartphone

Pages: Any, as far as I can see

Steps to reproduce:
1:View article, such as "Streatham Street"
Screen layout,from top, is:

  • My phone's top bar with time, battery, signal bars etc
  • internet bar with search window, tabs icon, etc
  • "Search Wikipedia" etc bar
  • "Last edited..."
  • Article title
  • Bar with edit, talkpage, watch icons
  • Article (starting 40mm down the 75mm screen)

2: Click on "pen" icon to edit

3: See screen with, top to bottom:

  • My phone's top bar with time, battery, signal bars etc
  • internet bar with search window, tabs icon, etc
  • Bar saying "Editing Streatham Street" with "Next" button
  • Article source, down to words "became the location for new"

4: Attempt to scroll: only very slight movement on screen

5: See screen with:

  • My phone's top bar with time, battery, signal bars etc
  • (note that internet bar disappears)
  • Bar saying "Editing Streatham Street" with "Next" button
  • text of article, from 2nd line (part of file link), to "became the location for new"
  • empty space below, about 10mm (ie width of the disappeared Internet bar plus one line of article text)

6:I can scroll up and down between states 3 and 5, but cannot see anything lower in the article. I can edit what I can see. I can't edit anything else.

7: In an article with multiple sections, the same problem occurs for each section.

Fortunately a lot of my editing is stub-sorting, where I'm editing the end matter of an article and there's usually not enough stuff after the "References" section heading to cause a problem, so I can continue to do most of those edits in mobile. But for more substantial edits, it's a huge nuisance to have to remember "Must get back to Streatham Street and sort it out next time I'm on the laptop".

I hope I've explained the scenario clearly now!

These steps i have done (HTC One in Chrome for Android)

(i'm logged in and in beta mode)

  • Editing and scrolling works fine :/

Can you give some more info, e.g. the browser you're using? Can you test another browser?

Thanks!

Can't reproduce with Android 4 and neither Chrome nor Firefox.

Please can you tell us which android version has your phone? Also which browser are you using?

If you don't know how to get that info this two links should help:
http://whatismyandroidversion.com/
https://www.whatismybrowser.com/

PamD added a comment.Nov 12 2014, 7:26 PM

Thanks for the two links.

The first tells me Android 4.1.2 (Jelly Bean)

The second says: Android Browser 4 on Android (Jelly Bean)

I can scroll up and down articles and talk pages, no problem.

And I'm almost 100% sure that I used to be able to edit long articles/sections without this problem, until perhaps a couple of weeks ago. Hope that helps.

Change 173344 had a related patch set uploaded by Robmoen:
Focus editor textarea

https://gerrit.wikimedia.org/r/173344

Change 173344 merged by jenkins-bot:
Focus editor textarea

https://gerrit.wikimedia.org/r/173344

Pam a fix should be on this site: http://en.m.wikipedia.beta.wmflabs.org/wiki/Headings - are you able to verify the above fix is working there? If so we can get it pushed to English Wikipedia.

PamD added a comment.Nov 19 2014, 10:06 AM

Thanks for working on this.

That page as it was didn't test the problem as none of the sections were long, so I edited section YOO YO to test ... and the problem seems to be more or less solved. When I go to section YOO YO and try to edit it, initially my scrolling doesn't work but after a couple of tries, on the third attempt it scrolls OK and I can edit. This seems reproducible at the moment. I've got quite a poor wifi signal and a pretty low-grade phone, if that might signify anything.

Change 175552 had a related patch set uploaded (by Kaldari):
Reverting change I10c2cbfdfa5c6d74b98d7c45e1c060911a7f20b4

https://gerrit.wikimedia.org/r/175552

Patch-For-Review

Change 175554 had a related patch set uploaded (by Kaldari):
Reverting change I10c2cbfdfa5c6d74b98d7c45e1c060911a7f20b4

https://gerrit.wikimedia.org/r/175554

Patch-For-Review

Change 175552 merged by jenkins-bot:
Reverting change I10c2cbfdfa5c6d74b98d7c45e1c060911a7f20b4

https://gerrit.wikimedia.org/r/175552

Change 175554 merged by jenkins-bot:
Reverting change I10c2cbfdfa5c6d74b98d7c45e1c060911a7f20b4

https://gerrit.wikimedia.org/r/175554

Florian set Security to None.

Is this fixed or still presenting itself as a problem?

Jdlrobson closed this task as Resolved.Dec 24 2014, 7:48 PM
Jdlrobson claimed this task.

I guess this is fixed then? Please reopen if this is not true.