Page MenuHomePhabricator

PNG fails to render with lexing error for some input containing Malayalam
Closed, ResolvedPublic

Description

Input fails to render with a lexing error

The given example fails to render in PNG mode with a lexing error (can someone put this in plaintext in the bug report, so it's easier to reproduce?)

Extracted out of T50032. Screenshot by praveenp.


Version: unspecified
Severity: normal

Attached:

Details

Reference
bz73285

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:50 AM
bzimport added a project: Math.
bzimport set Reference to bz73285.
bzimport added a subscriber: Unknown Object (MLST).
TTO added a comment.Nov 12 2014, 4:09 AM

This is enough to see the bug:

<math>ക</math>

TTO added a comment.Nov 12 2014, 4:11 AM

The example in comment 1 gives the error "Failed to parse (lexing error): ക"

This example:

<math>\text{ക}</math>

gives a different message: "Failed to parse (PNG conversion failed; check for correct installation of latex and dvipng (or dvips + gs + convert)): {\text{ക}}"

This bug is not limited to Malayalam only.

Examples: Tamil: <math>\text{ப}</math>, Hindi: <math>\text{ग}</math>

This particular bug report is limited to Malayalam. Those are not just different languages, but also different alphabets, meaning a fix for this bug (e.g. a new font) will not necessarily fix those.

So if you want to track those other alphabets, please file separate reports.

I don't think it's a font issue, I think it's a TeX validation issue.

Does this bug occur with Mathoid enabled?

Physikerwelt triaged this task as Low priority.Mar 20 2015, 3:09 PM
Physikerwelt set Security to None.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 21 2016, 4:43 PM
Debenben closed this task as Resolved.Nov 11 2018, 7:28 PM
Debenben claimed this task.
Debenben added a subscriber: Debenben.

the rendering of Malayalam is still not very good, but there is no error anymore, since the png is created from the svg images now