Rename a lot of getters for consistency
Open, NormalPublic

Description

There are a very large number of changes, so older changes are hidden. Show Older Changes

Change 376502 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[oojs/ui@master] Use findHighlightedItem instead of getHighlightedItem

https://gerrit.wikimedia.org/r/376502

Change 376503 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[oojs/ui@master] [BREAKING CHANGE] SelectWidget: Remove getHighlightedItem

https://gerrit.wikimedia.org/r/376503

Prtksxna updated the task description. (Show Details)Sep 7 2017, 11:53 AM
Prtksxna moved this task from Next-up to Doing on the OOUI board.Sep 7 2017, 12:10 PM

Change 376171 merged by jenkins-bot:
[oojs/ui@master] [DEPRECATING CHANGE] SelectWidget: Rename getFirstSelectableItem to findFirstSelectableItem

https://gerrit.wikimedia.org/r/376171

Change 376501 merged by jenkins-bot:
[oojs/ui@master] [DEPRECATING CHANGE] SelectWidget: Rename getHighlightedItem to findHighlightedItem

https://gerrit.wikimedia.org/r/376501

Change 376502 merged by jenkins-bot:
[oojs/ui@master] Use findHighlightedItem instead of getHighlightedItem

https://gerrit.wikimedia.org/r/376502

Volker_E moved this task from Doing to In discussion on the OOUI board.Sep 13 2017, 5:21 AM

Change 376172 merged by Prtksxna:
[oojs/ui@master] Use findFirstSelectableItem instead of getFirstSelectableItem

https://gerrit.wikimedia.org/r/376172

Change 376183 merged by jenkins-bot:
[oojs/ui@master] [DEPRECATING CHANGE] SelectWidget: Rename getRelativeSelectableItem to findRelativeSelectableItem

https://gerrit.wikimedia.org/r/376183

Change 376184 merged by jenkins-bot:
[oojs/ui@master] Use findRelativeSelectableItem instead of getRelativeSelectableItem

https://gerrit.wikimedia.org/r/376184

Jdforrester-WMF updated the task description. (Show Details)

Change 376177 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] Use findFirstSelectableitem instead of getFirstSelectableItem

https://gerrit.wikimedia.org/r/376177

Change 376175 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Use findFirstSelectableitem instead of getFirstSelectableItem

https://gerrit.wikimedia.org/r/376175

Change 376174 merged by jenkins-bot:
[mediawiki/extensions/TemplateData@master] Use findFirstSelectableitem instead of getFirstSelectableItem

https://gerrit.wikimedia.org/r/376174

Change 376176 merged by jenkins-bot:
[mediawiki/core@master] apisandbox.js: Use findFirstSelectableitem instead of getFirstSelectableItem

https://gerrit.wikimedia.org/r/376176

Change 376186 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Use findRelativeSelectableItem instead of getRelativeSelectableitem

https://gerrit.wikimedia.org/r/376186

Change 376503 merged by jenkins-bot:
[oojs/ui@master] [BREAKING CHANGE] SelectWidget: Remove getHighlightedItem

https://gerrit.wikimedia.org/r/376503

Change 375936 merged by jenkins-bot:
[oojs/ui@master] [BREAKING CHANGE] Remove BookletLayout#getClosestPage

https://gerrit.wikimedia.org/r/375936

Change 376185 merged by jenkins-bot:
[oojs/ui@master] [BREAKING CHANGE] SelectWidget: Remove getRelativeSelectableItem

https://gerrit.wikimedia.org/r/376185

Change 376173 merged by jenkins-bot:
[oojs/ui@master] [BREAKING CHANGE] SelectWidget: Remove getFirstSelectableItem

https://gerrit.wikimedia.org/r/376173

@Prtksxna Would you please care about the two last open items here, as well? Want to get this in for v0.25.0.

OO.ui.GroupElement.prototype.getItemFromData ➞ OO.ui.GroupElement.prototype.findItemFromData

Just confirming, we should also change the plural, OO.ui.GroupElement.prototype.getItemsFromData ➞ OO.ui.GroupElement.prototype.findItemsFromData

@Prtksxna Yes, please. Also getSelectedItemsDatafindSelectedItemsData.

Prtksxna added a comment.EditedDec 13 2017, 6:44 AM

@Prtksxna Yes, please. Also getSelectedItemsDatafindSelectedItemsData.

Yes, thanks, just writing a comment about that.

OO.ui.SelectWidget.prototype.getSelectedItem ➞ OO.ui.SelectWidget.prototype.findSelectedItem

We should also change this for MultiSelectWidget (not just SelectWidget) and thus getSelectedItemsData.

Prtksxna updated the task description. (Show Details)Dec 13 2017, 6:59 AM

Change 398004 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[oojs/ui@master] [DEPRECATING CHANGE] GroupElement: Rename getItemFromData to findItemFromData

https://gerrit.wikimedia.org/r/398004

Prtksxna updated the task description. (Show Details)Dec 13 2017, 7:06 AM

Change 398005 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[oojs/ui@master] [DEPRECATING CHANGE] SelectWidget: Rename getSelectedItem to findSelectedItem

https://gerrit.wikimedia.org/r/398005

Prtksxna updated the task description. (Show Details)Dec 13 2017, 7:14 AM

Change 398006 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[oojs/ui@master] [DEPRECATING CHANGE] MultiSelectWidget: Rename getters

https://gerrit.wikimedia.org/r/398006

Prtksxna updated the task description. (Show Details)Dec 13 2017, 7:23 AM

Change 398209 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[oojs/ui@master] Use findItem(s)FromData instead of getItem(s)FromData

https://gerrit.wikimedia.org/r/398209

Prtksxna updated the task description. (Show Details)Dec 14 2017, 5:57 AM

Change 398217 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[mediawiki/extensions/ContentTranslation@master] Use findItem(s)FromData instead getItem(s)FromData

https://gerrit.wikimedia.org/r/398217

Prtksxna updated the task description. (Show Details)Dec 14 2017, 7:25 AM
Prtksxna updated the task description. (Show Details)Dec 14 2017, 7:30 AM

Change 398221 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[mediawiki/core@master] Use findItemFromData instead getItemFromData

https://gerrit.wikimedia.org/r/398221

Prtksxna updated the task description. (Show Details)Dec 14 2017, 7:48 AM

Change 398223 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[mediawiki/extensions/AdvancedSearch@master] Use findItem(s)FromData instead getItem(s)FromData

https://gerrit.wikimedia.org/r/398223

Prtksxna updated the task description. (Show Details)Dec 14 2017, 8:01 AM

Change 398224 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[mediawiki/extensions/Echo@master] Use findItem(s)FromData instead getItem(s)FromData

https://gerrit.wikimedia.org/r/398224

Prtksxna updated the task description. (Show Details)Dec 14 2017, 8:08 AM

Change 398004 merged by jenkins-bot:
[oojs/ui@master] [DEPRECATING CHANGE] GroupElement: Rename getItem(s)FromData to findItem(s)FromData

https://gerrit.wikimedia.org/r/398004

Change 398209 merged by jenkins-bot:
[oojs/ui@master] Use findItem(s)FromData instead of getItem(s)FromData

https://gerrit.wikimedia.org/r/398209

Change 400466 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[mediawiki/extensions/Flow@master] Use findItemFromData instead getItemFromData

https://gerrit.wikimedia.org/r/400466

Prtksxna updated the task description. (Show Details)Thu, Dec 28, 6:07 AM

Change 400467 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[mediawiki/extensions/CentralNotice@master] Use findItemFromData instead getItemFromData

https://gerrit.wikimedia.org/r/400467

Prtksxna updated the task description. (Show Details)Thu, Dec 28, 6:14 AM

Change 400468 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[mediawiki/extensions/TemplateData@master] Use findItemFromData instead getItemFromData

https://gerrit.wikimedia.org/r/400468

Prtksxna updated the task description. (Show Details)Thu, Dec 28, 6:17 AM

Change 400469 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[mediawiki/extensions/VisualEditor@master] Use findItemFromData instead getItemFromData

https://gerrit.wikimedia.org/r/400469

Prtksxna updated the task description. (Show Details)Thu, Dec 28, 6:24 AM

Change 400470 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[VisualEditor/VisualEditor@master] Use findItemFromData instead getItemFromData

https://gerrit.wikimedia.org/r/400470

Prtksxna updated the task description. (Show Details)Thu, Dec 28, 6:28 AM
Prtksxna updated the task description. (Show Details)Wed, Jan 3, 5:56 AM
Prtksxna updated the task description. (Show Details)Wed, Jan 3, 6:24 AM

Change 398005 merged by jenkins-bot:
[oojs/ui@master] [DEPRECATING CHANGE] SelectWidget: Rename getSelectedItem to findSelectedItem

https://gerrit.wikimedia.org/r/398005

Change 398006 merged by jenkins-bot:
[oojs/ui@master] [DEPRECATING CHANGE] MultiSelectWidget: Rename getters

https://gerrit.wikimedia.org/r/398006

Change 400470 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] Use findItemFromData instead getItemFromData

https://gerrit.wikimedia.org/r/400470

Change 400466 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Use findItemFromData instead getItemFromData

https://gerrit.wikimedia.org/r/400466

Change 400468 merged by jenkins-bot:
[mediawiki/extensions/TemplateData@master] Use findItemFromData instead getItemFromData

https://gerrit.wikimedia.org/r/400468

Change 400469 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Use findItemFromData instead getItemFromData

https://gerrit.wikimedia.org/r/400469

Change 398217 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Use findItem(s)FromData instead getItem(s)FromData

https://gerrit.wikimedia.org/r/398217

Change 398223 merged by jenkins-bot:
[mediawiki/extensions/AdvancedSearch@master] Use findItem(s)FromData instead getItem(s)FromData

https://gerrit.wikimedia.org/r/398223

Change 398221 merged by jenkins-bot:
[mediawiki/core@master] Use findItemFromData instead getItemFromData

https://gerrit.wikimedia.org/r/398221

Change 398224 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Use findItem(s)FromData instead getItem(s)FromData

https://gerrit.wikimedia.org/r/398224

Volker_E updated the task description. (Show Details)Thu, Jan 11, 1:38 AM

Change 404513 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (d5428e9b3)

https://gerrit.wikimedia.org/r/404513

Change 404513 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (d5428e9b3)

https://gerrit.wikimedia.org/r/404513

Jdforrester-WMF updated the task description. (Show Details)