Page MenuHomePhabricator

Popup/Hover on Wikidata Q pages shows plain /*<![CDATA[*/ only
Closed, DuplicatePublic

Description

Popup/Hover on Wikidata Q pages shows plain /*<![CDATA[*/ only.

I am not sure if this works in the past. Maybe disable the popups for "wgPageContentModel": "wikibase-item"and similar?

Event Timeline

Raymond raised the priority of this task from to Needs Triage.
Raymond updated the task description. (Show Details)
Raymond added a project: Page-Previews.
Raymond changed Security from none to None.
Raymond added a subscriber: Raymond.
Se4598 added subscribers: Bene, Se4598.

This is only applicable for some items, for others extracts returned are empty. Should be fixed in TextExtracts?

side note: there is a changeset (https://gerrit.wikimedia.org/r/150731) awaiting review, which would made is possible to create a custom renderer for namespaces like wikibase-item.

Prtksxna triaged this task as Medium priority.Jan 4 2015, 11:12 PM

The hovercards seem to actually mostly work now, so I guess this should be closed if someone can explain how that happened?

Bene claimed this task.

Closed per https://www.wikidata.org/wiki/Wikidata:Project_chat#Popups_extension_now_also_working_on_items_and_properties. This is done as a local javascript hack now but should perhaps go into the extension itself at some point.

Ricordisamoa added a subscriber: Ricordisamoa.

Should work without hacks.

I will prepare another patch set for the Popups extension but if it again takes 3 months to get a review or response this can't be implemented without local javascript hacks on the wiki.

I will prepare another patch set for the Popups extension but if it again takes 3 months to get a review or response this can't be implemented without local javascript hacks on the wiki.

Thanks.