Page MenuHomePhabricator

Cached "Last modified" date in footer not always updated after edit
Closed, DeclinedPublic

Description

Author: jean

Description:
For some pages, the last modified date displayed at the bottom of the page is
the last one.

On the other hand, the logging history - from the upper tab - for these pages is
correct.

If I go on updating these pages, the lastmod date is incrementing, but remains
the date that has been logged in the histort before the last one.

The above url gives an example : the real last date/time is 11:08 and the
displayed is 10:55.

I use the standard monobook skin.

Thx for your help.


Version: 1.11.x
Severity: normal
URL: http://arkae.redirectme.net/wiki/index.php/Deguignet%2C_Informations_pratiques

Details

Reference
bz6263

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 9:19 PM
bzimport added a project: Wikimedia-Rdbms.
bzimport set Reference to bz6263.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Jun 10 2006, 9:46 AM

jean wrote:

The 1st above sentence should be: For some pages, the last modified date
displayed at the bottom of the page is NOT the last one.

brion added a comment.Jun 10 2006, 9:34 PM

Please provide a specific list of steps to reproduce the
problem and very specific descriptions of what is different
from the expected results.

jean wrote:

The above URL1 (*) stated the unexpected result when I posted the Bug id :

  • from the history tab, the last updates is June 10th at 11:08 (previous at 10:55)
  • the 'listmod' property at the bottom was 10:55 instead of 11:08.
  • I did clean my local cache (and even restarted my browser)
  • now it is correct and I don't know why.

(*) URL 1 =
http://arkae.redirectme.net/wiki/index.php/Deguignet%2C_Informations_pratiques

Right now I have another example of the same inconsistant information :

  • URL 2

http://arkae.redirectme.net/wiki/index.php/Enqu%C3%AAte_sur_le_canal_et_les_moulins

  • the history tab states the 2 last updates : June 11th, 18:01 and June 11th, 18:03
  • the 'lastmod' property at bottom gives only June 11th, 18:01

Thks for any clue

brion added a comment.Jun 11 2006, 8:31 PM

The footer matches the history exactly.

dpischenko wrote:

In version 1.6.5 this bug present too. And it may be depends on browser cashe or
cookies, because jcognard links work correctly for me, but my link:
http://modiki.civfanatics.ru/index.php/%D0%9C%D0%BE%D0%B4%D0%BE%D1%81%D1%82%D1%80%D0%BE%D0%B5%D0%BD%D0%B8%D0%B5_%D0%BD%D0%B0%D1%88-%D1%84%D0%B0%D0%BD%D0%B0%D1%82%D0%B8%D0%BA%D0%BE%D0%B2_%D0%BD%D0%B0_civfanatics.ru
shows not last date.

dotkorg wrote:

I've encountered this bug several times.

Some examples:

pq3854 wrote:

Seems like this bug still exists, and it's not a cache issue.
It's no big deal, but having the wrong timestamp is annoying.
The follow reproduces the problem, at least for me.

  1. (refresh pages after every step below)
  2. log in
  3. edit and save an article you've worked on earlier
  4. log out
  5. navigate to the article: page footer is correct & properly matches top item

in history file.

  1. log in
  2. page footer is now incorrect, it matches date and time

of the second item in history file, not the first one.

Behaves the same in both Firefox and IE.
FWIW, I run with a time offset of -4 hours from UTC.

  • Bug 8283 has been marked as a duplicate of this bug. ***
brion added a comment.Jul 20 2007, 2:41 PM
  • Bug 10646 has been marked as a duplicate of this bug. ***
brion added a comment.Nov 30 2007, 4:10 PM
  • Bug 781 has been marked as a duplicate of this bug. ***
brion added a comment.Nov 30 2007, 4:11 PM
  • Bug 12161 has been marked as a duplicate of this bug. ***
  • Bug 14541 has been marked as a duplicate of this bug. ***

I observed the same problem:
Steps performed:

  1. I went to the "Internet Bot" page on Wikipedia
  2. I edited it by adding a few spaces (this was done on 6th December at 3:06 pm, 5.5 hours ahead of UTC)
  3. Saved changes
  4. Refreshed it a couple of times, and the footer still displays: This page was last modified on 6 December 2014 at 09:31.

Version: 1.25wmf11 (cd2519e)

Nemo_bis renamed this task from Last modified display date not the last one to Cached "Last modified" date in footer not always updated after edit.Dec 8 2014, 7:37 AM
Nemo_bis set Security to None.
  1. Refreshed it a couple of times, and the footer still displays: This page was last modified on 6 December 2014 at 09:31.

That's actually correct, your edit was at 9.31 UTC. https://en.wikipedia.org/w/index.php?title=Internet_bot&diff=636867420&oldid=634355358
Cache updates for footer and sidebar are not always intuitive.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 15 2015, 2:18 AM
Krinkle closed this task as Declined.May 24 2017, 11:56 AM
Krinkle added a subscriber: Krinkle.

Closing for now. This issue is from 2006. The footer message is rendered based on the revision timestamp and cached as part of ParserOutput, ParserCache and File cache (if configured) together with everything else. If this is still an issue, please create a new task.