Page MenuHomePhabricator

Implement Data Retention Guidelines
Open, MediumPublic

Description

Parent ticket for all tasks related to the Data Retention Policy.
--
Mark Bergsma <mark at wikimedia>
Lead Operations Architect
Wikimedia Foundation

Related Objects

StatusSubtypeAssignedTask
OpenNone
OpenNone
OpenNone
OpenNone
DuplicateNone
ResolvedOttomata
ResolvedOttomata
ResolvedOttomata
ResolvedOttomata
ResolvedOttomata
ResolvedOttomata
ResolvedOttomata
Resolvedakosiaris
ResolvedJgreen
ResolvedJgreen
ResolvedJgreen
ResolvedJgreen
ResolvedJgreen
Resolvedawight
Resolvedcoren
Resolvedawight
ResolvedOttomata
ResolvedMilimetric
ResolvedOttomata
ResolvedMilimetric
ResolvedMilimetric
ResolvedMilimetric
ResolvedMilimetric
ResolvedOttomata
ResolvedOttomata
ResolvedMilimetric
OpenNone
OpenNone
OpenNone
OpenNone

Event Timeline

rtimport raised the priority of this task from to Medium.Dec 18 2014, 1:49 AM
rtimport added a project: ops-core.
rtimport set Reference to rt6858.
mark created this task.Feb 17 2014, 2:39 PM
mark added a comment.Feb 17 2014, 2:40 PM

Member ticket #6855 added by mark

mark added a comment.Feb 17 2014, 2:40 PM

Member ticket #6856 added by mark

mark added a comment.Feb 17 2014, 2:40 PM

Member ticket #6857 added by mark

mark added a comment.Feb 17 2014, 2:43 PM

Subject changed from 'Implement Data Retention Policy' to 'Implement Data Retention Guidelines' by mark

Jeff and I will be taking a first whack at this; notes on
https://office.wikimedia.org/wiki/User:ArielGlenn/Data_Retention and adding
Jeff on cc

Status changed from 'new' to 'open' by RT_System

kevinator reopened this task as Open.Jan 30 2015, 12:06 AM
kevinator closed this task as a duplicate of Restricted Task.
kevinator set Security to None.
This comment was removed by kevinator.
faidon added a subtask: Restricted Task.Feb 12 2015, 8:57 PM

also see this patch for "purge webrequest logs after 90 days", just added a bug

https://gerrit.wikimedia.org/r/#/c/197081/

see comment from @Ottomata though -> "please wait on this, or sync up with analytics :)"

mw logs are now deleted after 90 days, not 180 anymore:

https://gerrit.wikimedia.org/r/#/c/195917/

the webrequests log change in the last comment above is still open

Restricted Application added a subscriber: Matanya. · View Herald TranscriptJul 30 2015, 10:35 PM
Dzahn added a comment.Sep 22 2015, 5:54 AM

https://gerrit.wikimedia.org/r/#/c/197081/ is stalled because of the comments on Gerrit from Kevinator

"We need to keep some data for legal purposes. Also there also needs to be some assessments done to some of the subdirectories. Not all have been cleared for deletion:"

and links to T84618

Dzahn added a subtask: Restricted Task.Sep 22 2015, 5:54 AM
Dzahn moved this task from Backlog to tracking on the audits-data-retention board.Feb 12 2016, 9:55 PM

objections to making this task public?

Nuria closed subtask Restricted Task as Resolved.Dec 6 2016, 6:06 PM
fgiunchedi changed the visibility from "WMF-NDA (Project)" to "Public (No Login Required)".Apr 15 2020, 2:54 PM
fgiunchedi changed the edit policy from "WMF-NDA (Project)" to "acl*sre-team (Project)".