Page MenuHomePhabricator

Bump minimum PHP version for MediaWiki to 5.3.3
Closed, ResolvedPublic


The CSSJanus upstream lists 5.3.3 as the minimum version and we currently use 5.3.2. It would be nice for these to match. Timo doesn't want to drop his requirement to 5.3.2 since 5.3.3 is the oldest version that Travis-CI supports for testing.

Event Timeline

bd808 raised the priority of this task from to Needs Triage.
bd808 updated the task description. (Show Details)
bd808 added a project: Librarization.
bd808 changed Security from none to None.
bd808 added a subscriber: bd808.

@Reedy pointed out that Ubuntu 10.04LTS ships with 5.3.2-1ubuntu4.27, so we'd be dropping support for lucid.

CentOS 6 appears to ship with 5.3.3.

WMF and Ubuntu 12.04LTS use 5.3.10, so we can't go any higher than that.

Base 10.04 came out in April 2010. The latest point release for it came out in Feb 2012.

10.04.4 is only supported by Canonical till April 2015 (already dropped Desktop support)

Loosing support for 10.04 doesn't seem the biggest issue in the world. By the time MW 1.25 is released, 10.04 will be just about dead. I also can't imagine many people developing for MW/using core master still using 10.04 for php et al is a little more of an issue... 6 is listed as "Full Updates" till Q2 2017 and Maintenance to "30 November 2020". seems to suggest 5.3.3-26 is the stock upgradeable package... Same for CentOS 6.5

I think I'd happily +1 anything for PHP <= 5.3.10. Might want to get Brion and/or Tim to sign off and +2 it as architects

I set up a 10.04 VM and tried it out. It first bailed on phpunit, which requires 5.3.3 already, but only as require-dev. Adding a dependency upon cssjanus/cssjanus then failed with the same error of unsatisfiable dependencies.

bd808 triaged this task as Medium priority.Oct 24 2014, 4:41 AM
bd808 moved this task from Untriaged to In Dev on the Librarization board.