Page MenuHomePhabricator

Link cards are not showing equivalent articles
Closed, ResolvedPublic1 Story Points

Description

When a word in the translation area is selected, link cards may appear.
#The target link card should show an article that has the same title as the selected text.
#The source link card should show the equivalent article to (a) based on Wikidata equivalences. This is currently not happening.

It seems that the source link card is shown based on a text search for the title which leads to unexpected results. For example:

  1. Translate any article from Spanish to Catalan
  2. Clear the initial automatic translation and write "cama" ("cama" means "leg" in Catalan and "bed" in spanish).
  3. Select the text and observe that two articles are shown in link cards.
  4. Open both articles and for each article go to the English version.
  5. Observe that you get two different articles ("Bed" and "leg") which should not be the case.

Screenshot below:

The expected behaviour would be to see "pierna" (leg in Spanish) as source link and "cama" (leg in Catalan) as target link.

Related issues

  • This may be also the cause of another issue: when selecting text in the target area the source link card is not shown despite an article existing. I imagine that looking for title match instead of equivalence is the root of the problem.
  • Note that the behaviour of selecting an existing link on the translation area seems to also work inconsistently since the source link card is only shown if the link exist on the equivalent source paragraph.

Details

Related Gerrit Patches:
mediawiki/extensions/ContentTranslation : masterLink Adaptation: Adapt links if no corresponding link found

Event Timeline

Pginer-WMF raised the priority of this task from to Needs Triage.
Pginer-WMF updated the task description. (Show Details)
Pginer-WMF edited projects, added LE-Sprint-81; removed LE-Sprint-80.
Pginer-WMF set Security to None.
santhosh moved this task from Backlog to Done on the LE-Sprint-81 board.Jan 9 2015, 2:11 PM
santhosh moved this task from Done to Backlog on the LE-Sprint-81 board.
Amire80 triaged this task as High priority.Jan 15 2015, 8:54 AM
Arrbee added a subscriber: Arrbee.
gerritbot added a subscriber: gerritbot.

Change 188703 had a related patch set uploaded (by Jsahleen):
Link Adaptation: Adapt links if no corresponding link found

https://gerrit.wikimedia.org/r/188703

Patch-For-Review

Jsahleen moved this task from Backlog to In Review on the LE-Sprint-82 board.Feb 4 2015, 11:57 PM

Change 188703 merged by jenkins-bot:
Link Adaptation: Adapt links if no corresponding link found

https://gerrit.wikimedia.org/r/188703

santhosh moved this task from In Review to Done on the LE-Sprint-82 board.
Lydia_Pintscher moved this task from incoming to monitoring on the Wikidata board.Feb 9 2015, 10:05 AM
Arrbee closed this task as Resolved.Feb 11 2015, 3:06 PM
Pginer-WMF edited a custom field.Feb 24 2015, 2:26 PM