Page MenuHomePhabricator

Mistake in Create Account does not generate error message
Closed, ResolvedPublic

Description

At http://en.m.wikipedia.beta.wmflabs.org click Create Account

enter a user name, a password, and a confirm-password that does not match the password. Click 'Sign up'

User should see an error message but does not.

Behavior is the same when entering the CAPTCHA, although that should not be necessary.

This is the failure at https://integration.wikimedia.org/ci/view/BrowserTests/view/-All/job/browsertests-MobileFrontend-en.m.wikipedia.beta.wmflabs.org-linux-chrome-sauce/436/testReport/(root)/Create%20failure%20messages/Create_account_password_mismatch_message/

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : wmf/1.25wmf13Hygiene: Only omit warning messages on LoginForm
mediawiki/extensions/MobileFrontend : wmf/1.25wmf14Hygiene: Only omit warning messages on LoginForm
mediawiki/extensions/MobileFrontend : masterHygiene: Only omit warning messages on LoginForm

Event Timeline

Cmcmahon raised the priority of this task from to Needs Triage.
Cmcmahon updated the task description. (Show Details)
Cmcmahon added a subscriber: Cmcmahon.

I'm not able to reproduce this locally. I see an error message.

I can replicate this on beta labs stable...

Florian claimed this task.Jan 7 2015, 11:11 PM

Yes, can replicate locally and on beta labs :/

Argghhh, i know why.

Change 183389 had a related patch set uploaded (by Florianschmidtwelzow):
Hygiene: Only omit warning messages on LoginForm

https://gerrit.wikimedia.org/r/183389

Patch-For-Review

Change 183396 had a related patch set uploaded (by Florianschmidtwelzow):
Hygiene: Only omit warning messages on LoginForm

https://gerrit.wikimedia.org/r/183396

Patch-For-Review

Change 183389 merged by jenkins-bot:
Hygiene: Only omit warning messages on LoginForm

https://gerrit.wikimedia.org/r/183389

Jdlrobson closed this task as Resolved.Jan 7 2015, 11:47 PM

Change 184388 had a related patch set uploaded (by Kaldari):
Hygiene: Only omit warning messages on LoginForm

https://gerrit.wikimedia.org/r/184388

Patch-For-Review

Change 183396 merged by jenkins-bot:
Hygiene: Only omit warning messages on LoginForm

https://gerrit.wikimedia.org/r/183396

Change 184388 merged by jenkins-bot:
Hygiene: Only omit warning messages on LoginForm

https://gerrit.wikimedia.org/r/184388