Page MenuHomePhabricator

Kill all "original_"- fields
Open, MediumPublic1 Estimated Story Points

Description

This turns out to be a really confusing naming convention. Instead, we’ll use “gross” and “currency” for normal stuff, and when we actually know the settlement currency and amount, that will be sent in new fields “settlement_gross”, etc.

https://gerrit.wikimedia.org/r/164390

https://gerrit.wikimedia.org/r/164393

https://gerrit.wikimedia.org/r/164394

Also need:

  • CRM patch to warn at deprecated “original_” usage in queue messages
  • Followon: Implement “settlement_” fields where we know settlement details.

Event Timeline

atgo assigned this task to awight.
atgo raised the priority of this task from to Medium.
atgo updated the task description. (Show Details)
atgo added a subscriber: atgo.
atgo edited a custom field.
awight updated the task description. (Show Details)
awight updated the task description. (Show Details)
Ejegg added a subscriber: Ejegg.

Looks like we got 'em all!

You totally got my hopes up, only to dash them against the rocks of the crm repo... Seems like we might be using the code in PaymentsListeners/paypal as well?

awight removed awight as the assignee of this task.Feb 7 2016, 1:24 AM
Reedy renamed this task from Owner to Kill all "original_"- fields.Apr 2 2017, 4:32 PM
Reedy removed Cholof13 as the assignee of this task.
Reedy updated the task description. (Show Details)
Reedy edited subscribers, added: Ejegg, Liuxinyu970226, awight; removed: Cholof13.