Page MenuHomePhabricator

Reviewing pages in dewiktionary via API fails with "'flag_accuracy' parameter missing from query." despite sending the flag_accuracy parameter.
Closed, ResolvedPublic

Details

Related Gerrit Patches:
mediawiki/extensions/FlaggedRevs : wmf/1.25wmf14API: Fix action=review for binary flagging
mediawiki/extensions/FlaggedRevs : masterAPI: Fix action=review for binary flagging

Event Timeline

Giftpflanze raised the priority of this task from to Needs Triage.
Giftpflanze updated the task description. (Show Details)
Giftpflanze added a subscriber: Giftpflanze.

Steps to reproduce / testcase welcome (pasting the query and the error results)

Ok, this is stupid, but here you go:
https://de.wiktionary.org/w/api.php?action=review&revid=4021885&token=redacted&flag_accuracy=1
{"servedby":"mw1204","error":{"code":"missingflag","info":"'flag_accuracy' parameter missing from query.","*":"See https://de.wiktionary.org/w/api.php for API usage"}}

Schnark added a subscriber: Schnark.Jan 9 2015, 8:46 AM

https://de.wiktionary.org/w/api.php?action=help&modules=review doesn't even know a "flag_accuracy" parameter, only in the example.

TTO added subscribers: demon, TTO.Jan 9 2015, 9:16 AM

Evidently caused by 4cf8187fe6bac0b089c70612ef4ab4d3179d99cd. @Chad, could you have a look at this?

My guess is that if ( !FlaggedRevs::binaryFlagging() ) should have been put around that code, but it's only a guess.

TTO triaged this task as High priority.Jan 9 2015, 9:51 AM
demon added a comment.Jan 9 2015, 2:25 PM

Maybe? I really was grasping at straws with that patch as it was unclear why the error was occurring to begin with.

TTO added a comment.Jan 13 2015, 12:46 AM

Now causing issues on enwiki with Twinkle, see WT:TW. Any chance of reverting that patch until a fix can be found?

In T86258#972570, @TTO wrote:

Now causing issues on enwiki with Twinkle, see WT:TW. Any chance of reverting that patch until a fix can be found?

Link is https://en.wikipedia.org/wiki/Wikipedia_talk:Twinkle#Issue.3F and says:

When reviewing pending changes and reverting I sometimes get "Automatically accepting your changes: 'flag_status' parameter missing from query.",

gerritbot added a subscriber: gerritbot.

Change 184916 had a related patch set uploaded (by Anomie):
API: Fix action=review for binary flagging

https://gerrit.wikimedia.org/r/184916

Patch-For-Review

Change 184916 merged by jenkins-bot:
API: Fix action=review for binary flagging

https://gerrit.wikimedia.org/r/184916

Anomie closed this task as Resolved.Jan 14 2015, 6:32 PM
Anomie claimed this task.
Anomie added a subscriber: Anomie.

This should be deployed to phase 0 wikis with 1.25wmf15 in a few hours, and I've scheduled it for SWAT tomorrow morning.

Change 185180 had a related patch set uploaded (by Anomie):
API: Fix action=review for binary flagging

https://gerrit.wikimedia.org/r/185180

Patch-For-Review

Change 185180 merged by jenkins-bot:
API: Fix action=review for binary flagging

https://gerrit.wikimedia.org/r/185180

This should be fixed on all WMF wikis now.