Page MenuHomePhabricator

Jenkins tests fail
Closed, ResolvedPublic

Description

See for example https://integration.wikimedia.org/ci/job/mwext-Math-testextension-zend/5/console

ResourcesTest::testMissingDependencies
The module 'ext.visualEditor.mwcore' required by 'ext.math.visualEditor' must exist
Failed asserting that an array contains 'ext.visualEditor.mwcore'.

/srv/ssd/jenkins-slave/workspace/mwext-Math-testextension-zend/src/tests/phpunit/structure/ResourcesTest.php:74
/srv/ssd/jenkins-slave/workspace/mwext-Math-testextension-zend/src/tests/phpunit/MediaWikiTestCase.php:141
ResourcesTest::testUnsatisfiableDependencies
Undefined index: ext.visualEditor.mwcore

/srv/ssd/jenkins-slave/workspace/mwext-Math-testextension-zend/src/tests/phpunit/structure/ResourcesTest.php:94
/srv/ssd/jenkins-slave/workspace/mwext-Math-testextension-zend/src/tests/phpunit/MediaWikiTestCase.php:141

Both fixed by https://gerrit.wikimedia.org/r/#/c/183864/

There are a few more MathCoverageTest::testCoverage failing though.

for example

MathCoverageTest::testCoverage with data set #12 ('\\hat{a}, \\widehat{a}, \\vec{a} \\!', '<img class="mwe-math-fallback-image-inline tex" alt="\\hat{a}, \\widehat{a}, \\vec{a} \\!" src="eaededf26bb201c699ef1597902383c3.png" />')
Failed to render \hat{a}, \widehat{a}, \vec{a} \!
Failed asserting that two strings are equal.
--- Expected
+++ Actual
@@ @@
-'<img class="mwe-math-fallback-image-inline tex" alt="\hat{a}, \widehat{a}, \vec{a} \!" src="eaededf26bb201c699ef1597902383c3.png" />'
+'<img class="mwe-math-fallback-image-inline tex" alt="\hat{a}, \widehat{a}, \vec{a} \!" src="731677a388ba08f520ebe91623dab74a.png" />'

/srv/ssd/jenkins-slave/workspace/mwext-Math-testextension-zend/src/extensions/Math/tests/MathCoverageTest.php:75
/srv/ssd/jenkins-slave/workspace/mwext-Math-testextension-zend/src/tests/phpunit/MediaWikiTestCase.php:141

It seems, that the visual impression of the renderd expression is unchanged. But some minor difference seems to have caused a change of the hash value.

Details

Related Gerrit Patches:
mediawiki/extensions/Math : masterUpdate MathParser tests
mediawiki/vagrant : masterAdd dependency to texlive-generic-extra
integration/config : masterMath depends on VisualEditor

Event Timeline

Physikerwelt raised the priority of this task from to High.
Physikerwelt updated the task description. (Show Details)
Physikerwelt added projects: Math, Jenkins.
Physikerwelt added subscribers: Physikerwelt, hashar.
hashar updated the task description. (Show Details)Jan 9 2015, 4:04 PM
hashar set Security to None.

The tests fails because Math depends on the VisualEditor extension. Will amend the Jenkins job.

Change 183864 had a related patch set uploaded (by Hashar):
Math depends on VisualEditor

https://gerrit.wikimedia.org/r/183864

Patch-For-Review

hashar updated the task description. (Show Details)Jan 9 2015, 4:14 PM

The structure tests are fixed by https://gerrit.wikimedia.org/r/#/c/183864/

There are a few more MathCoverageTest::testCoverage failing though. Example:

MathCoverageTest::testCoverage with data set #12 ('\\hat{a}, \\widehat{a}, \\vec{a} \\!', '<img class="mwe-math-fallback-image-inline tex" alt="\\hat{a}, \\widehat{a}, \\vec{a} \\!" src="eaededf26bb201c699ef1597902383c3.png" />')
Failed to render \hat{a}, \widehat{a}, \vec{a} \!
Failed asserting that two strings are equal.
--- Expected
+++ Actual
@@ @@
-'<img class="mwe-math-fallback-image-inline tex" alt="\hat{a}, \widehat{a}, \vec{a} \!" src="eaededf26bb201c699ef1597902383c3.png" />'
+'<img class="mwe-math-fallback-image-inline tex" alt="\hat{a}, \widehat{a}, \vec{a} \!" src="731677a388ba08f520ebe91623dab74a.png" />'

/srv/ssd/jenkins-slave/workspace/mwext-Math-testextension-zend/src/extensions/Math/tests/MathCoverageTest.php:75
/srv/ssd/jenkins-slave/workspace/mwext-Math-testextension-zend/src/tests/phpunit/MediaWikiTestCase.php:141

I have no idea where this comes from. The onlything I realized that it affects overscripts. Those commands seem to orginate from standard amsmath

Change 183864 merged by jenkins-bot:
Math depends on VisualEditor

https://gerrit.wikimedia.org/r/183864

Physikerwelt moved this task from Incoming to Doing on the Math board.Jan 10 2015, 9:33 AM

I could not reproduce that on vagrant up to now. It would be intersting to see if 731677a388ba08f520ebe91623dab74a.png looks like $\hat{a}, \widehat{a}, \vec{a} $

Finally I managed to reproduce the problem (I had to create new labs-instance... I could not reprodiuce that on the old ubutu12 instance)
The new images look all right to me
see for example
http://math.testme.wmflabs.org/images/math/7/3/1/731677a388ba08f520ebe91623dab74a.png

Change 184123 had a related patch set uploaded (by Physikerwelt):
Add dependency to texlive-generic-extra

https://gerrit.wikimedia.org/r/184123

Patch-For-Review

Change 184124 had a related patch set uploaded (by Physikerwelt):
Update MathParser tests

https://gerrit.wikimedia.org/r/184124

Patch-For-Review

Physikerwelt moved this task from Doing to Blocked: needs help on the Math board.Jan 10 2015, 2:54 PM

Change 184123 merged by jenkins-bot:
Add dependency to texlive-generic-extra

https://gerrit.wikimedia.org/r/184123

Now, since we have merged the vagrant part, it should be easy for everyone to reproduce the problem and verify the fix.

Physikerwelt raised the priority of this task from High to Needs Triage.Jan 13 2015, 6:15 PM
Physikerwelt updated the task description. (Show Details)

Change 184124 merged by jenkins-bot:
Update MathParser tests

https://gerrit.wikimedia.org/r/184124

Jdforrester-WMF closed this task as Resolved.Jan 13 2015, 7:17 PM
Jdforrester-WMF claimed this task.

Now fixed?