Page MenuHomePhabricator

Remove font choices from REL1_24, REL1_25 and REL1_26 branch while the implementation is unstable
Closed, DeclinedPublic

Description

Sadly, we're still in the same situation as at the time of T65942: Remove font choices from REL1_23 branch while the implementation is unstable. The move away from "sans-serif" causes severe regressions for at least some locales: we know of T65817: Provide a workaround to IE's bug that causes the generic "serif" rendered broken, T65827: Explore better Korean default fonts, T65843: Times New Roman font appearing unintentionally on he.wp (as Georgia font has no support for Hebrew).

The change was taken out of 1.23 but not 1.24; only few wikis have upgraded to 1.24.x (12 Japanese wikis out of hundreds are on 1.24.0 or 1.24.1 according to WikiApiary), so we're still on time for

  • restoring "sans-serif" to allow safe upgrade for the other hundreds wikis; and
  • correcting the release notes noting the open regressions caused by the other changes.

Event Timeline

Nemo_bis created this task.Jan 9 2015, 9:17 PM
Nemo_bis raised the priority of this task from to Normal.
Nemo_bis updated the task description. (Show Details)
Nemo_bis added subscribers: Qgil, Quiddity, He7d3r and 11 others.

Has anybody tried just compiling the list of languages/scripts where the new fonts don't work, and simply disabling the fonts for them? Because that would be a much better solution than continuing to revert this change in successive release branches.

(From the technical side, that can be trivially done using the :lang() selector, supported on all browsers other than IE<6: http://caniuse.com/#feat=css-sel2. We already use this technique to disable link underlines in some languages.)

Legoktm set Security to None.
matmarex changed the task status from Open to Stalled.Feb 5 2015, 11:29 PM
Nemo_bis added a subscriber: demon.Apr 3 2015, 8:02 PM

Has anybody tried just compiling the list of languages/scripts where the new fonts don't work, and simply disabling the fonts for them?

Well, that wasn't done because no language testing was ever done in the first place for this font change. Can't we instead whitelist the languages which have been verified to work?
As a start, we could blacklist all non-Latin script languages.

This patch might be related: https://gerrit.wikimedia.org/r/#/c/200940/

matmarex removed a subscriber: matmarex.Apr 7 2015, 6:04 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

We're not getting this done in time for the MediaWiki 1.25.x tarballs. It's not a regression from the releases in the 1.24.x series, so, pulling from there too.

Change 216028 had a related patch set uploaded (by Isarra):
Make headers use the same fonts as the rest of the content

https://gerrit.wikimedia.org/r/216028

Language testing was done for this typography update in 2012

Please see this page where we were recording issues for non latin scripts:

https://www.mediawiki.org/wiki/Typography_refresh/Non-Latin_scripts
The old type size in non-Latin scripts was 0.8em (12.8px). This squashes glyphs and superscripts significantly along with the type being too small to read.
Scripts examined were Urdu, Marathi, Bahasa Melayu, Chinese, Korean, and Navajo. The body copy type size increase will improve readability for most scripts. Specifically for Navajo, an override will be provided because character pairs render strangely in Helvetica.

Inline CSS guidance can be provided to ensure that languages make overrides on a case-by-case basis as needed. Please reach us/comment on the Talk page if you primarily use a non-Latin script and encounter significant problems. We want to get this list together.

demon removed a subscriber: demon.Aug 19 2015, 3:54 PM
Nemo_bis renamed this task from Remove font choices from REL1_24 and REL1_25 branch while the implementation is unstable to Remove font choices from REL1_24, REL1_25 and REL1_26 branch while the implementation is unstable.Nov 3 2015, 7:34 AM

It would be nice to have a release that I'm not ashamed of promoting to non-English users. 1.23 is LTS but it's getting old.

Catrope removed a subscriber: Catrope.Nov 13 2015, 7:49 PM
Isarra moved this task from Backlog to Typography on the Vector board.Apr 7 2016, 1:11 AM
Verdy_p updated the task description. (Show Details)Oct 7 2016, 9:48 PM
Verdy_p updated the task description. (Show Details)Oct 7 2016, 10:03 PM
Qgil removed a subscriber: Qgil.Oct 10 2016, 12:27 PM

Change 216028 abandoned by Isarra:
Make headers use the same fonts as the rest of the content

https://gerrit.wikimedia.org/r/216028

Patch provided at https://gerrit.wikimedia.org/r/#/c/217707/ and released in 1.28.10 https://phabricator.wikimedia.org/diffusion/SVEC/browse/wmf%252F1.28.0-wmf.10/ featuring generic font-family: sans-serif specifically for Korean, Hebrew and Japanese fixed this issue stated in the task description.
If there's any language mistakenly left behind please reopen and comment or preferably file a new task.

Volker_E closed this task as Invalid.Oct 27 2016, 8:29 PM
Volker_E changed the task status from Invalid to Declined.
Volker_E removed a project: Patch-For-Review.
Volker_E added a project: UI-Standardization.

featuring generic font-family: sans-serif specifically for Korean, Hebrew and Japanese fixed this issue stated in the task description.

Does not seem so to me.