Page MenuHomePhabricator

patrol.py only accepts canonical names in the whitelist
Closed, ResolvedPublic

Description

patrol.py only accepts the English canonical name 'special:prefixindex' in its whitelist format.

Event Timeline

jayvdb created this task.Jan 11 2015, 3:02 AM
jayvdb raised the priority of this task from to Needs Triage.
jayvdb updated the task description. (Show Details)
jayvdb added a project: Pywikibot-Scripts.
jayvdb added a subscriber: jayvdb.
jayvdb moved this task from Backlog to Needs Review on the Pywikibot board.
jayvdb added a subscriber: XZise.

After the switch from mwlib to mwparserfromhell, this might even be fixed by @XZise in 0c8150f3. If not, it is an good first task fix.

where patrol.py file can be found?

Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptFeb 29 2016, 9:29 PM

https://www.mediawiki.org/wiki/Manual:Pywikibot/Scripts is where it is explained.

It is available as an up-to-date tool on toollabs if you have an account

I didn't quite understand the problem.
Do we want to add more namespaces to the whitelist, i..e, more of the following branches with different indices?

if obj.namespace == -1:

Or do we want translations of special:prefixindex?

@darthbhyrava the English syntax in the whitelist is ...

  • [[User:Tom Morris]] : [[Special:Prefixindex/Page:The Yellow Book|Page:The Yellow Book*]]

I presume that the local language versions of Special:Prefixindex do not work, and that is the adaptation desired

@darthbhyrava the English syntax in the whitelist is ...

  • [[User:Tom Morris]] : [[Special:Prefixindex/Page:The Yellow Book|Page:The Yellow Book*]]

I presume that the local language versions of Special:Prefixindex do not work, and that is the adaptation desired

Look at
https://gu.wikisource.org/w/api.php?action=query&meta=allmessages
and you will something like

...

{
    "name": "prefixindex",
    "normalizedname": "prefixindex",
    "*": "\u0aaa\u0ac2\u0ab0\u0acd\u0ab5\u0abe\u0a95\u0acd\u0ab7\u0ab0 \u0ab8\u0ac2\u0a9a\u0abf"
},
{
    "name": "prefixindex-namespace",
    "normalizedname": "prefixindex-namespace",
    "*": "\u0ab6\u0ab0\u0ac2\u0a86\u0aa4\u0aae\u0abe\u0a82 ($1 namespace) \u0aa7\u0ab0\u0abe\u0ab5\u0aa4\u0abe \u0aaa\u0abe\u0aa8\u0abe\u0a82"
}

...

@Billinghurst, I still don't think I get the issue. :/
If the problem is about the local language versions of Special:PrefixIndex, then there is a contradiction on Multilingual Mediawiki - where under the 'Rationale' section, it is clearly mentioned that:

MediaWiki also does not support:

  • Indeed, operating any special page across a set of languages.

If the above is true, then is implementing the translation still an good first task task? Could you clarify this one last time, please?
@jayvdb

@darthbhyrava I am explaining the phabricator request as I understand it. I am not commenting on its alignment with anything, nor advocating that is a requirement.

where patrol.py file can be found?

@NeerajBattan if you're still willing to take this up, patrol.py is found under scripts/ in pywikibot-core
Check this or the corresponding github mirror.

MtDu added a subscriber: MtDu.Jul 22 2016, 12:45 PM

Just to understand the problem. Going back to the page Billinghurst linked, is the problem that not all of https://dpaste.de/ooOC#L2,7,12,17,22 highlighted lines are accepted? Is the only one that is accepted now L2? If so, does this just require a regular expression fix? If not, please explain what the problem is to me.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptJul 22 2016, 12:45 PM

If you put the local language version of "Special:PrefixIndex" it is my understanding that it fails to work, and only the English version as shown works.

XZise added a comment.Jul 22 2016, 5:00 PM

I think it is fixed by my patch which is merged as 0c8150f, but I don't know why it isn't closed. Maybe it needs to be verified (and for me it has been to long to remember how much I actually tested it).

Xqt closed this task as Resolved.May 14 2018, 11:24 AM
Xqt claimed this task.
Xqt triaged this task as Low priority.
Xqt added a subscriber: Xqt.

Guess this is fixed, isn’t it?