Page MenuHomePhabricator

InvalidArgumentException from line 34 of PageEntityUsages.php: $pageId must be an integer > 0
Closed, ResolvedPublic

Description

/rpc/RunJobs.php?wiki=glwiki&type=ChangeNotification&maxtime=60&maxmem=300M InvalidArgumentException from line 34 of /srv/mediawiki/php-1.25wmf14/extensions/Wikidata/extensions/Wikibase/client/includes/Usage/PageEntityUsages.php: $pageId must be an integer > 0
#0 /srv/mediawiki/php-1.25wmf14/extensions/Wikidata/extensions/Wikibase/client/includes/Changes/AffectedPagesFinder.php(327): Wikibase\Client\Usage\PageEntityUsages->__construct()
#1 /srv/mediawiki/php-1.25wmf14/extensions/Wikidata/extensions/Wikibase/client/includes/Changes/AffectedPagesFinder.php(188): Wikibase\Client\Changes\AffectedPagesFinder->makeVirtualUsages()
#2 /srv/mediawiki/php-1.25wmf14/extensions/Wikidata/extensions/Wikibase/client/includes/Changes/AffectedPagesFinder.php(114): Wikibase\Client\Changes\AffectedPagesFinder->getAffectedPages()
#3 /srv/mediawiki/php-1.25wmf14/extensions/Wikidata/extensions/Wikibase/client/includes/Changes/ChangeHandler.php(167): Wikibase\Client\Changes\AffectedPagesFinder->getAffectedUsagesByPage()
#4 /srv/mediawiki/php-1.25wmf14/extensions/Wikidata/extensions/Wikibase/client/includes/Changes/ChangeHandler.php(142): Wikibase\Client\Changes\ChangeHandler->handleChange()
#5 /srv/mediawiki/php-1.25wmf14/extensions/Wikidata/extensions/Wikibase/lib/includes/ChangeNotificationJob.php(133): Wikibase\Client\Changes\ChangeHandler->handleChanges()
#6 /srv/mediawiki/php-1.25wmf14/includes/jobqueue/JobRunner.php(136): Wikibase\ChangeNotificationJob->run()
#7 /srv/mediawiki/rpc/RunJobs.php(42): JobRunner->run()

Event Timeline

aude created this task.Jan 14 2015, 8:51 PM
aude raised the priority of this task from to Needs Triage.
aude updated the task description. (Show Details)
aude added a subscriber: aude.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 14 2015, 8:51 PM
gerritbot added a subscriber: gerritbot.

Change 184996 had a related patch set uploaded (by Aude):
Handle Article ID of 0 in AffectedPagesFinder

https://gerrit.wikimedia.org/r/184996

Patch-For-Review

aude added a comment.Jan 14 2015, 9:02 PM

this can happen if either:

  1. page in the client has already been deleted when the job is run
  2. if the page is a special page (special pages can be site links in the repo)

seems consistent with the frequency of exception log entries, and is okay (imho) to skip these usages since no reason to try to parse these...

Change 185192 had a related patch set uploaded (by Aude):
Add regression tests for "$pageId must be an integer > 0" bug

https://gerrit.wikimedia.org/r/185192

Patch-For-Review

Change 185192 abandoned by Aude:
Add regression tests for "$pageId must be an integer > 0" bug

Reason:
squashed into https://gerrit.wikimedia.org/r/#/c/184996/

https://gerrit.wikimedia.org/r/185192

Change 184996 merged by jenkins-bot:
Handle Article ID of 0 in AffectedPagesFinder and usage lookup

https://gerrit.wikimedia.org/r/184996

Change 185448 had a related patch set uploaded (by JanZerebecki):
Handle Article ID of 0 in AffectedPagesFinder and usage lookup

https://gerrit.wikimedia.org/r/185448

Patch-For-Review

Tobi_WMDE_SW closed this task as Resolved.Jan 19 2015, 1:56 PM
Tobi_WMDE_SW claimed this task.

Change 185448 merged by jenkins-bot:
Handle Article ID of 0 in AffectedPagesFinder and usage lookup

https://gerrit.wikimedia.org/r/185448