Page MenuHomePhabricator

Editor's onSaveComplete handler is broken (edit is saved but the user isn't redirected to it)
Closed, ResolvedPublic

Description

Cuased by: https://gerrit.wikimedia.org/r/#/c/184280/

Steps to reproduce:

  1. Open a page (no matter if stable/beta/alpha or if the page already exist)
  2. Click edit pencil
  3. Type in some text and click next
  4. Click save

Expected: You see a "Save, please wait" message and a spinner and you will be redirected to the page after the edit was saved
Observed: The edit is saved correctly, but the user hangs in the "Save, please wait" screen and get's no info that the page was saved or what he has to do now

Error in console:
Uncaught TypeError: Cannot read property 'always' of undefined
https://github.com/wikimedia/mediawiki-extensions-MobileFrontend/blob/master/javascripts/modules/editor/EditorOverlayBase.js#L166

The problem is not branched in a wmf version actually. It will be in 1.25wmf16, so let's fix it before that and we save a SWAT :D

Event Timeline

Florian created this task.Jan 15 2015, 5:52 PM
Florian raised the priority of this task from to Needs Triage.
Florian updated the task description. (Show Details)
Florian added a project: Readers-Web-Backlog.
Florian added subscribers: Florian, Jdlrobson, ori.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 15 2015, 5:52 PM
Florian triaged this task as High priority.Jan 15 2015, 5:53 PM
gerritbot added a subscriber: gerritbot.

Change 185211 had a related patch set uploaded (by Florianschmidtwelzow):
Revert "Don't return a value from Schema.log"

https://gerrit.wikimedia.org/r/185211

Patch-For-Review

Change 185211 merged by jenkins-bot:
Revert "Don't return a value from Schema.log"

https://gerrit.wikimedia.org/r/185211

Jdlrobson closed this task as Resolved.Jan 16 2015, 6:31 PM
Jdlrobson claimed this task.