Page MenuHomePhabricator

Cannot download image file from WM Phabricator in Chrome: 403 File Link has Expired
Closed, ResolvedPublic

Description

Tried with F29217 in Chrome 39 / Ubuntu:

  • click in the image
  • click on the download link
  • press Ctrl-S
  • I get a 403 with "File Link Has Expired"

Apparently Phabricator uses some weird one-time-link scheme. Google Chrome, for whatever reasons, tries to redownload the file when I tell it to save to the disk, instead of just saving the already displayed image. (I suspected "disable cache" option in devtools which can cause similar issues, but it is off.)

The installation at secure.phabricator.com behaves saner in multipleaspects:

  • file links are not one-time (compare middle-clicking this image and reloading with doing the same for https://secure.phabricator.com/T6964 )
  • clicking on the "Download" button actually downloads the file, while on the WMF instance it just opens it. The download link has ?download=1 in both cases, so I suspect this is a webserver configuration issue.

Both instances set a past Expires header on the file, which is probably the "whatever reason" mentioned above.

Event Timeline

Tgr created this task.Jan 17 2015, 1:40 AM
Tgr raised the priority of this task from to Needs Triage.
Tgr updated the task description. (Show Details)
Tgr added a subscriber: Tgr.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 17 2015, 1:40 AM
Tgr updated the task description. (Show Details)Jan 17 2015, 1:42 AM
Tgr set Security to None.
Tgr added a comment.Jan 17 2015, 1:45 AM

You can right-click--save-as on the thumbnail, but that's not very intuitive.

Aklapper triaged this task as Low priority.Jan 18 2015, 11:36 PM

Confirming in Chrome 39 in my normal-user account with two images in WM instance and that the upstream instance does not expose this behavior. No problems in Firefox 35.
Wondering if related to our Security extension. Somehow(TM). Maybe not.

Aklapper renamed this task from Cannot download original file from Phabricator to Cannot download image file from WM Phabricator in Chrome: 403 File Link has Expired.Jan 18 2015, 11:37 PM
Gilles added a subscriber: Gilles.Feb 19 2015, 8:26 AM

Related upstream: "Paranoid file URL security mode causes nearly universal performance problems" in https://secure.phabricator.com/T10262

Restricted Application added subscribers: Luke081515, scfc. · View Herald TranscriptFeb 9 2016, 10:01 PM

I think this has been fixed.

It now dosent keep showing that error and instead updates it transparently. Was fixed in the recent upgrade to phabricator.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptApr 28 2016, 12:20 PM
Paladox closed this task as Resolved.EditedMay 5 2016, 9:41 PM
Paladox claimed this task.

Closing as resolved since I followed your steps and could not reproduce what you got. This problem was in the older phabricator version but when we upgraded last week caching got some improvements, like it no longer pops up an error asking you to regenerate the link, it now does in transparently.

So this is fixed now :)

Please reopen if I am wrong.