Page MenuHomePhabricator

Many errors on Russian Wikinews due to HotCat gadget
Closed, InvalidPublic

Description

As far as I understand last week you changed the code of the Russian Wikinews.

We have compiled a list of the most notable errors. (link).

Последнее изменение этой страницы: 13:55, 23 августа 2014.<br /> <a href="http://stats.grok.se/ru.n/latest/%D0%97%D0%B0%D0%B3%D0%BB%D0%B0%D0%B2%D0%BD%D0%B0%D1%8F_%D1%81%D1%82%D1%80%D0%B0%D0%BD%D0%B8%D1%86%D0%B0">Посмотреть статистику посещений</a> данной страницы
  1. String in the bottom of all pages (see title) isn't formatted properly. (see above)
  2. Cannot hide an advert at the top of the page (id="siteNotice").
  3. If I click on preliminary view, panel quick access (id="userSummaryButtonsA"; [[MediaWiki:Editpage.js]]) and panel tools edit (class="wikiEditor-ui-top") will disappear.
  4. Tab comments (namespace "Комментарии:") aren't in general articles (main namespace) and discussions (talk namespace). Example (at the top).
  5. Pages of comments (namespace "Комментарии:") haven't tabs on general articles (main namespace) and discussions (talk namespace). Example (at the top).
  6. The search doesn't navigate to the target page (example).
  7. Block "Other projects" (id='p-wikibase-otherprojects') must locate before the block "Other languages" (id='p-lang'). Example.
  8. Upd: the Notifications Popup problem in n:ru. (see discussion below)

Fix it, please, and be careful when changing in the future.

Please create projects "Wikinews" and "Russian Wikinews" for Phabricator.

Event Timeline

Krassotkin raised the priority of this task from to High.
Krassotkin updated the task description. (Show Details)
Krassotkin added a subscriber: Krassotkin.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 21 2015, 4:31 PM
Krassotkin updated the task description. (Show Details)Jan 21 2015, 4:36 PM
Krassotkin set Security to None.
Umherirrender added a subscriber: Umherirrender.EditedJan 21 2015, 6:03 PM

Point 1 is T86702

Other points sounds like broken (local) javascript, have a look in the error console of your browser and try to fix.

One possible fix for Internet Explorer: Remove section "фикс горизонтальной прокрутки в IE6" from https://ru.wikinews.org/wiki/MediaWiki:Common.js, because there will be no longer javascript executed for IE6

Krenair added a subscriber: Krenair.EditedJan 21 2015, 8:57 PM
  • Code changes happen to all WMF sites all the time. Some happen on the server and (usually) get logged in the Server Admin Log on wikitech, some happen on-wiki and get logged there instead.
  • Please don't try to use wikitext syntax on Phabricator, it won't work.
  • One task for many issues like this is likely not okay.
  • #2 - you should not be hiding the siteNotice, if you opened a task for that it'd be declined/invalid.
  • #7 - this works for me...
  • #3, #4, #5 and #6 are unclear.
  • See T802 for the projects you suggested.

This is my first ticket here. Thank you for your recommendation. I will follow them in the future.

Please be more specific. I need to open a ticket elsewhere to fix it?

We have combined these bugs, because they emerged from the same wrong correction last week (series of edits). Probably there is easier roll back all of them.

#2 This applies to a user who wants to hide this ad.

Krenair added a comment.EditedJan 21 2015, 9:43 PM

Please be more specific. I need to open a ticket elsewhere to fix it?

It's not fully clear what software is to blame for the issues some users have experienced right now.

We have combined these bugs, because they emerged from the same wrong correction last week (series of edits). Probably there is easier roll back all of them.

Okay, then we'll need to know what edits you refer to.

#2 This applies to a user who wants to hide this ad.

So they have some custom user JS that broke? Yeah I suspect there was some general local JS breakage here, that would cause such things.

ssr added a subscriber: ssr.Jan 22 2015, 12:23 PM
ssr added a comment.Jan 22 2015, 12:32 PM

These errors, that appeared recently and suddenly, have significant negative impact on the everyday life of our project, the Russian Wikinews, which I am an administrator in.

Generally, we are not IT specialists, but civil journalists, and are very concerned now. But it's quite hard for us to get properly through these troubles with code.

I suggest that we start with the most noticeable and annoying issue: the ugly horizontal scrollbar caused by broken very long link popped out of HTML in the page bottom. What caused it, and which exact piece of our local code should we edit to get rid of it?

I can't see these issues when looking at ru.wikinews.org (I don't doubt that you see them, However, I can't do anything about them unless I also see them)

For item 1: I can't see that string on the page, neither in a formatted version or in an unformatted version. I do not have any long horizontal scroll bar.

item 2: skipping that one per Kreniar. Do you mean their is some gadget that is broken?

item 3: Not sure if I understand your meaning correctly, but edit page has all the appropriate buttons for me

item 4: comments tab appears fine for me

Item 5: tabs appear fine for me

item 6: That url doesn't go to the page, but I don't think its supposed to. If I type google into the search bar, it goes directly to the page (On monobook, you have to press "go" not "search"). If I go to the url https://ru.wikinews.org/w/index.php?search=Google&title=Служебная%3AПоиск in goes directly to the page.

Item 7: other projects appear before languages for me.


Do these issues appear for you if you are logged out as an anonoymous user? Do you have any gadgets enabled (And if so, can you determine by disabling them one by one if a specific gadget is causing this)? Do you have any custom javascript on your Special:MyPage/common.js , Special:MyPage/monobook.js or Special:MyPage/vector.js ?

ssr added a comment.EditedJan 22 2015, 1:16 PM

Here is a screenshot for the bug #1 in Incognito mode (anonymous/unlogged in) of Chromium:


This is for the page https://ru.wikinews.org/wiki/Запретить_Википедию_предложили_в_Рособрнадзоре — you can clearly see horizontal scrollbar and the long encoded link text that caused it (page's bottom). The length of the defunct link depends on size of page's title coded in Cyrillic Unicode.

(P. S. Hmm, I see Phabricator fails to display the bottom of the screenshot...)

Glaisher updated the task description. (Show Details)Jan 22 2015, 4:18 PM
Aklapper changed the task status from Open to Stalled.EditedJan 22 2015, 5:03 PM

Item 1: The <div> element footer-info-lastmod shows raw HTML at the bottom here in Firefox 35 and being logged in, but Firefox 35 at least does proper linebreaks for me.


In general to track down issues that are likely JavaScript problems, please open the developer tools of your browser and reload the page (with ?debug=true added to the URL, or &debug=true if the URL already contains a ? symbol) that you see the problem on. If there is a problem or an error with JavaScript it will be printed there. (It can be also extremely to disable local gadgets and see if the problem still happens.)
For more information about developer tools / browser console please see:

ssr added a comment.Jan 22 2015, 5:30 PM

The one extra issue, that may be related to all others, is the problem with "Notifications" popup. When I press "Your notifications" "0" link next to my username at top-right menu, I don't get a popup window, like in other projects, but get generally redirected to the page "Special:Notifications" ("Служебная:Уведомления" in Russian).

ssr added a comment.EditedJan 22 2015, 6:39 PM

In debug mode in Chromium, when viewing footer-info-lastmod, I see no errors and see such properties (truncated):

innerHTML: " Последнее изменение этой страницы: 13:40, 22 января 2015.&lt;br /&gt;↵&lt;a href="http://sta
innerText: "Последнее изменение этой страницы: 13:40, 22 января 2015.<br /> <a href="http://stats.grok.s

outerHTML: "<li id="footer-info-lastmod"> Последнее изменение этой страницы: 13:40, 22 января 2015.&lt;br /&gt;↵&lt;a href="http://stats.grok
outerText: "Последнее изменение этой страницы: 13:40, 22 января 2015.<br /> <a href="http://stats.grok.se

textContent: " Последнее изменение этой страницы: 13:40, 22 января 2015.<br />↵<a href="http://stats.gro

Remove html from https://ru.wikinews.org/wiki/MediaWiki:Lastmodifiedat or delete the whole page to fix (or workaround) item 1

ssr added a comment.Jan 22 2015, 8:32 PM

Thank you, blanking this page seemed to work for now for item 1!

Krassotkin added a comment.EditedJan 23 2015, 6:56 AM

#4 & #5 (tab comments - "комментарии" in russian)

all three tabs should be visible from each
screenshot (https://ru.wikinews.org/w/?curid=58513; vector; firefox, chrome; fedora):

I see the third tab on that page, both when logged in and logged out. Does anybody other than you have this issue? Can you try disabling the gadgets and user scripts you have enabled one-by-one until it reappears?

Krassotkin added a comment.EditedJan 23 2015, 7:23 AM

I see three tabs only if I disconnect simultaneously all the gadgets of editing (https://ru.wikinews.org/wiki/MediaWiki:Gadgets-definition). But it is no good.

ssr added a comment.Jan 23 2015, 10:21 AM

Yes I, like Krassotkin, only see 3 tabs in different browsers when logged out. And, like him, see 2 tabs (incorrect) when logged in:


Yes this is no good as we use these tabs (and, likely, some related tools) in everyday editing. They worked previously.

ssr added a comment.Jan 23 2015, 11:09 AM
  1. I decided to add Item 8: the Notifications Popup problem in n:ru. Here is the screenshot explaining it:
Krassotkin updated the task description. (Show Details)Jan 23 2015, 1:02 PM

To #2 demo: I cannot hide (close) ad.

TTO added a subscriber: TTO.Jan 23 2015, 1:22 PM

Looks like a broken gadget or JS.

I can't test this with my main account, as my username This, that and the other is blacklisted on ruwikinews:

<Запрещено использовать имя участника «This, that and the other». Имя соответствует следующей записи из чёрного списка: .*([\w\d]+([\s-_]+[\w\d]+){3,}).* <newaccountonly> # 4+ words>

However, I logged in with an alternative account, and discovered that the problem is probably with the HotCat gadget. It looks like your copy of HotCat is severely out-of-date.

I'll leave it to others to inform ruwikinews admins how to update HotCat. In the meantime, you can disable HotCat in your preferences and most of the problems should go away. Tell us if any problems persist after turning off HotCat.

ssr added a comment.Jan 23 2015, 1:27 PM

Yes! Turning off HotCat seem to have fixed tabs and notifications problem as far as I can see! Thank you!

In T87337#990982, @TTO wrote:

...

the problem is probably with the HotCat gadget. It looks like your copy of HotCat is severely out-of-date.

@TTO: Thank you very much!

I updated HotCat (https://ru.wikinews.org/w/index.php?diff=347380&oldid=284362) and all error have disappeared.

I also increased the number of words in the name (test it please).

Let this branch will be open for a while yet others can check out it.

Aklapper renamed this task from Many errors after updating interface of Russian Wikinews to Many errors on Russian Wikinews due to HotCat gadget.Jan 23 2015, 7:30 PM
Aklapper closed this task as Invalid.
Aklapper claimed this task.

Closing as INVALID because the changeto fix this is outside the power of the component's developers - it has to be done on-wiki in the gadget.