MediaWiki needs technical leadership
Closed, ResolvedPublic

Description

MediaWiki needs technical ledership that people can rely on to direct the development of MediaWiki.

  • There is no team assigned to core development. From the outside, it seems that the assumption is that core will somehow magically improve without coordination. I don't think this is the case
  • ArchCom and the RfC process are currently not set up to fill that gap. Both the RfC process and ArchCom's decisions happen very early, before implementation of a feature acutally starts.
  • Things like slipping a completely new authentication mechanism into MW 1.27 happen without coordination and predictable roadmap. In this specific case, this will cause a lot of self installed MediaWikis to break.
MarkAHershberger updated the task description. (Show Details)
MarkAHershberger raised the priority of this task from to Needs Triage.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 27 2015, 5:37 PM

What projects is this supposed to be in?

What projects is this supposed to be in?

Good question. I've added one.

Is the expectation that someone from the mwcore team will take on this role?

greg added a comment.Jan 27 2015, 6:24 PM

I think this isn't a given, at least without defining all of the terms ("Product" "Manager" and "MediaWiki").

This is conflating a few different things.

  1. Release management
  2. Arch design/decisions
  3. PM for a team doing work (eg MWCore will have a PM soon, for their work only)

For 1), I/my team will be doing that. Please come to me/us with suggestions and ideas (I got a few from today's session at the Summit).

For 2) That's something that we need leadership in the technical direction of MW (including answering the SOA discussion that is still on-going)

For 3) That role will only periphly deal with MW as a released thing for third-parties (non-WMF). A PM for MWCore team will work on things described on the page at: https://www.mediawiki.org/wiki/Wikimedia_Engineering/2014-15_Goals#MediaWiki_Core

I think the real answer is real leadership in the future of MW as a released thing; we don't really have that clarity yet.

greg set Security to None.

From how I've seen the role of PM, it is not something that MW Core team would take on. But I could be completely wrong. The issue is just that, as Mark Bergsma has pointed out, no one is charged with directing MW development.

greg added a comment.Jan 27 2015, 6:25 PM

(s/MWCoreTeam/MWCore/ as this isn't inherently owned by those people and it's conflating a few things)

In T87655#996289, @greg wrote:

For 3) That role will only periphly deal with MW as a released thing for third-parties (non-WMF).

My point is that MW for third parties needs a product manager. This person should be independent of the Greg's team.

greg added a comment.Jan 27 2015, 6:33 PM
In T87655#996289, @greg wrote:

For 3) That role will only periphly deal with MW as a released thing for third-parties (non-WMF).

My point is that MW for third parties needs a product manager. This person should be independent of the Greg's team.

That's a big ask given that we still have many teams at WMF that don't yet have PMs who really want/need them.

Bluntly, I think this is the wrong solution at this time. A PM isn't the right answer; we need technical leadership.

In T87655#996338, @greg wrote:

That's a big ask given that we still have many teams at WMF that don't yet have PMs who really want/need them.

Well, I don't think there's any requirement that the PM needs to come from the WMF.

Bluntly, I think this is the wrong solution at this time. A PM isn't the right answer; we need technical leadership.

This.

Technical leadership is a prerequisite for this, absolutely agreed. Right now MW looks like an open field with no real direction. Is there an open phabricator task for this?

Should I just rename this task to "MW needs technical leadership" since I seem to have gotten confused on what is needed?

There is a future of the ArchCom session later today and the numerous wikitech-l threads.

There is a future of the ArchCom session later today and the numerous wikitech-l threads.

And I'm trying to synthesize the discussion. Relying on "numerous wikitech-l threads" just exacerbates the problem of "No technical leadership".

MarkAHershberger renamed this task from Create product manager role for MediaWiki to MediaWiki needs technical leadership.Jan 27 2015, 6:49 PM
MarkAHershberger updated the task description. (Show Details)
brion added a subscriber: brion.Jan 27 2015, 7:12 PM
greg added a comment.Jan 27 2015, 7:19 PM

See also: Future of the Arch Committee: T87605

brion added a comment.Jan 27 2015, 7:42 PM

Hopefully we'll get some good discussion in the archcom session -- I'm still in 'listen and ponder issues' mode so not making a lot of pronouncements yet. :)

Waiting for outcome of ArchCom session to be shared in T87605 / T87470.
Does this ticket depend on those ones?

Also not sure about criteria here when this task can be considered fixed? Someone please clarify (OT?).

Aklapper writes:

Waiting for outcome of ArchCom session to be shared in https://phabricator.wikimedia.org/T87605 / https://phabricator.wikimedia.org/T87470.
Does this ticket depend on those ones?

I would say so.

Also not sure about criteria here when this task can be considered fixed? Someone please clarify (OT?).

Depending on the outcome of ArchCom, this could be considered a tracking
bug. If it there is a better way to do that in Phabricator, then we
should use that.

The bottom line is that this is an ongoing issue that was really made
apparent at the recent Developer Summit. One action isn't going to fix
the problem.

Aklapper triaged this task as Low priority.Mar 21 2015, 9:44 PM

So this has been open for a year-ish now. What do the participants think?

I don't know about the other participants, but I was disappointed when I heard the Director of Architecture say, at the Developer Summit this year, that everyone should just "do the right thing" instead of providing actual direction. I fear that is the culture around MW: every dev does what he feels is best. Which means we end up with many different great ideas, but no cohesive structure.

I see the introduction of SOA as an excuse for this. Instead of providing good standards, we'll just provide tell people to build services however they want.

RobLa-WMF closed this task as Invalid.Jun 30 2016, 3:16 AM
RobLa-WMF added a subscriber: RobLa-WMF.

A Phab task is not the place to track the author's opinion about whether people can rely on the leadership of MediaWiki development

@RobLa-WMF I'm just a subscriber here, but was hoping the author's question would be addressed in some capacity. If not a phab task, then where can interested users of MediaWiki go to better understand the leadership of MediaWiki development?

Another possible approach. Maybe this task is a bit of an EPIC. :) Are there blockers to an answer? Could we create subtasks to help organize what needs to be done? Some examples off the top of my head.

  • the WMF needs a CTO
  • WMF leadership (not sure who) with input from the communites needs to decide if MediaWiki is part of the mission or purely a byproduct
  • a plan needs to be drafted to carry out a long-term strategy for MediaWiki
Mglaser added a comment.EditedJun 30 2016, 2:42 PM

@RobLa-WMF Closing this task is fine with me, but it doesn't resolve the issues related. Here are some key points:

  • There is no team assigned to core development. From the outside, it seems that the assumption is that core will somehow magically improve without coordination. I don't think this is the case
  • ArchCom and the RfC process are currently not set up to fill that gap. Both the RfC process and ArchCom's decisions happen very early, before implementation of a feature acutally starts.
  • Things like slipping a completely new authentication mechanism into MW 1.27 happen without coordination and predictable roadmap. In this specific case, this will cause a lot of self installed MediaWikis to break.

Having said that, I recognize there is some effort going into core, see for example the overhaul of the watchlist. It's just that people in the world of self installed MediaWikis need some predictability. I think the stakeholders can help in the communication about MW development, but how do we get the info without having to search all commits which go into core (maybe that is a subject for a phab task)?

As of @Ckoerner, where would be a good place to ask or track this question?

Also, I think calling this just a single author's opinion seems to be belittling the issue related.

MarkAHershberger reopened this task as Open.Jun 30 2016, 3:48 PM
MarkAHershberger updated the task description. (Show Details)

@RobLa-WMF was right: The task was poorly written. I've updated it with @Mglaser's points to give it better clarity.

Danny_B added a subscriber: Danny_B.Jul 1 2016, 8:34 PM

@MarkAHershberger needs some tag again, please...

Restricted Application added a project: Notice. · View Herald TranscriptJul 2 2016, 3:19 PM
saper added a subscriber: saper.Aug 5 2016, 12:17 AM
Krinkle moved this task from Inbox to Backlog on the Architecture board.Mar 29 2017, 8:52 PM
daniel closed this task as Resolved.Wed, Jan 3, 9:38 PM
daniel claimed this task.
daniel added a subscriber: daniel.

resolved with the creation of the platform team

Krinkle reopened this task as Open.Wed, Jan 3, 9:38 PM
Krinkle removed daniel as the assignee of this task.
Krinkle removed projects: Roadmap, Architecture, Notice.
Krinkle closed this task as Resolved.
Krinkle assigned this task to daniel.