Page MenuHomePhabricator

Allow local file upload to all users on mr.wikipedia until June 07, 2015
Closed, ResolvedPublic

Description

request from mr wikipedia

Hi, Seasons Greetings

Seasons Greetings, at https://mr.wikipedia.org/wiki/%E0%A4%AE%E0%A4%BF%E0%A4%A1%E0%A4%BF%E0%A4%AF%E0%A4%BE%E0%A4%B5%E0%A4%BF%E0%A4%95%E0%A5%80_%E0%A4%9A%E0%A4%B0%E0%A5%8D%E0%A4%9A%E0%A4%BE:Licenses we had a brief discussion in july 2014 and decided to suspend local media file uploading for non sysops for a while to bring in awareness and desciplene on file licencing and copyright issues. While those issues are still not completelely sorted out still there we find a need to be flexible and allow file uploading to all from 21st Jan to 7th june; the reason being jan to may month has lot of important days and celebrations regarding Marathi language and May month is school holiday season off line marathi students tend to visit Marathi Wikipedia and upload phographs for photothon . it is emotional connect and some specialy developed android apps are tuned to marthi wikipedia.

Request is being made vide Local discussion page at https://mr.wikipedia.org/wiki/%E0%A4%AE%E0%A4%BF%E0%A4%A1%E0%A4%BF%E0%A4%AF%E0%A4%BE%E0%A4%B5%E0%A4%BF%E0%A4%95%E0%A5%80_%E0%A4%9A%E0%A4%B0%E0%A5%8D%E0%A4%9A%E0%A4%BE:Licenses

So local community wishes we allow local uploading from 21 jan to 7th june.

Already there is a delay in making this request since I am not used to Phabricator usage, please do the needful at your earliest
rgds

Event Timeline

Mahitgar created this task.Jan 28 2015, 3:41 PM
Mahitgar raised the priority of this task from to High.
Mahitgar updated the task description. (Show Details)
Mahitgar added a subscriber: Mahitgar.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 28 2015, 3:41 PM
Aklapper renamed this task from local file upload to be allowd to all users at mr Wikipedia from 21 Jan to 7 June to Allow local file upload to all users on mr.wikipedia until June 07, 2015.Jan 28 2015, 7:56 PM
Aklapper lowered the priority of this task from High to Normal.
Aklapper updated the task description. (Show Details)
Aklapper set Security to None.

Please make the local file upload option available on MR Wikipedia at earliest. If you want any thing to be done from community side please update at earliest.

Thanks - Rahul

Nemo_bis updated the task description. (Show Details)Feb 7 2015, 1:29 PM

Again, speaking personally: I understand there is consensus, but not on what.

If the aim is to let people use those upload apps, can I have a list of the apps? I'd like to fix them myself.

As for whether a temporary permission change like that is possible, I let others in the Site requests project speak.

We could simply enable uploads now and revert it later on ~7th June.

Yes I also think it should be open immediately first. As Marathi Wikipedia conducts “Photothon” a week long activity around Marathi Language Day ie. on 27th Feb every year. This is 4th year it is going to happen where in the local community is very active, so as an admin on Marathi Wikipedia I will like to make it available from immediate effect.
Thanks - Rahul

Glaisher' suggession " We could simply enable uploads now and revert it later on ~7th June." would be ok for us. If we fail to revert in june need not be a big fuss. Awareness is a issue local community can and need to handle in many different ways.

Feb is an important month for Marathi community 21st Feb is international mother tongue day and 27th feb is Marathi language day. I wish this gets sorted out at the earliest.

harish added a subscriber: harish.Feb 16 2015, 7:13 AM

I guess enabling local upload for the the duration of event could be temp solution and also reverting it back after event to wiki commans is any time possible.

Every year we run a photothon event, we start a photothon event when number of images are 3000+, in Marathi Wikipedia, but now Marathi Wikipedia have 13000+ images.
https://mr.wikipedia.org/wiki/%E0%A4%B5%E0%A4%BF%E0%A4%B6%E0%A5%87%E0%A4%B7:%E0%A4%B8%E0%A4%BE%E0%A4%82%E0%A4%96%E0%A5%8D%E0%A4%AF%E0%A4%BF%E0%A4%95%E0%A5%80

it was old activity in Marathi Wikipedia. This year we already announced photothon2015 event, in Bengali Wikipedia 10th Anniversary Celebration Conference, kolkata

https://www.flickr.com/photos/cherishsantosh/15645765553/in/set-72157647928566494
https://www.flickr.com/photos/cherishsantosh/16079801407/in/set-72157647928566494

If local file upload option link is not open then we have close this event, because we are not able to upload images on Marathi Wikipedia, and mobile application is not working because of link.

looking forward for a positive response

Cherishsantosh raised the priority of this task from Normal to High.Feb 21 2015, 5:38 AM

Glaisher' suggession " We could simply enable uploads now and revert it later on ~7th June." would be ok for us. If we fail to revert in june need not be a big fuss.

So we need someone to go ahead with this, and this is getting a bit more urgent now. CC'ing some folks.

This is a good activity and should be continued.

I have e-mailed @Eloquence and @damons about this with a request to assign someone to this bug today.

Eloquence added a subscriber: greg.Feb 24 2015, 6:57 PM

@greg should be able to help shepherd.

tomasz added a subscriber: tomasz.Feb 24 2015, 9:17 PM

I am happy to work on this (ie. submit a config patch and close this task) if people can wait till morning UTC time.

greg added a comment.Feb 24 2015, 9:28 PM

I am happy to work on this (ie. submit a config patch and close this task) if people can wait till morning UTC time.

patch would be nice, thanks tomasz. Feel free to add to the next available SWAT (you can put my name next to it in case you won't be there).

tomasz claimed this task.Feb 24 2015, 9:31 PM

@tomasz...
@greg....

Thank you for your initiative. It will be very helpful, if you could able to activate the link at the earliest.

-Ms. K. Selvarani

Change 192784 had a related patch set uploaded (by Odder):
Temporarily re-enable uploads on Marathi Wikipedia

https://gerrit.wikimedia.org/r/192784

Scheduled for deployment at around 16:00 UTC today.

Change 192784 merged by jenkins-bot:
Temporarily re-enable uploads on Marathi Wikipedia

https://gerrit.wikimedia.org/r/192784

tomasz closed this task as Resolved.Feb 25 2015, 4:11 PM

It seems uploads are now enabled; I could not test it because I'm not a member of the autoconfirmed user group, but Special:Upload answers with a permission error which suggests everything is OK.

You might want to add a link to Special:Upload to MediaWiki:Sidebar to easily point users there.

I can confirm that it works now (now able to see the normal MediaWiki upload interface there, previously it was a sysop permissions error).