Page MenuHomePhabricator

"Edit without login" button is hidden in editor cta
Closed, ResolvedPublic

Description

The button "Edit without login" has display:none; on the editor cta.

Steps to reproduce:

  1. Make sure you're in alpha or anonymous editing is enabled in your configuration
  2. Go to an editable page
  3. Click the edit pencil

Expected: You see a warning and 3 options (Edit without login, login and signup)
Observed: You don't see the edit without login button

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : masterDon't hide "edit without login" button on editor cta

Event Timeline

Florian created this task.Feb 2 2015, 8:41 AM
Florian claimed this task.
Florian raised the priority of this task from to Lowest.
Florian updated the task description. (Show Details)
Florian added a project: Readers-Web-Backlog.
Florian added a subscriber: Florian.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 2 2015, 8:41 AM
gerritbot added a subscriber: gerritbot.

Change 188043 had a related patch set uploaded (by Florianschmidtwelzow):
Don't hide "edit without login" button on editor cta

https://gerrit.wikimedia.org/r/188043

Patch-For-Review

Florian closed this task as Resolved.Feb 2 2015, 5:01 PM

Change 188043 merged by jenkins-bot:
Don't hide "edit without login" button on editor cta

https://gerrit.wikimedia.org/r/188043

Between 2015-01-29 and 2015-02-11 the only MobileFrontend SAL item I see is 19:27 logmsgbot: phuedx Synchronized php-1.25wmf15/extensions/MobileFrontend/: No-op deployment training (duration: 00m 06s). The bug and its fix were both in 1.25wmf16.

So the bug was never deployed, right?

phuedx added a subscriber: phuedx.Mar 5 2015, 10:33 AM

I've just very quickly verified the behaviour on http://en.wikipedia.org/wiki/Samurai?mobileaction=alpha – including checking that the change is present in the source for EditorOverlay.js.

The change will have gone out on the train since the last date you mentioned, right?

The change will have gone out on the train since the last date you mentioned, right?

I think so, unless I missed something.

phuedx set Security to None.