Page MenuHomePhabricator

[1 day] BUG: CN banner being shown after campaign end
Closed, ResolvedPublic

Description

For some reason, I'm still being served the Commons Picture of the Year banner even though that were set to end on 31st January.

FF & Chrome on Win 7x64.

Details

Related Gerrit Patches:
mediawiki/extensions/CentralNotice : masterSpecial:BannerLoader: test campaign staleness
mediawiki/extensions/CentralNotice : masterCheck choiceData for staleness

Event Timeline

KTC created this task.Feb 2 2015, 11:43 AM
KTC raised the priority of this task from to Needs Triage.
KTC updated the task description. (Show Details)
KTC added a subscriber: KTC.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 2 2015, 11:43 AM
Aklapper triaged this task as Medium priority.Feb 2 2015, 6:01 PM

@KTC is this still happening? How long did it persist?

KTC added a comment.Feb 27 2015, 12:14 PM

@atgo, can't tell because we have active banners scheduled displaying (until tomorrow) so I'm seeing those. I think I kept seeing the POTY banner until the steward vote / wikimania banner came online. Of course, I'm seeing the POTY banner again, but this time it's expected because it's currently R2 at the moment and it's been set to display for this last week.

Will have to wait and see if any either the stewvote or POTY banner stay after the 28th.

Thanks @KTC. Keep me posted here so we can track this... We haven't had any other reports. Maybe a caching issue?

KTC added a comment.Feb 27 2015, 8:40 PM

Entirely possible, but I wasn't the only one at the Wikimedia UK's office that saw the banner after it supposed to have ended.

Anyway, will let you know.

In T88276#1073227, @KTC wrote:

can't tell because we have active banners scheduled displaying (until tomorrow) [...] Will have to wait and see if any either the stewvote or POTY banner stay after the 28th.

@KTC: Any news here, now that ~one week has passed?

KTC added a comment.Mar 6 2015, 6:36 PM

Personally, I'm not seeing any banners I shouldn't, but as @Glaisher mentioned, I'm not unique in having encourtered this.

Also, when I encourtered this before, there were no banner scheduled to display. At the moment, there's the ongoing 2015 WMF Strategy Consultation campaign that started before Stewvote & POTY_2014_R2 finished, and more recently there's Inspire that's running till the end of the month. I suspect it's less (if not completely cease) of a problem when there's active campaign running.

Errr, I thought I already said this was cache problem, clear it and you'll be fine. I think we can close this one.

KTC added a comment.Mar 12 2015, 10:45 PM

Whose cache? The user's, the ISP's, Wikimedia server's? Multiple users have experienced this, so even if it's the users computers, should look at whether there's anything that can be done server side to reduce/eliminate this.

Yes, seeing banners after several days of its finishing time is an issue. The cache needs to be invalidated directly by the extension itself.

atgo renamed this task from CN banner being shown after campaign end to BUG: CN banner being shown after campaign end.Mar 18 2015, 9:35 PM
atgo set Security to None.
atgo renamed this task from BUG: CN banner being shown after campaign end to [1 day] BUG: CN banner being shown after campaign end.Mar 18 2015, 11:20 PM

Change 201349 had a related patch set uploaded (by AndyRussG):
Check choiceData for staleness

https://gerrit.wikimedia.org/r/201349

Hi everyone! Here's where we're at with this:

  • While we can't reproduce the bug at this time, it's probably due to Javascript modules being cached longer than they should somewhere between WMF servers and users. We do have a known case of this general problem (see T89258) and campaign/banner options are indeed sent to the browser as JS modules. Also, the server-side code that produces these options is straightforward. If the problem isn't misbehaving intermediate caches, then maybe it's a larger JS caching issue on the cluster, or some caching issue related specifically to the campaign/banner choice data... but I'd bet it's the first one.
  • The patch for review is simple and covers any of the above cases: it just checks the dates of the campaign options sent from the server, and if somehow we're receiving stale data, it aborts the whole banner display process.
  • A future improvement would be to log when something like this happens. I've noted this TODO here.

Thanks!!

Change 201349 merged by jenkins-bot:
Check choiceData for staleness

https://gerrit.wikimedia.org/r/201349

Change 204390 had a related patch set uploaded (by AndyRussG):
Special:BannerLoader: test campaign staleness

https://gerrit.wikimedia.org/r/204390

Again, since we can't presently reproduce this bug, it's hard to know where we stand. The second patch adds an additional check for campaign staleness server-side when a banner is requested. This is better than the first patch because users who are getting old versions of campaign choices JSON might never get the updated JS code in the first patch that checks for that.

Anyhoo, I'd suggest we close this bug after both those patches are deployed, and just re-open it if we get more reports of old campaigns displaying banners

Change 204390 merged by Awight:
Special:BannerLoader: test campaign staleness

https://gerrit.wikimedia.org/r/204390

@AndyRussG did this go out already?

AndyRussG closed this task as Resolved.May 15 2015, 6:25 PM
AndyRussG moved this task from Pending Deployment to Done on the Fundraising Sprint Kraftwerk board.

@atgo yep! Sorry for the delay :)