Page MenuHomePhabricator

wikidata-rdf wrong format.
Closed, DeclinedPublic

Description

In wikidata-simple-statements triple files, there's triples such as "http://www.wikidata.org/entity/Q4318 http://www.wikidata.org/entity/P569c "-400"^^http://www.w3.org/2001/XMLSchema#gYear . ", which is wrong format. unable to parse by any rdf parser.

The -400 is wrong format, must be "-0400" for BCE Time. In addition, according to XMLS format, '-0002' of 3 BCE, and I am not sure whether wikidata noticed this. Maybe some conflicts happened.

Event Timeline

W013ccw created this task.Feb 5 2015, 8:21 PM
W013ccw raised the priority of this task from to Lowest.
W013ccw updated the task description. (Show Details)
W013ccw added a subscriber: W013ccw.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 5 2015, 8:21 PM

Is this about the RDF dump provided by Markus Krötzsch?

Yes, this refers to the Wikidata Toolkit RDF exports. I have created an issue now: https://github.com/Wikidata/Wikidata-Toolkit/issues/128 As it turns out, the error is actually caused by the code that treats the year-0 issue (which we of course are well aware of). Should be easy to fix as part of our upcoming RDF improvements. Note that negative dates before -9999 may still confuse some RDF tools.

Pro tip: use descriptive titles whe reporting bugs ;-)

Lydia_Pintscher closed this task as Declined.Mar 16 2015, 3:06 PM
Lydia_Pintscher claimed this task.

Thanks Markus. I am closing the ticket here then. No need to keep them both around.