Page MenuHomePhabricator

create a gerrit project / git repo for the contents of the annualreport
Closed, ResolvedPublic

Description

please create a gerrit project / git repo to put the source of annual.wikimedia.org in (HTML, CSS, JS..), so we don't have to deploy from tarballs anymore in the future

Event Timeline

Dzahn raised the priority of this task from to Needs Triage.
Dzahn updated the task description. (Show Details)
Dzahn added a subscriber: Dzahn.

@Dzahn: As far as I know, to request a repository, it is still required to use https://www.mediawiki.org/wiki/Git/New_repositories/Requests , or has that changed?
If it has changed, that wikipage needs updating.

I am completely unlikely and unwilling to go through the process of getting a new key and access to git repots.

I am more than willing to provide the source for someone else to do so, however.

This sounds excellent for many reasons.

@Jorm if it's fine with you i will just take the tarball and upload it as initial commit

@Dzahn: As far as I know, to request a repository, it is still required to use https://www.mediawiki.org/wiki/Git/New_repositories/Requests , or has that changed?

I don't know if that has changed but it seems odd to make me use wiki for certain requests while the same people doing it are here on phab all day.

[OT]

it seems odd to make me use wiki for certain requests while the same people doing it are here on phab all day

Feel free to create a task to move the request queue here if it seems odd. :)

Feel free to create a task to move the request queue here if it seems odd. :)

Fair. I would say that is a duplicate of T38269 then, so it's already handled. Thanks

Dzahn claimed this task.
Dzahn added a subscriber: QChris.
Dzahn closed this task as Resolved.
Dzahn reassigned this task from Dzahn to QChris.