Page MenuHomePhabricator

Q3. ToC placeholder makes most of the page blank when the screen is narrow -- in production (needs backport)
Closed, ResolvedPublic1 Story Points

Description

To reproduce:

  1. Go to https://he.wikipedia.org/wiki/%D7%A9%D7%99%D7%97%D7%AA_%D7%95%D7%99%D7%A7%D7%99%D7%A4%D7%93%D7%99%D7%94:%D7%96%D7%A8%D7%99%D7%9E%D7%94
  2. Resize your browser window and make it narrow. (Or just go to the link from your smartphone.)
  3. Scroll down.

Note that most of the screen is blank. Only a little bit of the conversation is seen at the bottom, and the topic title is seen at the top, and there's also the sidebar on the right.

Comments:

  • This happens in both Chrome and Firefox.
  • This happens with a narrow window, but with both the desktop and the mobile interface.
  • This doesn't happen in mediawiki.org, even if I use it with RTL UI. This still may have something to do with RTL, however, so I'm marking it as I18n and blocking T2745.

Event Timeline

Amire80 created this task.Feb 6 2015, 11:59 PM
Amire80 raised the priority of this task from to Needs Triage.
Amire80 updated the task description. (Show Details)
Amire80 added subscribers: Amire80, EBernhardson, DannyH.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 6 2015, 11:59 PM

Things to notice in the screenshot:

Quiddity triaged this task as High priority.Feb 7 2015, 2:26 AM
Quiddity added a subscriber: Quiddity.

It's happening at anything under 780px, when the responsive design changes to the next stage. (what's the technical term?).
It's Not a problem at LTR wikis.
It's something to do with the new ToC. (because, same size)

I'm now seeing this at the other group 2 wikis, too. e.g.
https://ca.wikipedia.org/wiki/Viquip%C3%A8dia_Discussi%C3%B3:Flow and
https://ca.m.wikipedia.org/wiki/Viquip%C3%A8dia_Discussi%C3%B3:Flow
But still not at mediawiki.org/beta.wmflabs.

Quiddity renamed this task from In Hebrew Wikipedia scrolling down a Flowified discussion page makes most of the page blank when the screen is narrow to ToC placeholder makes most of the page blank when the screen is narrow, at group 2 wikis.Feb 10 2015, 7:57 PM
Quiddity updated the task description. (Show Details)
DannyH renamed this task from ToC placeholder makes most of the page blank when the screen is narrow, at group 2 wikis to ToC placeholder makes most of the page blank when the screen is narrow -- in production (needs backport).Feb 11 2015, 7:13 PM
DannyH edited a custom field.
DannyH renamed this task from ToC placeholder makes most of the page blank when the screen is narrow -- in production (needs backport) to Q3. ToC placeholder makes most of the page blank when the screen is narrow -- in production (needs backport).Feb 11 2015, 9:35 PM

Does this still happen for anyone?
I can't seem to reproduce, on any of those links, in any of those browsers.

matthiasmullie closed this task as Resolved.Feb 19 2015, 6:35 PM
matthiasmullie claimed this task.

Seems to be resolved