Page MenuHomePhabricator

One stop translation search
Closed, InvalidPublic

Description

NOTE: current work in this area is tracked at T92929: Reinvent Translation Search.

A Special:SearchTranslations page has been created for the Translate extension to allow searching for translations. However it has not been finished and it lacks important features: in particular, being able to search in source language, but show and edit messages in your translation language. The interface has some bugs with facet selection and direct editing of search results is not working properly. It is not possible to search by message key unless you know the special syntax, nor to reach a message in one click. Interface designs are available for this page.

Example tasks to include in your project:

Project characteristics:

  • Primary mentor: @Nikerabbit
  • Co-mentor: @Nemo_bis
  • Other mentors: @Manybubbles (for the Elasticsearch part if needed)
  • Skills: Backend coding with PHP, frontend coding with jQuery, Solr/ElasticSearch/Lucene
  • Estimated project time for a senior contributor: 2-3 weeks

Suggested micro-task: submit a patch for one of the bugs linked above; then get it merged, or get an i18n bug fixed (see the lists of open tickets for interface messages that need rewording under "Blocked by" and open Language Engineering bugs); then feel free to contact the mentors about this project.

Event Timeline

Niharika raised the priority of this task from to Needs Triage.
Niharika updated the task description. (Show Details)
Niharika added a subscriber: Niharika.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 10 2015, 10:44 AM
Niharika updated the task description. (Show Details)Feb 10 2015, 10:56 AM
Niharika set Security to None.
Niharika updated the task description. (Show Details)
Nikerabbit triaged this task as Lowest priority.Feb 11 2015, 7:49 AM

I don't see a purpose for this tracking bug, it looks like unnecessary paperwork. I recommend to close as invalid and keep the description on wiki, as with most development projects.

Qgil added a subscriber: Qgil.Feb 11 2015, 10:01 AM

This was copied from https://www.mediawiki.org/w/index.php?title=Outreach_programs/Possible_projects&oldid=1404823#One_stop_translation_search

Seeing the amount of blockers, it doesn't look like a good GSoC 2015 project idea, right?

I just listed the bugs mentioned in the description and some others there. If this is misuse of blockers, they can be moved elsewhere.

Qgil added a comment.Feb 11 2015, 11:09 AM

Oops, sorry. You did right.

Qgil updated the task description. (Show Details)Feb 11 2015, 11:15 AM
Qgil added a subscriber: Manybubbles.

Are the mentors confirmed for the next round?

Qgil added a comment.Feb 11 2015, 1:44 PM

Wikimedia will apply to Google Summer of Code and Outreachy on Tuesday, February 17. If you want this task to become a featured project idea, please follow these instructions.

Nikerabbit triaged this task as Normal priority.Feb 28 2015, 11:38 AM
AYUSH added a subscriber: AYUSH.Mar 1 2015, 6:20 AM
Rits added a subscriber: Rits.Mar 4 2015, 6:23 PM
Nemo_bis added a comment.EditedMar 7 2015, 9:19 AM

AYUSH> Nemo_bis: i am facing problem in installing Special: search translation. It is showing "Couldn't connect to host, Elasticsearch down?".can you tell me what is the possible reason?

https://www.mediawiki.org/wiki/Help:Extension:Translate/Translation_memories is your starting point. Ask on talk page or MediaWiki-Internationalization when a step fails; phoenix303 has worked on ttmserver setup for some days now, so maybe she can help you as well if you join the channel. ;-)

Vikas_Sangle added a subscriber: Vikas_Sangle.EditedMar 10 2015, 2:15 PM

Hi,

I would like to work on this project as a part of GSOC 2015. I have development experience in PHP, javascript/jquery. Kindly guide me.

Thank you

Kindly guide me.

Thanks for your interest!

Please see https://www.mediawiki.org/wiki/Google_Summer_of_Code_2015 for general information and documentation. If you have specific questions related to this task, please explicitly ask them here. Thank you!

Please see https://www.mediawiki.org/wiki/Google_Summer_of_Code_2015 for general information and documentation. If you have specific questions related to this task, please explicitly ask them here. Thank you!

Thank you very much.

Hi. On searching anything on Special:SearchTranslations, it says 'The search service is temporarily unavailable.' However, in the Special:Versions page, it shows Elastica added as an extension
But on running ttmserver-export.php according to https://www.mediawiki.org/wiki/Help:Extension:Translate/Translation_memories , I get https://dpaste.de/HqoW. Can someone please guide me here?

@Ayushimrigen: Might be more of a general question about the development setup than about actually fixing this task ("One stop translation search")? Wherever this is brought up, the versions of CirrusSearch and Elasticsearch would be interesting too.

Nemo_bis updated the task description. (Show Details)Mar 17 2015, 9:17 AM

We're holding an IRC meeting on March 25, at 1700 UTC for prospective GSoC and Outreachy participants with Wikimedia, on #wikimedia-office channel. Do join us!

Hello! The IRC meeting tomorrow has been shifted to #wikimedia-ect channel. Looking forward to seeing you there. :)

Nemo_bis closed this task as Invalid.May 13 2015, 8:24 AM
Nemo_bis removed Phoenix303 as the assignee of this task.
Nemo_bis updated the task description. (Show Details)
Restricted Application added a project: Discovery. · View Herald TranscriptAug 25 2015, 10:47 AM