Page MenuHomePhabricator

Add "find text" function when editing
Closed, ResolvedPublic

Description

When editing (wikitext) in the Android app, it would be very useful to be able to find text in the box. This helps you navigate to the point you want to edit (particularly important in long sections).

Event Timeline

Mattflaschen-WMF updated the task description. (Show Details)
Mattflaschen-WMF raised the priority of this task from to Needs Triage.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 11 2015, 1:59 AM
Deskana triaged this task as Low priority.Feb 11 2015, 2:03 AM
Deskana added a subscriber: Deskana.

Great idea.

Readers are our priority this quarter so we can't prioritise this right now.

RHo closed this task as Resolved.Dec 31 2017, 5:06 AM
RHo claimed this task.
RHo added a subscriber: RHo.
This comment was removed by RHo.
RHo reopened this task as Open.Dec 31 2017, 5:07 AM
RHo renamed this task from Allow find in the edit box to Add "find text" function when editing.
RHo removed RHo as the assignee of this task.Apr 25 2018, 1:48 PM

Change 483890 had a related patch set uploaded (by Cooltey; owner: Cooltey):
[apps/android/wikipedia@master] [WIP] Add "find text" function when editing

https://gerrit.wikimedia.org/r/483890

Change 483890 merged by jenkins-bot:
[apps/android/wikipedia@master] Add "find text" function when editing

https://gerrit.wikimedia.org/r/483890

ABorbaWMF added a subscriber: ABorbaWMF.

LGTM on 2.7.269-alpha-2019-02-11

Sending to design for a quick look

Thanks for your work on this @cooltey. I did not find design specifications for this feature. However, there are two things to be optimized in regards to design consistency (2.7.269-alpha-2019-02-11).


01) I suggest to use the exact same UI from “Find in page“ in articles for this. There’s no need for a back button for “Find in page“ in Wikitext since going back is already covered by the close “X“

“Find in page" in Wikitextvs“Find in page“ in Article

02) Please use the exact same colors for “active result“ (orange: #FF9632) and “found“ (yellow: #FFFF00) as used in “Find in page“ in articles:


Exciting feature, looking forward to see it out there in the real world!

Change 490512 had a related patch set uploaded (by Cooltey; owner: Cooltey):
[apps/android/wikipedia@master] Tweak: Add "find text" function when editing

https://gerrit.wikimedia.org/r/490512

Thanks @schoenbaechler, the patch is waiting for review now, and will let you know after the patch got merged.

Just an FYI, in the updated "find in page" feature, when you pressing the arrows to find next or previous results, the "style" will be applied after 0.5 seconds, and that's our current default behavior of applying the syntax colors.

cmadeo added a subscriber: cmadeo.Feb 14 2019, 3:37 PM

Not sure if y'all want to consider this on Android but we'll be working on a 'Find and replace' update to 'Find in page' on iOS as it was requested in user testing with internal folks.

Change 490512 abandoned by Cooltey:
Tweak: Add "find text" function when editing

Reason:
moved to GitHub

https://gerrit.wikimedia.org/r/490512

@schoenbaechler The patch has been merged. Please download the latest version of the alpha app to check.

schoenbaechler added a comment.EditedFri, Mar 1, 10:19 AM

Looks great @cooltey, it works as designed. I have two suggestions that would make the current experience even better:

  • There’s currently a small delay when highlighting the active result from yellow to orange when navigating forward/back in page results. Is there a way to improve that and highlight it right away without the 0.5s delay? I used “Find in page“ within an article page and it feels more direct (as a reference).
  • Can we cache/store/keep the the search term when closing the “Find in page“ UI element as long as a user is within the same article in edit mode?

Moving the task to “Did not pass QA“ for now. Thanks for the feedback.

cooltey added a comment.EditedFri, Mar 1, 5:55 PM

Thanks, @schoenbaechler! Here are the responses:

  • There’s currently a small delay when highlighting the active result from yellow to orange when navigating forward/back in page results. Is there a way to improve that and highlight it right away without the 0.5s delay? I used “Find in page“ within an article page and it feels more direct (as a reference).

Found a simple solution of implementing this, will see if it works!

  • Can we cache/store/keep the the search term when closing the “Find in page“ UI element as long as a user is within the same article in edit mode?

Yes, will do that!

Thanks @cooltey, looking forward to what you’re coming up with!

Excellent, looks & works perfectly! Thanks @cooltey. Moving it to the “Ready for signoff“ column.

Dbrant closed this task as Resolved.Wed, Mar 6, 7:12 PM