Page MenuHomePhabricator

PHP Fatal error: MediaWiki requires the PSR-3 logging library</a> to be present, when running install.php
Closed, ResolvedPublic

Description

there sort of is useful error information but it is combined with a fatal error and stack trace and also tells me twice "Please see <a href="https://www.mediawiki.org/wiki/Download_from_Git#Fetch_external_libraries">mediawiki.org</a> "

also seems like this might be a known issue, but i can't find relevant existing task for it.

php maintenance/install.php --dbtype=sqlite --dbname mwsqlite TestWiki admin
MediaWiki requires the <a href="https://github.com/php-fig/log">PSR-3 logging library</a> to be present. This library is not embedded directly in MediaWiki's git repository and must be installed separately by the end user.

Please see <a href="https://www.mediawiki.org/wiki/Download_from_Git#Fetch_external_libraries">mediawiki.org</a> for help on installing the required components.PHP Fatal error: MediaWiki requires the <a href="https://github.com/php-fig/log">PSR-3 logging library</a> to be present. This library is not embedded directly in MediaWiki's git repository and must be installed separately by the end user.

Please see <a href="https://www.mediawiki.org/wiki/Download_from_Git#Fetch_external_libraries">mediawiki.org</a> for help on installing the required components. in /Library/WebServer/Documents/mediawiki/includes/debug/logger/Factory.php on line 101
PHP Stack trace:
PHP 1. {main}() /Library/WebServer/Documents/mediawiki/maintenance/install.php:0
PHP 2. require_once() /Library/WebServer/Documents/mediawiki/maintenance/install.php:158
PHP 3. require_once() /Library/WebServer/Documents/mediawiki/maintenance/doMaintenance.php:98
PHP 4. ExtensionRegistry::getInstance() /Library/WebServer/Documents/mediawiki/includes/Setup.php:39
PHP 5. ExtensionRegistry->__construct() /Library/WebServer/Documents/mediawiki/includes/registration/ExtensionRegistry.php:58
PHP 6. ObjectCache::newAccelerator() /Library/WebServer/Documents/mediawiki/includes/registration/ExtensionRegistry.php:65
PHP 7. ObjectCache::newFromId() /Library/WebServer/Documents/mediawiki/includes/objectcache/ObjectCache.php:146
PHP 8. ObjectCache::newFromParams() /Library/WebServer/Documents/mediawiki/includes/objectcache/ObjectCache.php:72
PHP 9. MWLoggerFactory::getInstance() /Library/WebServer/Documents/mediawiki/includes/objectcache/ObjectCache.php:89
PHP 10. trigger_error() /Library/WebServer/Documents/mediawiki/includes/debug/logger/Factory.php:101

Event Timeline

aude created this task.Feb 23 2015, 2:14 PM
aude raised the priority of this task from to Needs Triage.
aude updated the task description. (Show Details)
aude added a project: MediaWiki-Installer.
aude added a subscriber: aude.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 23 2015, 2:14 PM
aude set Security to None.Feb 23 2015, 2:14 PM
aude added subscribers: Legoktm, bd808.
devunt added a subscriber: devunt.Feb 24 2015, 5:53 AM

Have you installed the all external vendor libraries and kept it up-to-date?

Have you installed the all external vendor libraries and kept it up-to-date?

@aude: Could you answer devunt's question?

Aklapper changed the task status from Open to Stalled.Apr 17 2015, 6:27 PM

@aude: Could you answer devunt's question? (Please reset the task status to "open" after doing so.)

aude added a comment.Apr 17 2015, 7:14 PM

@devunt I know to run composer install, but the problem is the error information isn't very friendly and shouldn't come with a stack trace :)

@devunt I know to run composer install, but the problem is the error information isn't very friendly and shouldn't come with a stack trace :)

php maintenance/install.php --dbtype=sqlite --dbname mwsqlite TestWiki admin
MediaWiki requires the <a href="https://github.com/php-fig/log">PSR-3 logging library</a> to be present. This library is not embedded directly in MediaWiki's git repository and must be installed separately by the end user.
Please see <a href="https://www.mediawiki.org/wiki/Download_from_Git#Fetch_external_libraries">mediawiki.org</a> for help on installing the required components.

Is this message not friendly enough?

aude added a comment.Apr 17 2015, 7:36 PM

@devunt if the message was displayed once (instead of twice) with no stack trace, then it's okay. (somewhat strange to have html formatting, but not a big problem)

aude added a comment.Apr 17 2015, 7:37 PM

hmmm, now I just get "PHP Fatal error: Interface 'Psr\Log\LoggerAwareInterface' not found in /home/aude/src/core/includes/profiler/TransactionProfiler.php on line 35"

devunt changed the task status from Stalled to Open.Apr 17 2015, 7:46 PM

@aude Okay. That's a problem. Can you change the description and title of the issue to match with current circumstances?

Change 205001 had a related patch set uploaded (by Aude):
Check for dependencies in entry point and Maintenance.php

https://gerrit.wikimedia.org/r/205001

aude added a comment.Apr 18 2015, 9:59 AM

With my patch, I now get:

compared to with current master:

Change 205001 merged by jenkins-bot:
Check for dependencies in entry point and Maintenance.php

https://gerrit.wikimedia.org/r/205001

Change 212949 had a related patch set uploaded (by Chad):
Check for dependencies in entry point and Maintenance.php

https://gerrit.wikimedia.org/r/212949

Change 212949 merged by jenkins-bot:
Check for dependencies in entry point and Maintenance.php

https://gerrit.wikimedia.org/r/212949

aude closed this task as Resolved.Aug 13 2015, 1:13 PM
aude triaged this task as Medium priority.
aude removed a project: Patch-For-Review.