Page MenuHomePhabricator

Convert existing legacy phpcs jobs to use composer entry point + versioning
Closed, ResolvedPublic

Description

In the past the master branch of the codesniffer repo was deployed and run across extensions. This made making any changes extremely difficult as doing so would potentially cause extensions to fail. The following extensions need to be converted to use composer entry points:

They need to set an explicit version number in their composer.json (currently 0.4.0) so we can do releases and proper upgrades.

Related Objects

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Paladox updated the task description. (Show Details)Sep 27 2015, 8:15 PM
Paladox updated the task description. (Show Details)
hashar assigned this task to Paladox.Sep 27 2015, 9:04 PM
hashar added subscribers: Paladox, hashar.

Assigning this task to @Paladox since he is doing an excellent job at removing the legacy jobs and adding composer support to all those extensions. \O/

Change 236258 had a related patch set uploaded (by Paladox):
Update interwiki tests

https://gerrit.wikimedia.org/r/236258

Paladox updated the task description. (Show Details)Sep 28 2015, 5:08 PM

11 extensions left to convert to using composer for php code sniffing instead of phpcs test.

Change 241694 had a related patch set uploaded (by Paladox):
[UploadWizard] Add composer-test

https://gerrit.wikimedia.org/r/241694

Change 241692 had a related patch set uploaded (by Paladox):
[Translate] Add composer-test test

https://gerrit.wikimedia.org/r/241692

Change 240327 had a related patch set uploaded (by Paladox):
Add php parrallel lint to composer.json

https://gerrit.wikimedia.org/r/240327

Change 241713 had a related patch set uploaded (by Paladox):
Add support for running grunt in npm, Update i18n messages, Add phplint to composer.json

https://gerrit.wikimedia.org/r/241713

Change 241715 had a related patch set uploaded (by Paladox):
[Sentry] Add composer-test test

https://gerrit.wikimedia.org/r/241715

Change 241716 had a related patch set uploaded (by Paladox):
[Sentry] Remove phpcs test

https://gerrit.wikimedia.org/r/241716

Change 241726 had a related patch set uploaded (by Paladox):
[OnlineStatus] Add composer-test test

https://gerrit.wikimedia.org/r/241726

Change 241728 had a related patch set uploaded (by Paladox):
[OnlineStatus] Remove phpcs test

https://gerrit.wikimedia.org/r/241728

Change 241725 had a related patch set uploaded (by Paladox):
Add composer.json

https://gerrit.wikimedia.org/r/241725

Change 241737 had a related patch set uploaded (by Paladox):
[AutomaticBoardWelcome] Add composer-test test

https://gerrit.wikimedia.org/r/241737

Change 241738 had a related patch set uploaded (by Paladox):
[AutomaticBoardWelcome] Remove phpcs test

https://gerrit.wikimedia.org/r/241738

Change 241739 had a related patch set uploaded (by Paladox):
Add composer.json

https://gerrit.wikimedia.org/r/241739

Change 241713 merged by jenkins-bot:
Add support for running grunt in npm, Update i18n messages, Add phplint to composer.json

https://gerrit.wikimedia.org/r/241713

Change 241742 had a related patch set uploaded (by Paladox):
Add php code sniffer

https://gerrit.wikimedia.org/r/241742

Change 241737 merged by jenkins-bot:
[AutomaticBoardWelcome] Add composer-test test

https://gerrit.wikimedia.org/r/241737

Change 241726 merged by jenkins-bot:
[OnlineStatus] Add composer-test test

https://gerrit.wikimedia.org/r/241726

Change 241694 merged by jenkins-bot:
[UploadWizard] Add composer-test

https://gerrit.wikimedia.org/r/241694

Change 241739 merged by jenkins-bot:
Add composer.json

https://gerrit.wikimedia.org/r/241739

Change 241725 merged by jenkins-bot:
Add composer.json

https://gerrit.wikimedia.org/r/241725

Change 241715 merged by jenkins-bot:
[Sentry] Add composer-test test

https://gerrit.wikimedia.org/r/241715

Change 241716 merged by jenkins-bot:
[Sentry] Remove phpcs test

https://gerrit.wikimedia.org/r/241716

Change 241742 merged by jenkins-bot:
Add php code sniffer

https://gerrit.wikimedia.org/r/241742

Change 241692 abandoned by Hashar:
[Translate] Add composer-test test

Reason:
Duplicate of https://gerrit.wikimedia.org/r/#/c/240326/

https://gerrit.wikimedia.org/r/241692

Change 236258 merged by jenkins-bot:
Update interwiki tests

https://gerrit.wikimedia.org/r/236258

I will upload one more patch after all my patches to do with removing phpcs test are merged. This patch will include the full removal of phpcs test. Including its template since not needed.

@hashar should I do that now or wait until after all my patches are merged to do it quicker.

Lets wait for all of them to be merged / deployed and verified to be working. Then we will want to:

  • double check none are triggered anymore
  • delete them from Jenkins
  • cleanup the leftover workspaces

The patch should be trivial enough once all the cleanup has been done :-)

Should I upload a patch that remove all the phpcs test from phpcs template leaving the template to be removed in a follow-up patch.

Paladox updated the task description. (Show Details)Sep 30 2015, 8:17 PM

Change 241728 merged by jenkins-bot:
[OnlineStatus] Remove phpcs test

https://gerrit.wikimedia.org/r/241728

Paladox updated the task description. (Show Details)Oct 1 2015, 11:57 AM

Change 241738 merged by jenkins-bot:
[AutomaticBoardWelcome] Remove phpcs test

https://gerrit.wikimedia.org/r/241738

Paladox updated the task description. (Show Details)Oct 1 2015, 3:39 PM

Change 240327 abandoned by Paladox:
Add php parrallel lint to composer.json

Reason:
Siebrand uploaded one with the php code sniffer https://gerrit.wikimedia.org/r/#/c/243160/

https://gerrit.wikimedia.org/r/240327

Change 243160 had a related patch set uploaded (by Paladox):
Add/update tests

https://gerrit.wikimedia.org/r/243160

Change 243203 had a related patch set uploaded (by Paladox):
[TwnMainPage] Remove phpcs test, update tests

https://gerrit.wikimedia.org/r/243203

Change 243159 had a related patch set uploaded (by Paladox):
Add tests

https://gerrit.wikimedia.org/r/243159

Change 243209 had a related patch set uploaded (by Paladox):
[TranslationNotifications] Updat tests

https://gerrit.wikimedia.org/r/243209

Change 243208 had a related patch set uploaded (by Paladox):
Add php code sniffer, Add jshint and jscs to grunt

https://gerrit.wikimedia.org/r/243208

Change 243160 abandoned by Siebrand:
Add/update tests

Reason:
Lost interest

https://gerrit.wikimedia.org/r/243160

Change 243682 had a related patch set uploaded (by Paladox):
Add php code sniffer

https://gerrit.wikimedia.org/r/243682

From T66371: Deprecate global CodeSniffer rules repo

With https://gerrit.wikimedia.org/r/243917 I have deleted the three non voting jobs:

mwext-JSBreadCrumbs-phpcs-HEAD
mwext-UploadWizard-phpcs-HEAD
mwext-WhitelistPages-phpcs-HEAD

hashar updated the task description. (Show Details)Oct 6 2015, 12:02 PM

Change 243159 merged by jenkins-bot:
Add tests

https://gerrit.wikimedia.org/r/243159

Change 243203 merged by jenkins-bot:
[TwnMainPage] Remove phpcs test, update tests

https://gerrit.wikimedia.org/r/243203

Change 243682 merged by jenkins-bot:
Add php code sniffer

https://gerrit.wikimedia.org/r/243682

Paladox updated the task description. (Show Details)Nov 7 2015, 3:37 PM
Paladox updated the task description. (Show Details)
Paladox updated the task description. (Show Details)

Two more repos to do cldr and TranslationNotifications.

Translate just needs patch merged in integration/config.

Change 243209 merged by jenkins-bot:
[TranslationNotifications] Update tests

https://gerrit.wikimedia.org/r/243209

Change 254392 had a related patch set uploaded (by Hashar):
Run PHPCS from composer

https://gerrit.wikimedia.org/r/254392

Change 254392 merged by jenkins-bot:
Run PHPCS from composer

https://gerrit.wikimedia.org/r/254392

TranslationNotifications is done;

hashar updated the task description. (Show Details)Nov 20 2015, 1:57 PM

Change 254396 had a related patch set uploaded (by Hashar):
Run PHPCS from composer

https://gerrit.wikimedia.org/r/254396

hashar updated the task description. (Show Details)Nov 20 2015, 2:13 PM
hashar updated the task description. (Show Details)

Change 254396 merged by jenkins-bot:
Run PHPCS from composer

https://gerrit.wikimedia.org/r/254396

Change 254398 had a related patch set uploaded (by Hashar):
Remove legacy phpcs jobs and related config

https://gerrit.wikimedia.org/r/254398

Change 254400 had a related patch set uploaded (by Hashar):
Drop bin/run-phpcs-mw.sh

https://gerrit.wikimedia.org/r/254400

Change 254400 merged by jenkins-bot:
Drop bin/run-phpcs-mw.sh

https://gerrit.wikimedia.org/r/254400

I have deleted some old jobs from Jenkins:

mediawiki-core-phpcs-HEAD
mwext-cldr-phpcs-HEAD
mwext-Mantle-phpcs-HEAD
mwext-Translate-phpcs-HEAD
mwext-TranslationNotifications-phpcs-HEAD
mwext-TwnMainPage-phpcs-HEAD
mwext-WikiGrok-phpcs-HEAD

Change 254398 merged by jenkins-bot:
Remove legacy phpcs jobs and related config

https://gerrit.wikimedia.org/r/254398

hashar closed this task as Resolved.Nov 20 2015, 2:36 PM

All repositories have been migrated, thank you @Paladox. I cleaned up the CI configuration.

Awesome work @Paladox and @hashar :D