Page MenuHomePhabricator

Content translation won't begin if there is a '+' in the url
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Visit https://uz.wikipedia.org/wiki/Maxsus:ContentTranslation
  2. Click on 'create a new translation' button
  3. Select the English and type 'GTK+'
  4. Click on 'Start translation'
  5. Nothing happens

I'm taken to https://uz.wikipedia.org/wiki/Special:ContentTranslation?page=GTK%2B&from=en&to=uz&targettitle=GTK%2B but I still see that 'new translation' dialog.

Event Timeline

bmansurov raised the priority of this task from to Needs Triage.
bmansurov updated the task description. (Show Details)
bmansurov added a project: ContentTranslation.
bmansurov added a subscriber: bmansurov.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 27 2015, 1:03 AM
KartikMistry set Security to None.
KartikMistry added a subscriber: KartikMistry.

Thanks for report this, @bmansurov I can reproduce this.

santhosh claimed this task.Mar 2 2015, 5:23 AM

Change 193773 had a related patch set uploaded (by Santhosh):
Improve the special character handling for CX token

https://gerrit.wikimedia.org/r/193773

santhosh triaged this task as High priority.Mar 2 2015, 5:23 AM
santhosh moved this task from Backlog to In Review on the LE-Sprint-83 board.Mar 2 2015, 5:28 AM

Change 193773 merged by jenkins-bot:
Fix the special character handling for CX token

https://gerrit.wikimedia.org/r/193773

Amire80 closed this task as Resolved.Mar 2 2015, 7:31 AM
Amire80 removed a project: Patch-For-Review.
Amire80 moved this task from In Review to Done on the LE-Sprint-83 board.