Page MenuHomePhabricator

Rename "Unbreak Now!" priority
Closed, DeclinedPublic

Description

Now that "needs volunteer" has been renamed back to "lowest", can we change "unbreak now!" back to "highest" as well? (Or perhaps "urgent", if people think that's more meaningful.) I'm kind of bothered by the neologism / buzzword and the gratuitous exclamation mark.

(Yes, this is bikeshedding. Mea culpa.)

Event Timeline

wctaiwan created this task.Feb 27 2015, 1:12 AM
wctaiwan raised the priority of this task from to Low.
wctaiwan updated the task description. (Show Details)
wctaiwan added a project: Phabricator.
wctaiwan added a subscriber: wctaiwan.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 27 2015, 1:12 AM
Qgil added subscribers: Dzahn, Qgil.EditedFeb 27 2015, 10:33 AM

Let me copy this:

I would suggest do simply call the priorities: Lowest, Low, Normal, High and Highest.
So replace "needs volunteer" with lowest and 'unbreak now' with highest.
Other names seem just confusing for no additional value, since this is what we mean, it has the lowest priority. And calling this 'needs volunteer' additionally makes it sound volunteers are only doing the least important things which is not the message we want to send.
also, KISS

and my reply

Looking at the description of the problem, this looks like a consistent solution. Simple and clear.

Then again, something I really like about "Unbreak Now!" is that it clearly stands out of the rest, including "High". I remember @Aklapper complaining about teams (ab)using "Highest" for tasks that could wait indeed, and of different criteria for its use across different projects. In this sense, "Unbreak Now!" sounds clearly like an exceptional priority requiring to put anything else aside.

I've seen tasks with "highest priority" being open for half a year in Bugzilla.
At least the wording of "Unbreak now" makes it way clearer that this is something different: Urgency.
Which of these three is actually wanted might need discussion/bikeshed (urgency vs priority vs importance vs ____).

Unbreak now is appropriate for its usage in this context.

hoo added a subscriber: hoo.Feb 27 2015, 5:19 PM

While I see the issues raised above, I'm ok with unbreak now... It might not strictly be a priority either, but it is pretty close to that and it's (probably) not a flawed assumption (like lowest priority = a volunteer would need to do that).

Would "urgent" be sufficient to convey the sense of urgency?

+1 to Unbreak Now sticking around

Perhaps name this "Do This Today!"

Could someone move this to "Need discussion" please?

scfc added a subscriber: scfc.Feb 27 2015, 8:07 PM
Dzahn lowered the priority of this task from Low to Lowest.Feb 27 2015, 9:13 PM

scnr

TheDJ added a subscriber: TheDJ.Feb 27 2015, 9:19 PM

Keep: Also because "Unbreak Now" is very much part of the defaults of Phabricator.

Changing it might make it more difficult for people who want to follow the Audit and/or Differential user guides. That might be important if we are going the way of Phabricator code review at some point.

Isarra added a subscriber: Isarra.Feb 27 2015, 11:34 PM

I agree it should be renamed. This may be normal phabricator, but phrasing it as 'Unbreak now!' doesn't actually make sense as a general thing. If these are urgent, calling them 'urgent' would be much more straight-forward, and also less potentially misleading - things be urgent without necessarily being broken, per se, which is what 'unbreak' is saying they are... especially since 'broken' also implies it was previously working and the fact that it needs fixing now is a regression. Which often isn't the case at all.

Given that none of the other priorities are at all like this one, this added layer of convolution doesn't seem like a good idea.

I suggest the following changes:

  • Unbreak Now! -> Do This Today!
  • High -> Do within a Week
  • Normal -> Do within a Month
  • Low -> Do within Three Month
  • Lowest -> Do within a Year

Any comments?

The scope of this task is only about the name of "Unbreak now".
The scope of this task is not about discussing the entire Priority value naming scheme.
The discussion on the naming scheme took place in T268.

Qgil added a comment.Feb 28 2015, 2:31 PM

I agree it should be renamed. This may be normal phabricator, but phrasing it as 'Unbreak now!' doesn't actually make sense as a general thing.

It doesn't aim to be a general thing or an entry in Merriam-Webster. It is a task priority and in this context makes sense.

If these are urgent, calling them 'urgent' would be much more straight-forward, and also less potentially misleading - things be urgent without necessarily being broken, per se, which is what 'unbreak' is saying they are... especially since 'broken' also implies it was previously working and the fact that it needs fixing now is a regression. Which often isn't the case at all.

Well, precisely. "Unbreak Now!" is for a more precise and restrictive case than "Urgent":

Unbreak Now! - Something is broken and needs to be fixed immediately, setting anything else aside.

https://www.mediawiki.org/wiki/Phabricator/Project_management#Priority_levels

Like @hoo, while I saw the point of discussing "Needs Volunteer" until finding an agreement, in this case I think it is just a detail that clearly has a risk of bikeshedding with little benefit. I think we can keep it as it is.

wctaiwan closed this task as Declined.Mar 2 2015, 12:14 AM
wctaiwan claimed this task.

Consensus seems to be that it's fine as it is.