Page MenuHomePhabricator

resurrect wikiviewstats tool
Closed, DeclinedPublic

Description

https://tools.wmflabs.org/wikiviewstats/

No db-connection-


also see last comment on T63833

https://phabricator.wikimedia.org/T63833#823180


< Coren> matanya: Sorry, can't seem to see what could be wrong with wikiviewstats. It logs no error, and unconditionally returns that message. AFAICT, that only should happen when it can't connect to the database but I see nothing wrong with them nor does it report a failure.
..
< Coren> There are two sets of creds, one of which is specifically connecting to the wrong db


T120497 discusses alternatives.

Event Timeline

Dzahn created this task.Mar 2 2015, 10:13 PM
Dzahn updated the task description. (Show Details)
Dzahn raised the priority of this task from to Needs Triage.
Dzahn added a project: Tools.
Dzahn added a subscriber: Dzahn.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 2 2015, 10:13 PM
Technical13 triaged this task as High priority.Apr 11 2015, 5:31 PM
Technical13 claimed this task.
Technical13 edited projects, added XTools; removed Tools.
Sitic added a subscriber: Sitic.Apr 11 2015, 5:37 PM
Fuzzy added a subscriber: Fuzzy.May 5 2015, 6:05 AM

Any progress on the resolution of the wrong DB connection that prevent Wikiviewstats from running?

Technical13 removed Technical13 as the assignee of this task.Jun 23 2015, 5:43 PM
Technical13 added a subscriber: Technical13.

OMG, the code. Hedonil certainly has a unique way of writing code. @Technical13 we may have to rewrite this too when we move it to xTools.

Yep. That's why I killed the webservice for it the other day. It's not something that is going to happen soon based on our current levels of free time. I got midterms in a week, so cramming for that.

I looked and looked, and for the life of me cannot figure out what's causing the problem, or how to even read this. I'd need to open a million files just to even follow along.

Cyberpower678, Technical13 do you see any chance to restore this tool?

Cyberpower678 removed Cyberpower678 as the assignee of this task.Dec 30 2015, 4:07 PM
Dzahn added a comment.Jan 4 2016, 9:54 PM

meanwhile this is not "no db connection" anymore as originally reported but the webservice has been disabled too.

It does still say:

This URI is part of the wikiviewstats tool, maintained by Tools.wikiviewstats2, Cyberpower678, Technical 13, Hedonil, Betacommand, and Tools.xtools.

Is Betacommand active?

Dzahn renamed this task from wikiviewstats - No db-connection to resurrect wikiviewstats tool.
Nemo_bis updated the task description. (Show Details)Jan 31 2016, 8:50 AM
Dzahn removed a subscriber: Dzahn.Feb 1 2016, 6:56 PM

From my initial assessment, it appears that wikiviewstats didn't handle the transition to a newer version of php well, as the error log had errors about passing by reference. Modified the relevant code, now there is no error ouptut yet the script is still dying. I'm still exploring.

Does anyone know if WikiViewStats is under vcs somewhere?

Further exploration has revealed the following:

On line 694 of ~/wvs_modules/Core.php, there is a query:

Select shortcut as prefix, title, title_local, infolink, marker from meta where marker > 0 ;

It is run against the meta_p.meta table, which doesn't exist. This leaves the language array empty, which then causes a 500 further down the line.

Proposed solution? Replacing that query with an alternative using the meta_p.wiki table.

Further exploration has revealed the following:

On line 694 of ~/wvs_modules/Core.php, there is a query:

Select shortcut as prefix, title, title_local, infolink, marker from meta where marker > 0 ;

It is run against the meta_p.meta table, which doesn't exist. This leaves the language array empty, which then causes a 500 further down the line.

A search reveals rOSOF061e316d5794e79c58cd4d15a5b2f38ef6bf9dce, which looks like a typo?

Would it be possible that the tool is from the toolserver-era and the query is supposed to run against toolserver.meta? In any case, I never had access to toolserver and dunno what data it had. Searches for toolserver.meta reveal nothing useful.

Matthewrbowker closed this task as Declined.Sep 14 2016, 8:30 PM

Closing this task... We have decided not to revive WikiViewStats. Instead, if you need this functionality look at http://tools.wmflabs.org/pageviews

Wait, what? When did "we" decide that?

News to me. Not that I object, but I don't recall discussing this.

It was in the chat thing. You all are in there, but really it was just Matthew and I chatting, to be fair :) Anyway, it's not really resurrectable without considerable effort. The old pageviews dumps it went off of no longer exist, the same reason stats.grok.se went down. The gadget that was using wikiviewstats is working now, by the way, it just isn't showing pageviews data. For that you can just hit the RESTBase API https://wikimedia.org/api/rest_v1/?doc

It was in the chat thing. You all are in there, but really it was just Matthew and I chatting, to be fair :) Anyway, it's not really resurrectable without considerable effort. The old pageviews dumps it went off of no longer exist, the same reason stats.grok.se went down. The gadget that was using wikiviewstats is working now, by the way, it just isn't showing pageviews data. For that you can just hit the RESTBase API https://wikimedia.org/api/rest_v1/?doc

I never got any notification of any activity going on in that chat room. :O

It was in the chat thing. You all are in there, but really it was just Matthew and I chatting, to be fair :) Anyway, it's not really resurrectable without considerable effort. The old pageviews dumps it went off of no longer exist, the same reason stats.grok.se went down. The gadget that was using wikiviewstats is working now, by the way, it just isn't showing pageviews data. For that you can just hit the RESTBase API https://wikimedia.org/api/rest_v1/?doc

I never got any notification of any activity going on in that chat room. :O

That sounds like a bug o.O

With the amount of work required, I really don't think it's worth the effort, especially since we have an alternative. I spent six hours on WikiViewStats some week back, and actually doubled the number of error messages.

IMHO WikiViewStats is much more complete and userfriendly of any other stats tool (this new one included). Since I'm not able to fix it, I need to accept the community decision, but is really sad to hear this.

I've never actually used it, and looking at the screenshots they are some really nice features! The problem however is the data source is no longer available, so even if you fix all the PHP bugs you're still going to have to figure that out.

Where is the source code? This clearly is not it https://github.com/x-tools/wikiviewstats

Where is the source code? This clearly is not it https://github.com/x-tools/wikiviewstats

I don't blieve it's under VCSanywhere. The github repo was created by me in order to VCS it... I didn't get around to it though sadly. I will be moving the code there and I'm sure we'll accept patches if someone wants to take on resurrecting the tool.

MusikAnimal moved this task from Inbox to Complete on the XTools board.Jul 23 2017, 7:47 PM