Page MenuHomePhabricator

[Epic] Make the Education program dashboard usable for all languages and projects
Closed, ResolvedPublic

Description

Details:

  • Primary mentor: @Ragesoss
  • Co-mentor: @Capt_Swing
  • Other mentors: (optional, Phabricator username)
  • Skills: Ruby, Javascript / Coffeescript, React.js
  • Estimated project time for a senior contributor: 3 weeks
  • Microtasks: T114906, T114908, T114905

DESCRIPTION:
The Wiki Ed Dashboard is a Ruby on Rails app that runs dashboard.wikiedu.org ( source on GitHub). It's being built primarily by Wiki Education Foundation to support Wikipedia classroom projects in the United States and Canada, and it serves as a replacement for the EducationProgram extension. It could also be useful for the global Wikimedia community — both for education programs and for other projects where it's important to keep track of the on-wiki activity of a group over users over a certain time period. But it's been designed first and foremost for the specific, English-language, English-Wikipedia-focused needs of Wiki Education Foundation. So it will take some effort to turn it into a system that can serve users in any language and to work well in many different contexts.

Some of the basic i18n infrastructure is in place, but it is not used consistently throughout the codebase. There are also many features and configurations that are specific to Wiki Education Foundation's programs. So the baseline for making the dashboard usable across languages and programs is complete the i18n work, and add options to disable — or locally configure — the features that are specific to Wiki Education Foundation's programs. That would make it feasible to deploy a new dashboard for any language. Getting that far is a reasonable goal for an internship project.

FOLLOW-ON WORK:
From there, it's an open question how best to support many different languages at once. That could mean spinning up a separate instance of the dashboard for each language, which means that automating the deployment and update process would be an important next step. Or, it could mean improving the core dashboard to support many languages simultaneously.

Relevant future work:

  • Consider making it work for multiple projects, rather than one instance per project.
  • Verify that branding is consistent with WMF sites.
  • Packaging and deployment.

PLAN:

  • Convert all hard-coded English interface strings to use i18n messages
  • Set up an instance on wmflabs.org for i18n testing, and work with Education Collaborative members to identify additional features need to be either disabled or generalized from their current Wiki Education Foundation-specific forms
  • Add option to disable the 'Wizard' assignment design tool, the content of which is very specific to Wiki Education Foundation
  • Add further configuration options to remove or generalize other features identified by Education Collaborative members

Additional working notes on the implementation:
https://etherpad.wikimedia.org/p/article.wiki

Related Objects

StatusAssignedTask
ResolvedRagesoss
InvalidNone
ResolvedRagesoss
OpenNone
ResolvedRagesoss
Resolvedawight
Resolvedawight
Invalidawight
ResolvedNikerabbit
Resolvedawight
Resolvedawight
ResolvedRagesoss
ResolvedRagesoss
ResolvedAbit
Duplicate FloorKoudijs
Resolvedawight
DeclinedHaritha28
DeclinedWdssilva
DeclinedKenua
Resolvedawight
ResolvedRagesoss
OpenNone
InvalidNone
Resolvedawight
Resolvedawight
ResolvedAbit
OpenNone
DeclinedNone

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
01tonythomas added a subscriber: 01tonythomas.

I am shifting this to Outreachy-Round-11 as the project description has two mentors, micro-tasks and looks ready for the 11th edition of Outreachy ( Dec 2015 - Mar 2016 ) . Potential candidates should start by submitting their proposals as a blocker for this task, by November 02.

Feel free to revert it back, if this task has some relevant issues which might block its completion in this term of Outreachy.

Kenua added a subscriber: Kenua.Oct 29 2015, 4:57 PM

Anyone willing to organize a webinar and show us through the existing dashboard?

Education leaders from all over the world should get to know it better - and comment on it - before you decide to devote precious programming time to it. We are the potential users and IMHO should be involved in the decision process.

Esh77 added a comment.Nov 2 2015, 10:07 AM

I second that..

Hi @Vojtech.dostal, @Esh77, and everyone else :)

The Wiki Ed team did a brown bag walk through of their dashboard last week at the WMF offices. The session was recorded and you can view it here. Maybe this helps somewhat?

Also, I would encourage the discussion to also take place on the Education Extension Impact page so we can capture what we like about the tool and what a replacement tool could do better.

Thank you. Just watched the youtube video and it gave me a pretty good idea about the WikiEd Dashboard. I will sum up my points on the page linked by Tighe.

Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptNov 3 2015, 9:49 PM
awight updated the task description. (Show Details)Feb 17 2016, 7:22 AM
Sumit added a subscriber: Sumit.Feb 19 2016, 8:15 PM
NOTE: Outreachy round 12 applications are now open and GSoC 2016 is round the corner. This project was featured for Outreachy round 11 and has a well defined scope. Are you ready to mentor the project this season? If yes, then we'll feature this for Outreachy round 12 and GSoC 2016 as well. Please reply back in comments.

Yes, that would be wonderful @Sumit! We didn't find any suitable participants in round 11 to take on this project but would love to feature it again and define the follow-up scope for this project for round 12 (we are currently working on some of this work during a sprint in February - but there's lots more to do and help would be appreciated!).
Poking @Abit because she should know about this. Also poking @Ragesoss and @dduvall, who graciously agreed to mentor and co-mentor a prospective Outreachy student.
Thank you for asking about this, @Sumit.

Sumit added a comment.Feb 23 2016, 5:14 PM

Yes, that would be wonderful @Sumit! We didn't find any suitable participants in round 11 to take on this project but would love to feature it again and define the follow-up scope for this project for round 12 (we are currently working on some of this work during a sprint in February - but there's lots more to do and help would be appreciated!).
Poking @Abit because she should know about this. Also poking @Ragesoss and @dduvall, who graciously agreed to mentor and co-mentor a prospective Outreachy student.
Thank you for asking about this, @Sumit.

Thats great news!
@Ragesoss , @dduvall are you willing to support this project for the upcoming round of GSoC/Outreachy programs?

Qgil removed a subscriber: Qgil.Feb 24 2016, 10:49 AM
ZeWaPr added a subscriber: ZeWaPr.Feb 25 2016, 11:02 PM
awight renamed this task from [epic] Make the Education program dashboard usable for all languages and projects to [Epic] Make the Education program dashboard usable for all languages and projects.Feb 27 2016, 6:52 AM
Prateechi removed a subscriber: Prateechi.
Prateechi added a subscriber: Prateechi.
This task do not have any confirmed co-mentors for GSoC'16/Outreachy'12 yet : The administration team is moving this project to ( Missing Mentors ) list as we do not have any confirmed co-mentor(s) for this round yet. Interested in co-mentoring ? Do add your name in the task description. A Possible-Tech-Projects task requires a minimum of one primary mentor and a co-mentor to be featured for GSoC/Outreachy. Prospective students ? Do take a look at the Wikimedia mentors pool at https://www.mediawiki.org/wiki/Outreach_programs/Possible_mentors, and try connecting this project with a co-mentor, to get featured for this round. A co-mentor needn't necessarily be from a technical background, as per https://www.mediawiki.org/wiki/Outreach_programs/Life_of_a_successful_project#Coming_up_with_a_proposal

@awight @AndyRussG @dduvall @Capt_Swing Are any of you up for co-mentoring with me on this? I can be the primary mentor. I think we've done enough of the groundwork on this project, thanks to the February sprint, that this would be a really good project for GSoC/Outreachy. There are also a couple of people who've expressed interest who seem likely to have the technical skills to dive into it, if selected.

@Pginer-WMF: same invitation as above... if you're interested in co-mentoring on this, let us know. :-)

Sumit added a comment.Mar 7 2016, 8:24 PM

@awight @AndyRussG @dduvall @Capt_Swing Are any of you up for co-mentoring with me on this? I can be the primary mentor. I think we've done enough of the groundwork on this project, thanks to the February sprint, that this would be a really good project for GSoC/Outreachy. There are also a couple of people who've expressed interest who seem likely to have the technical skills to dive into it, if selected.
@Pginer-WMF: same invitation as above... if you're interested in co-mentoring on this, let us know. :-)

As a reminder, GSoC application period starts on 14th March. It'd be great if this project could have a co-mentor. :)

Between my Release-Engineering-Team commitments and paternity leave, I'll be unable to co-mentor this round due. Next time perhaps!

Capt_Swing updated the task description. (Show Details)Mar 7 2016, 10:26 PM

At @Ragesoss's request, I just added myself as a mentor for UX related parts of the project. I look forward to helping!

Sumit added a comment.Mar 8 2016, 3:16 AM

At @Ragesoss's request, I just added myself as a mentor for UX related parts of the project. I look forward to helping!

Thank You @Capt_Swing , moving this to "featured for GSoC/Outreachy"

Sumit reopened this task as Open.Mar 8 2016, 5:39 PM

@ShAdrianSh you're requested not to close tasks in Possible-Tech-Projects without prior notice or comments.

Sumit added a comment.Mar 24 2016, 4:57 PM

@Ragesoss @Capt_Swing a gentle reminder to add some fresh microtasks as they allow candidates to get familiar with MediaWiki in general and help in proposal evaluation.. See https://www.mediawiki.org/wiki/Outreach_programs/Life_of_a_successful_project#Start_working_on_microtasks :)

@Sumit hasn't the deadline for proposals already passed? I did take a pass at making sure all the remaining microtasks are still relevant.

Sumit added a comment.Mar 24 2016, 5:10 PM

@Sumit hasn't the deadline for proposals already passed? I did take a pass at making sure all the remaining microtasks are still relevant.

I was referring to micro-tasks for the one proposal that is submitted. The one's listed are resolved but I found https://github.com/WikiEducationFoundation/WikiEduDashboard/issues?q=is%3Aissue+is%3Aopen+label%3Aeasy on one of them, which should be fine.

Ah, yeah. I discussed tasks with Mary on GitHub (and we also met once in person), and she's now done three nice commits.

@Ragesoss: Could you post the URL for this? I can't seem to find it.

@Ragesoss: Could you post the URL for this? I can't seem to find it.

https://outreachdashboard.wmflabs.org/

Sumit added a comment.Sep 6 2016, 4:33 PM

@Ragesoss , Outreachy-13 is soon to start, does this project still stand as a prospective internship project?

@Sumit: much of this one has been done, and the some of what remains is already being worked on, but I set up a new task that I think would be a great internship project: https://phabricator.wikimedia.org/T143003

@Sumit: much of this one has been done, and the some of what remains is already being worked on, but I set up a new task that I think would be a great internship project: https://phabricator.wikimedia.org/T143003

Great! I'll add Possible-Tech-Projects to it in that case.

DStrine removed a subscriber: awight.Oct 31 2016, 2:16 PM
Ragesoss closed this task as Resolved.Feb 28 2017, 8:33 PM
Ragesoss claimed this task.

The main push for this is done. There are some edge cases — UI issues for wikidata, support for incubator and multilingual wikisource, and probably other similar cases — that we don't yet handle, but the known individual cases are being tracked separately.

The main push for this is done.

Well done! We're already reaping the benefits.