Page MenuHomePhabricator

Vagrant up fails due to error in loading vagrantfile and need help in change in port from 8080 to something else.
Closed, ResolvedPublic

Description

Vagrant up
There was an error loading a Vagrantfile. The file being loaded
and the error message are shown below. This is usually caused by
a syntax error.

Path: /home/bhavyashree/vagrant/Vagrantfile
Message: The mediawiki-vagrant plugin hasn't been installed yet. Please run setup.sh.

but vagrantfile looks alright , still getting this error could any one help me out

and is there a way to change port of my MW vagrant from 8080 to something else ??

vagrant provision 
==> default: Running provisioner: lsb_check...
==> default: Running provisioner: puppet...
==> default: Running Puppet with site.pp...
==> default: Info: Loading facts in /tmp/vagrant-puppet/modules-fc1a4741a489b34b8bb072310d1247db/stdlib/lib/facter/pe_version.rb
==> default: Info: Loading facts in /tmp/vagrant-puppet/modules-fc1a4741a489b34b8bb072310d1247db/stdlib/lib/facter/facter_dot_d.rb
==> default: Info: Loading facts in /tmp/vagrant-puppet/modules-fc1a4741a489b34b8bb072310d1247db/stdlib/lib/facter/root_home.rb
==> default: Info: Loading facts in /tmp/vagrant-puppet/modules-fc1a4741a489b34b8bb072310d1247db/stdlib/lib/facter/puppet_vardir.rb
==> default: Notice: Compiled catalog for mediawiki-vagrant.dev in environment production in 4.93 seconds
==> default: Info: Loading facts in /tmp/vagrant-puppet/modules-fc1a4741a489b34b8bb072310d1247db/stdlib/lib/facter/pe_version.rb
==> default: Info: Loading facts in /tmp/vagrant-puppet/modules-fc1a4741a489b34b8bb072310d1247db/stdlib/lib/facter/facter_dot_d.rb
==> default: Info: Loading facts in /tmp/vagrant-puppet/modules-fc1a4741a489b34b8bb072310d1247db/stdlib/lib/facter/root_home.rb
==> default: Info: Loading facts in /tmp/vagrant-puppet/modules-fc1a4741a489b34b8bb072310d1247db/stdlib/lib/facter/puppet_vardir.rb
==> default: Info: Applying configuration version '1425619576.2d15ed3'
==> default: Info: mount[files]: allowing mediawiki-vagrant access
==> default: Notice: /Stage[main]/Apt/Exec[update_package_index]/returns: executed successfully
==> default: Notice: /Stage[main]/Hhvm/File[/var/run/hhvm/hhvm.hhbc]/owner: owner changed 'root' to 'www-data'
==> default: Notice: /Stage[main]/Hhvm/File[/var/run/hhvm/hhvm.hhbc]/group: group changed 'root' to 'www-data'
==> default: Notice: /Stage[main]/Hhvm/File[/var/run/hhvm/hhvm.hhbc]/mode: mode changed '0644' to '0666'
==> default: Notice: /Stage[main]/Mediawiki::Jobrunner/Service[jobrunner]/ensure: ensure changed 'stopped' to 'running'
==> default: Info: /Stage[main]/Mediawiki::Jobrunner/Service[jobrunner]: Unscheduling refresh on Service[jobrunner]
==> default: Notice: Finished catalog run in 30.28 seconds

Event Timeline

Bhavya30 created this task.Mar 5 2015, 7:18 PM
Bhavya30 raised the priority of this task from to Needs Triage.
Bhavya30 updated the task description. (Show Details)
Bhavya30 added a subscriber: Bhavya30.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 5 2015, 7:18 PM
Krenair added a subscriber: Krenair.
Bhavya30 renamed this task from Error while installing mediawiki-vagrant plugin and need help in change in port from 8080 to something else. to Vagrant up fails due to error in loading vagrantfile and need help in change in port from 8080 to something else..Mar 6 2015, 5:29 AM
Bhavya30 updated the task description. (Show Details)
Bhavya30 set Security to None.
Niharika updated the task description. (Show Details)Mar 6 2015, 5:32 AM

@Bhavya30, did you run 'setup.sh'?

@NiharikaKohli yup actually there was some issue with network or kernal its working fine now

@Bhavya, good. Closing this task.

Niharika closed this task as Resolved.Mar 6 2015, 6:48 AM
bd808 moved this task from Backlog to Done on the MediaWiki-Vagrant board.Mar 17 2015, 3:42 PM