Page MenuHomePhabricator

left-navigation and right-navigation fight for space in Vector (Firefox: 775px, Chrome: 789px width)
Closed, ResolvedPublic

Description

The elements inside of left-nave and right-nav will bounce back and forth without coming to any resolution when I set my browser (doesn't matter if it is chrome, FF, or IE) to half my screen.

Event Timeline

MarkAHershberger raised the priority of this task from to Needs Triage.
MarkAHershberger updated the task description. (Show Details)
MarkAHershberger added a subscriber: MarkAHershberger.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 5 2015, 8:34 PM
Aklapper triaged this task as Low priority.Mar 6 2015, 12:22 PM

Do you know what's the exact pixel width of your browser window? (For example, the "Responsive Design View" of Firefox' developer tools allows to set the height and width of the browser window.)
Is the zoom level in the browser set to default? Is this about the default Vector skin?

Looking at the source code of mediawiki.org, does this task refer to <div id="right-navigation"> and <div id="left-navigation"> (exact naming of elements welcome so someone else could try to reproduce without having to think too much)?

Note that this is the private wiki of my client, not Wikipedia.
However, they're just using stock Vector with an empty
MediaWiki:Common.css.

Aklapper writes:

Do you know what's the exact pixel width of your browser window?

I can reproduce this with the pixel width set to 775 in Firefox.

It happens in Chrome at 789.

I have IE sized the same. For pixel measurements I went to F12 ->
Emulation -> Enter a custom resolution -> Width: 540
(Even though the display area appeared to be the same.)

Is the zoom level in the browser set to default?

Yes.

Is this about the default Vector skin?

Yes. The only difference is a custom logo.

Looking at the source code of mediawiki.org, does this task refer to
<div id="right-navigation"> and <div id="left-navigation">

Yes (I wrote the bug report on the plane when I couldn't get to the site
itself).

Aklapper renamed this task from left-nav and right-nav fight for space to left-navigation and right-navigation fight for space in Vector (Firefox: 775px, Chrome: 789px width).Mar 19 2015, 1:34 PM
Aklapper edited projects, added Vector; removed Design.
Aklapper set Security to None.

This is probably a duplicate of T71729, I think all other issues with collapsible tabs have been resolved. @MarkAHershberger, can you confirm that the wiki in question has different tabs on affected pages when you visit it with JS enabled and disabled? (This apparently happens in some VisualEditor configurations.)

MarkAHershberger closed this task as Resolved.Sep 30 2015, 5:14 PM
MarkAHershberger claimed this task.

I'm not able to reproduce this currently. This can be closed.