Page MenuHomePhabricator

mediawiki.ui KSS template is incompatible with latest kss
Closed, ResolvedPublic

Description

@Nirzar ran cd core/docs/kss; make to build the mediawiki.ui desktop style guide.

npm installed the latest kss version 2.0.2 per package.json, but then the kss-node command failed with

{{whenDepth expression}} is deprecated; use {{ifDepth expression}} instead.

core/docs/kss/styleguide-template/index.html uses {{whenDepth}}. He fixed that and got another deprecation error.

It builds fine for me, npm list kss says I'm running kss@0.3.7.

According to https://github.com/kss-node/kss-node/releases these features were deprecated in version 2, so I think changing package.json to

"kss": ">=0.3.7 <=1.2.0"

would fix this. Or someone could update core/docs/kss/styleguide-template/index.html , but they would probably have to bump up the required version in package.json.

Event Timeline

Spage created this task.Mar 6 2015, 1:33 AM
Spage raised the priority of this task from to Needs Triage.
Spage updated the task description. (Show Details)
Spage moved this task to Backlog on the Wikimedia Design Style Guide board.
Spage added subscribers: Spage, Nirzar.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 6 2015, 1:33 AM
Spage updated the task description. (Show Details)Mar 6 2015, 1:35 AM
Spage set Security to None.
Restricted Application added a project: Documentation. · View Herald TranscriptMar 6 2015, 1:35 AM

Change 194785 had a related patch set uploaded (by Spage):
Specify max compatible kss version

https://gerrit.wikimedia.org/r/194785

Change 194785 merged by jenkins-bot:
Specify max compatible kss version

https://gerrit.wikimedia.org/r/194785

Spage closed this task as Resolved.Mar 14 2015, 5:49 AM
Spage claimed this task.
Volker_E removed a subscriber: gerritbot.