Page MenuHomePhabricator

Mobile search in Firefox repeats first letters
Closed, ResolvedPublic

Description

On a Firefox Mobile, every time I enter a search term in the top search box in a mobile version of a Wikimedia site (e.g. fr.wikipedia), some letters are repeated. More precisely it appears like this, if I try to enter "Abcde":

  • A
  • AAb
  • AAbc
  • AAbcAbcd
  • AAbcAbcde

And then the letters are entered correctly. It behaves identically if I try to add letters to an existing search term.
This doesn't happen in Chrome or the default browser on the same device.

Firefox 36
Android 4.4.2
Samsung Galaxy Note 3

Event Timeline

Darkdadaah raised the priority of this task from to Needs Triage.
Darkdadaah updated the task description. (Show Details)
Darkdadaah added a subscriber: Darkdadaah.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 6 2015, 5:17 PM

@Darkdadaah, thanks for reporting this. Can you share a screenshot too? If I understood you correctly, the texts you provided appear in the searchbox, right?

Here is a screenshot, after I typed "Abcde" in the searchbox at the top of the page:


This error happens consistently, but it would be good to know if other users of Firefox on Android have the same problem.

@Darkdadaah, thanks, I'm partially able to reproduce this on Firefox 36.0.1 on Android 5.0.2. I can briefly see what you have in your screenshot, but it goes away after a split second.

phuedx added a subscriber: phuedx.Mar 10 2015, 6:03 PM

I can reproduce this in Firefox Beta 36.0 for Android.

bmansurov set Security to None.

Turns out it's a bug on Firefox for Android [1].

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=735806

bmansurov removed bmansurov as the assignee of this task.Mar 12 2015, 8:50 PM

@bmansurov is there anything we can do for this, or does it belong in "tracking"?

@JKatzWMF, I think at this stage it may belong to 'tracking', unless we decide to work around the browser bug.

I can't reproduce this bug anymore on both Firefox 37.0.2 and 38.0 beta. It was still buggy with 37.0.1 and 38.0 (not sure if the beta was exactly the same).

Anyway, it may be fixed now. @phuedx and @bmansurov can you check?

I confirm that the bug is not re-producable on Firefox 37.0.2 on Android Lollipop.

Jdlrobson closed this task as Resolved.Sep 16 2015, 6:25 PM
Jdlrobson claimed this task.
Jdlrobson edited projects, added MobileFrontend, Upstream; removed Readers-Web-Backlog.
Jdlrobson added a subscriber: Jdlrobson.

Fixed upstream in latest Firefox release. Thanks guys for reporting/investigating/confirming fix!