Page MenuHomePhabricator

Investigate system-level packages
Closed, ResolvedPublic

Description

Currently, there are a number of local system-level packages that are installed on (all) instances:

scfc@tools-dev:/data/project/.system/deb$ ls -l dmeventd_1.02.74-6ubuntu4_amd64.deb dmsetup_1.02.74-6ubuntu4_amd64.deb init-system-helpers_1.7~precise1~ppa1_all.deb lvm2_2.02.95-6ubuntu4_amd64.deb 
-rw-r--r-- 1 tools.admin tools.admin  55384 Apr 13  2013 dmeventd_1.02.74-6ubuntu4_amd64.deb
-rw-r--r-- 1 tools.admin tools.admin  75248 Apr 13  2013 dmsetup_1.02.74-6ubuntu4_amd64.deb
-rw-r--r-- 1 root        tools.admin  10586 Okt 22  2013 init-system-helpers_1.7~precise1~ppa1_all.deb
-rw-r--r-- 1 tools.admin tools.admin 593568 Apr 13  2013 lvm2_2.02.95-6ubuntu4_amd64.deb
scfc@tools-dev:/data/project/.system/deb$

For example, lvm2 on Precise is 2.02.66-4ubuntu7, on Trusty 2.02.98-6ubuntu2.

IIRC, @Petrb packaged them then. Petan, were there any problems that necessitated those updates, or can we return to the Precise defaults (for Precise instances)?

Event Timeline

scfc raised the priority of this task from to Medium.
scfc updated the task description. (Show Details)
scfc added a project: Toolforge.
scfc added subscribers: yuvipanda, coren, Aklapper and 2 others.

@Petrb: Were there any problems that necessitated those updates, or can we return to the Precise defaults (for Precise instances)?

scfc claimed this task.

I have moved:

dmeventd_1.02.74-6ubuntu4_amd64.deb
dmsetup_1.02.74-6ubuntu4_amd64.deb
init-system-helpers_1.7~precise1~ppa1_all.deb
libdevmapper1.02.1_1.02.74-6ubuntu4_amd64.deb
libdevmapper-event1.02.1_1.02.74-6ubuntu4_amd64.deb
lvm2_2.02.95-6ubuntu4_amd64.deb

to ~tools.admin/archived-packages/.