Page MenuHomePhabricator

S3. Deploy new Flow indentation model on Mediawiki
Closed, ResolvedPublic2 Story Points

Description

This ticket is for deploying the new Flow indentation model on Mediawiki.

The new model includes:

  • 8 possible levels of indentation
  • replying to the last message in the thread or the last message in an indented tangent opens the entry field at the same indentation level, and posts the new comment at that level
  • replying to a previous message that's not the last in a tangent opens the entry field at the next indentation level, and posts the new comment at that level
  • clicking Reply on the last message in a thread puts the focus in the bottom entry field

It does NOT include any change to the width or spacing (at least, not right now).

Rationale

The feedback from the English tests was mixed -- some people really liked the new model, some were confused by it. The negative feedback flagged the "Comment/Reply" distinction and not having a Reply link for the last message in a thread as being confusing. We changed those two pieces, and also tried out a version with the current indentation system at 8 levels. The feedback at that point didn't reveal a particular preference for the 8-level current system.

We offered a week of testing in French, Catalan and Portuguese, to make sure we got feedback from a variety of users. We didn't get a ton of feedback -- it's a pretty subtle difference, and I'm sure translating my explanation didn't help. Still, all the people who commented were either positive about the new model, or didn't really care.

So I think the next step is to deploy on Mediawiki, and see how it goes in real conversations. We're not declaring victory on this -- just giving a tryout on real pages.

Examples

These are the same posts by the same users, posted using the same links.

Old indentation model:

New indentation model:

Event Timeline

DannyH created this task.Mar 11 2015, 5:06 PM
DannyH raised the priority of this task from to Normal.
DannyH updated the task description. (Show Details)
DannyH moved this task to Team discussion on the Collaboration-Team-Triage board.
DannyH added a subscriber: DannyH.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 11 2015, 5:06 PM
DannyH updated the task description. (Show Details)Mar 11 2015, 5:08 PM
DannyH set Security to None.
DannyH updated the task description. (Show Details)
DannyH edited a custom field.Mar 11 2015, 6:38 PM
DannyH renamed this task from Deploy new Flow indentation model on Mediawiki to S3. Deploy new Flow indentation model on Mediawiki.Mar 11 2015, 9:42 PM
DannyH removed a project: Collaboration-Team-Triage.

Do we really want to deploy 8 levels deep?

I just want confirmation, because:

  • in rationale it says noone expressed a preference for 8 levels.
  • the example of the old indentation model is with a lot of indents

Also, if we do want 8 levels deep, do we want to increase the width of the flow board?

Confirmed: 8 levels deep!

DannyH moved this task from Unscheduled to March 2015: Features & Apps on the Roadmap board.
Restricted Application added a project: Notice. · View Herald TranscriptMar 24 2015, 6:30 PM
gpaumier moved this task from Backlog to Triaged on the Notice board.Mar 25 2015, 9:59 PM
DannyH closed this task as Resolved.Mar 26 2015, 8:44 PM

Out on Mediawiki.org now

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 7 2015, 5:44 PM
gpaumier moved this task from Triaged to Archive on the Notice board.Apr 9 2015, 5:45 PM