Page MenuHomePhabricator

Train L10n-bot to work with repositories hosted in Wikimedia Phabricator (Diffusion)
Closed, DeclinedPublic

Description

In Gerrit, L10n-bot (is there a doc page?) merges all the localization progress produced in https://translatewiki.net . We will need the same when we decide to have code review in Wikimedia Phabricator.

Related Objects

StatusAssignedTask
Resolved Dzahn
ResolvedCmjohnson
Resolved Dzahn
Resolveddemon
Resolveddemon
ResolvedDanny_B
ResolvedPaladox
ResolvedPaladox
ResolvedNemo_bis
Resolveddemon
ResolvedPaladox
ResolvedKrenair
Resolvedmmodell
InvalidNone
DeclinedNone
Resolveddemon
InvalidNone
InvalidNone
ResolvedQgil
DeclinedNone
DuplicateNone
DeclinedNone
DeclinedNone

Event Timeline

Qgil created this task.Mar 12 2015, 1:28 PM
Qgil updated the task description. (Show Details)
Qgil raised the priority of this task from to Low.
Qgil added a subscriber: Qgil.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 12 2015, 1:28 PM
demon added a subscriber: demon.Mar 12 2015, 1:30 PM

I actually don't think it'll need to speak arc/differential. In l18n-bot's case we want to skip review anyway, so we might just be able to let it push directly to the repo and skip making a differential.

revi added a subscriber: revi.Nov 4 2015, 5:48 AM

I actually don't think it'll need to speak arc/differential. In l18n-bot's case we want to skip review anyway, so we might just be able to let it push directly to the repo and skip making a differential.

I agree with this. With the new differential you cannot review your own patchset (by default, which I think it's regression) and it's useless to review bunch of patches created by bot that we know what it does.

Legoktm added a subscriber: Legoktm.Nov 4 2015, 5:50 AM

I actually don't think it'll need to speak arc/differential. In l18n-bot's case we want to skip review anyway, so we might just be able to let it push directly to the repo and skip making a differential.

Long-term we do want l10n-bot to go through CI for things like T91707: L10n-bot should not force-merge / override Jenkins (breaks the build).

demon added a comment.Nov 4 2015, 5:56 AM

I actually don't think it'll need to speak arc/differential. In l18n-bot's case we want to skip review anyway, so we might just be able to let it push directly to the repo and skip making a differential.

Long-term we do want l10n-bot to go through CI for things like T91707: L10n-bot should not force-merge / override Jenkins (breaks the build).

Long term I'd love a world where we don't have to make gigantic daily commits to 100+ repos just to update l10n.

Long term I'd love a world where we don't have to make gigantic daily commits to 100+ repos just to update l10n.

They are not very gigantic imho, just numerous. Plans for "LUServer" do exist, it was also proposed for GSoC project.

greg moved this task from To Triage to Backlog on the Differential board.Nov 4 2015, 7:04 PM
greg moved this task from To Triage to Tooling on the Gerrit-Migration board.Dec 2 2015, 12:31 AM
greg raised the priority of this task from Low to Normal.
Qgil removed a subscriber: Qgil.Dec 2 2015, 11:50 AM
Raymond added a subscriber: Raymond.Dec 6 2015, 9:17 PM

@demon said we can use plain git (push?) which we already support. I don't know how that will go with the projects which want to run tests for l10n changes.

Will also need the l10n-bot account / permissions sorted out.

And finally, gerrit provides a list of repositories. Does Phabricator have equivalent? In a way that we can easily grep extensions and skins?

demon added a comment.Jan 4 2016, 10:21 PM

@demon said we can use plain git (push?) which we already support. I don't know how that will go with the projects which want to run tests for l10n changes.

We could have it go async. The changes could be tested by Jenkins after pushing and report back via Audit if a problem is encountered.

Will also need the l10n-bot account / permissions sorted out.

Not hard, just needs to be setup especially in a way that's pretty automated going forward so we don't have to manually set things up all the time.

And finally, gerrit provides a list of repositories. Does Phabricator have equivalent? In a way that we can easily grep extensions and skins?

Yes. There's conduit's repository.query but it's currently "unstable" and might need a little more work to get the exact data out we want.

greg renamed this task from Train L10n-bot to work with Differential in Wikimedia Phabricator to Train L10n-bot to work with repositories hosted in Wikimedia Phabricator (Diffusion).Apr 11 2016, 3:39 PM
greg updated the task description. (Show Details)
greg set Security to None.
greg added a subscriber: greg.Apr 11 2016, 3:44 PM

Just spoke with James about this in the office this morning. Siebrand did work to make l10n bot to work with github at the hackathon so presumably it is now much easier to add additional git push locations in l10n bot.

A good test case could be OOUI? They want to be an early adopter of Differential as well (T122834).

Any repo should do. I just need to know whether Differential uses git push or something else.

Example of the new repong configs you referred to: https://gerrit.wikimedia.org/r/#/c/281308

greg added a comment.Apr 11 2016, 5:15 PM

Any repo should do. I just need to know whether Differential uses git push or something else.

Since we don't need code-review of (all of) these commits a simple git push of the commit works (assuming the user pushing has the needed rights).

For repos that the owners want to actually review the changes you could use arc diff or wait for us to solve the "don't require arc" issue (T127).

Any repo should do. I just need to know whether Differential uses git push or something else.

Since we don't need code-review of (all of) these commits a simple git push of the commit works (assuming the user pushing has the needed rights).

For repos that the owners want to actually review the changes you could use arc diff or wait for us to solve the "don't require arc" issue (T127).

Ideally, all those patches would be merged automatically when tests pass. So far we have gone the other way because testing infrastructure is not able to take the load (maybe changed now?) and tests are more often failing for unrelated reasons rather than us breaking something (this should change though).

But we can certainly do git push right now. We are not yet prepared for mass migration of MediaWiki extensions, but other projects should be fine.

demon closed this task as Declined.Mar 7 2018, 10:11 PM
Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptMar 7 2018, 10:11 PM