Page MenuHomePhabricator

Add new page protection level for Latvian Wikipedia
Closed, ResolvedPublic

Description

Please, add new page protection level for Latvian Wikipedia. So that pages can be edited by autopatrolled users (which were enabled for Latvian Wikipedia at this request), and all higher user types (admins), of course.

Community consensus: https://lv.wikipedia.org/wiki/Vikip%C4%93dija:Kopienas_port%C4%81ls#Lapu_aizsarg.C4.81.C5.A1ana

Event Timeline

Edgars2007 raised the priority of this task from to Needs Triage.
Edgars2007 updated the task description. (Show Details)
Edgars2007 added a subscriber: Edgars2007.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 13 2015, 5:50 PM
Edgars2007 updated the task description. (Show Details)Mar 13 2015, 6:00 PM

All the users with the autopatrol right would be able to edit the pages protected with this level. At lvwiki, this means bots and patrollers, in addition to autopatrolled users and sysops. Is that fine by the community?

Change 196779 had a related patch set uploaded (by Glaisher):
Add 'autopatrol' protection level to lvwiki

https://gerrit.wikimedia.org/r/196779

Edgars2007 added a comment.EditedMar 15 2015, 10:11 AM

Wanted to ask, if it's not too late. Is it possible to add cascade protection option for this protection level (that is - for autopatrolled users)? Or it is possible only for sysop's protection level?

If yes, then could it also be added? If it is too late to do it at this request, but it is possible, then should I have a RfC at Latvian Wikipedia community or I can file a new request without community's RfC? I'm really sure there won't be any opposes to this, as we are really small community, and nobody (except some) is interested in such non-interesting things :)

It is technically possible. The usual procedure is to obtain consensus before deploying configuration changes unless it is a minor or WP:COMMONSENSE case. Since this doesn't appear to be a minor change, I think it is better if you start a community discussion first. If the above changeset gets deployed before the discussion ends and if there is community consensus for cascading protection, you can always file a new ticket.

Aklapper triaged this task as Medium priority.Mar 15 2015, 2:23 PM

Community consensus (the subsection "Kaskādes bloka iespēja") for adding cascading protection for this (autopatrol) level.

I went ahead and updated the patch because almost all the users who participated in the original discussion has commented on the new discussion.

Postponed the deploy.

<anomie> Glaisher: Do they realize that editing a page protected with cascading requires the 'protect' right in addition to whatever right is specified?
<Glaisher> oh, I don't think they do
<anomie> Otherwise someone could sneak around not being able to protect pages by editing a cascade-protected page they do have permission to edit, thereby extending the cascading.

Please confirm whether we should proceed with adding cascading protection level along with 'protect' right or whether normal protection only would be fine.

Sorry for delay.

The perfect situation would be: autopatrollers are able to edit pages, which are included in cascading protection. The page, which is protected with cascading protection option for autopatrolled users, can be edited by admins. I hope you understood what I mean.

If it's not possible, then forgot about the cascading protection, just add new protection level for autopatroll group.

No, it's not technically possible. Won't add the cascading protection level then.

Change 196779 merged by jenkins-bot:
Add 'autopatrol' protection level to lvwiki

https://gerrit.wikimedia.org/r/196779

Glaisher closed this task as Resolved.Mar 31 2015, 3:21 PM

"levels": [

    "",
    "autoconfirmed",
    "autopatrol",
    "sysop",
    "superprotect"
],
Mjbmr moved this task from Backlog to Done on the Wikimedia-Site-requests board.May 4 2015, 2:13 PM