Two main reasons for the rename:
- We do have two parser with the same name TimeParser, which is at least confusing and will turn out do be a problem if we ever try to move both into the same component. The other TimeParser in lib does have it's name for a good reason: It's the generic "head" parser that does nothing but call all the other, specific parsers.
- This parser is not a generic "time" parser, it's very specific: It can only parse strings that are (or resemble) ISO timestamps.
I suggest to call this an "ISO" parser even if we are trying to avoid the word "ISO" (see T88438 and related) because this parser can parse ISO and stuff that resembles but is not ISO.