Page MenuHomePhabricator

"Edit links" not working properly in categories named "Wikipedia"
Closed, ResolvedPublic

Description

The "Edit links" link doesn't work in categories named "Wikipedia:" - at least I've seen it at dewiki and I think it also happened in eswiki. I think the problem is that the feature is puzzled by two space names in a row - it can't tell apart what is the space name and what is the page name.

Example: in https://de.wikipedia.org/wiki/Kategorie:Wikipedia:Redundanz_Februar_2015 , when trying to link it to cawiki, it gives the error: "The external client site 'dewiki' did not provide a page information for page 'Wikipedia:Redundanz Februar 2015'.

Please notice the absence of "Kategorie" in page name in the error message. That's why I think it has ha problem identifying space name.

Event Timeline

pere_prlpz raised the priority of this task from to Needs Triage.
pere_prlpz updated the task description. (Show Details)
pere_prlpz added a subscriber: pere_prlpz.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 26 2015, 11:35 PM
Dereckson closed this task as Invalid.EditedMar 27 2015, 11:47 AM
Dereckson claimed this task.
Dereckson added a subscriber: Dereckson.

Hi @pere_prlpz,

Gadgets are developed on wiki, and bugs against this one aren't currently not tracked here, so the best way to handle this issue is to let a message on a talk page of the gadget author.

Go to https://de.wikipedia.org/wiki/Spezial:Helferlein and find the Edit links gadget in the list, then request the history of the .js page. You'll know who to contact, either to solve the issue or to tell you the name of the original gadget developer.

I can't find it in the list in dewiki. I think this link isn't actually a gadget, since it appeared in all Wikipedias some time after Wikidata interwikis were deployed.

Krenair reopened this task as Open.Mar 30 2015, 8:22 AM
Krenair updated the task description. (Show Details)
Krenair added a project: Wikidata.
Krenair set Security to None.
Lydia_Pintscher removed Dereckson as the assignee of this task.Mar 30 2015, 9:40 AM
Lydia_Pintscher triaged this task as Normal priority.
Lydia_Pintscher added a subscriber: hoo.
Lydia_Pintscher added a subscriber: Lydia_Pintscher.

Yes this is not a gadget.

Change 200882 had a related patch set uploaded (by Hoo man):
Use wgPageName to construct an mw.Title in linkItem init

https://gerrit.wikimedia.org/r/200882

Change 200882 merged by jenkins-bot:
Use wgPageName to construct a mw.Title in linkItem init

https://gerrit.wikimedia.org/r/200882

hoo closed this task as Resolved.Apr 1 2015, 9:11 AM
hoo claimed this task.
hoo removed a project: Patch-For-Review.
hoo moved this task from Backlog to Done on the § Wikidata-Sprint-2015-03-24 board.