Page MenuHomePhabricator

Rephrase "Last edited..." in mobile web UI and link only to page history
Closed, DeclinedPublic

Description

Currently mobile web UI offers a prominent entry on top of the page title:

Last edited 6 months ago by Username

This drives too much attention to one (quite arbitrary) user, which for the uninformed reader might look too close to the signatures of articles in the media, written by a single person. It also doesn't do much justice to the rest of contributors, and doesn't tell much about the history of the page. Instead, we could focus on the age of the page and the amount of volunteers that have worked on it, which does give a better impression of a) the collaborative nature of Wikipedia and wikis in general, and b) a sense of potential quality and maturity of the article.

Even if that string contains links to the page history and the user page, offering only a reference to the page history and a link is better. The last editor is not that relevant (and quite often it will be a bot), but the history gives you a quick glance to the fact that this page has been updated by several people at different points of time for reasons summarized in the description of each edit. From there you can click to user profile pages if you wish.

The history mobile page is ok already today, but could benefit from T94297: Summary of activity at the top of mobile history page .

Background: https://lists.wikimedia.org/pipermail/design/2015-March/002296.html and related posts.

Event Timeline

Qgil created this task.Mar 28 2015, 10:12 AM
Qgil raised the priority of this task from to Needs Triage.
Qgil updated the task description. (Show Details)
Qgil added a project: Readers-Web-Backlog.
Qgil added a subscriber: Qgil.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 28 2015, 10:12 AM
Qgil added a comment.Apr 7 2015, 3:25 PM

What data is needed?

Qgil added a subscriber: kaldari.Apr 8 2015, 10:39 AM

Alright, one could say that this task is a duplicate of T66921, the difference being that before it was about bugs only and now it's about all tasks in general. Also, that discussion went so wrong that I think it is better to let it rest, and refresh our views here.

From that thread:

As explained at http://blog.wikimedia.org/2014/05/02/the-wikipedia-editors-behind-the-curtain/, the rationale for surfacing authorship information is to help transition readers into editors. Getting more editors increases the depth and quality of Wikipedia. No evidence has been provided that a "Last edited" statement is confusing, nor would I expect it to be.

I fully agree with this. The only objection is the focus on a single editor instead of the collaborative work. I think the goal of this strapline could be achieved with a different sentence that, in turn, would describe better the effort put in an article and its hypothetical quality.

Written by N volunteers and updated 6 months ago.

N would be calculated based on registered users minus bots. We could consider the form "by more than N volunteers" if there are anonymous edits as well.

"6 months ago" would link to the history as it does now, but the bold font would highlight it as a link.

Jdlrobson moved this task from Backlog to Discussing on the MobileFrontend board.Aug 4 2015, 6:39 PM
Jhernandez triaged this task as Low priority.Aug 18 2015, 5:17 PM
Jhernandez removed a project: Readers-Web-Backlog.

There was discussion about this in Hebrew Village Pump, and there is a consensus that "last edited by USER" should be removed. Here is my summary for this discussion (I wasn't involved in this discussion):

  • A user called "Yemenite Camel" ( who opened the discussion ) , who edited many soccer articles, claimed teenagers reading on soccer see his nickname and create similar nicknames ("X Camel") that are used for vandalism.
  • This gives too bold indication on "last edited" but in many cases the article isn't up to date and the last edit was a technical change or a bot update and nothing more, which gives the reader misleading impression
  • This isn't consistent with the non-mobile version

For the full discussion see: https://he.wikipedia.org/w/index.php?title=%D7%95%D7%99%D7%A7%D7%99%D7%A4%D7%93%D7%99%D7%94:%D7%9E%D7%96%D7%A0%D7%95%D7%9F&oldid=17645704#.D7.94.D7.95.D7.A6.D7.90.D7.AA_.D7.A7.D7.99.D7.98.D7.95.D7.A8

kaldari removed a subscriber: kaldari.Oct 23 2015, 5:09 PM
Scott added a subscriber: Scott.May 3 2016, 10:10 PM
Nirzar added a subscriber: Nirzar.EditedMay 12 2016, 2:04 AM

The main advantage of exposing the username is to have awareness with readers outside the community that wikipedia is written by individuals like them. this creates a sense of community.

I agree that only one username has it's own problem i would still advocate for having the usernames.

Can we look at not loosing this sense but still being fair at representing?

maybe something like this? ->

or this

this is rough and obviously will go through the standardization process on UI part. but it archives following things

  1. shows how many people are involved into making this article happen
  2. shows freshness of the article
  3. creates the sense of human involvement into projects

Note: we need to think about how we can have a more standard treatment to this which fits into our design principals and matches other ui components.

Qgil added a comment.May 12 2016, 10:01 AM

Thank you @Nirzar ! For what is worth, I personally like the second proposal better. More interesting data, no usernames, a visual cue to know more.

This doesn't appear to be actionable at current time and needs more thought.

Qgil removed a subscriber: Qgil.Apr 20 2017, 11:43 AM
Qgil added a subscriber: Qgil.
Jdlrobson closed this task as Declined.Jun 14 2017, 2:43 PM

Reflecting reality.