Page MenuHomePhabricator

Flow: some of the messages in the history / logs are not converted
Closed, ResolvedPublic

Description

what i do:
menu - hide topic
I enter a comment click the button to hide
theme shows one line - the text "This topic has been hidden." and "Cancel" button
click cancel
I get:
https://ru.wikipedia.org/w/index.php?title=%D0%A2%D0%B5%D0%BC%D0%B0:Sec8ahocf8pdh8zk&action=history&setlang=en
in the history of this cancellation is shown as
(cur | prev | topic) 07:39, 30 March 2015 . . Сунприат (Talk | contribs) restored the topic "г" (<flow-topic-undo-hide>) . . (+1)‎ (hide | lock)
what is expected:
<flow-topic-undo-hide> should be replaced with some text


what i do:
If you close the topic
I get:
Look at the All public logs
( https://ru.wikipedia.org/w/index.php?title=%D0%A1%D0%BB%D1%83%D0%B6%D0%B5%D0%B1%D0%BD%D0%B0%D1%8F%3A%D0%96%D1%83%D1%80%D0%BD%D0%B0%D0%BB%D1%8B&type=&user=%D0%A1%D1%83%D0%BD%D0%BF%D1%80%D0%B8%D0%B0%D1%82&page=&year=&month=-1&hide_review_log=1&hide_thanks_log=1 )
line about the lock shown as
07:42, 30 марта 2015 <logentry-lock-flow-lock-topic> (some comm lock)
what is expected: <logentry-lock-flow-lock-topic> should be replaced with some text


what i do:
If you restore the topic
I get:
Look at the All public logs
( https://ru.wikipedia.org/w/index.php?title=%D0%A1%D0%BB%D1%83%D0%B6%D0%B5%D0%B1%D0%BD%D0%B0%D1%8F%3A%D0%96%D1%83%D1%80%D0%BD%D0%B0%D0%BB%D1%8B&type=&user=%D0%A1%D1%83%D0%BD%D0%BF%D1%80%D0%B8%D0%B0%D1%82&page=&year=&month=-1&hide_review_log=1&hide_thanks_log=1 )
line about the restore shown as
07:43, 30 марта 2015 Сунприат (обсуждение | вклад) flow-restore-topic (r)
what is expected: "flow-restore-topic" should be replaced with some text

Event Timeline

Sunpriat created this task.Mar 30 2015, 8:00 AM
Sunpriat raised the priority of this task from to High.
Sunpriat updated the task description. (Show Details)
Sunpriat added a subscriber: Sunpriat.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 30 2015, 8:00 AM
Mattflaschen-WMF closed this task as Resolved.Mar 30 2015, 8:43 PM
Mattflaschen-WMF claimed this task.

First one is fixed by https://gerrit.wikimedia.org/r/#/c/199161/1 .

Remainder is duplicate of T90319: Lock logging is completely unformatted.

It's better if you let the team mark the priority. As part of our triage process, we also try to find duplicates like this.

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptMar 30 2015, 8:43 PM