Page MenuHomePhabricator

Unable to reenter the ongoing translation
Closed, ResolvedPublic1 Story Points

Description

I've got already two translations pending. Both are about 70% finished. But I cannot enter and finish either.

One of them was started a few days ago, and then there was no problem in reentering and continuing my translation even after the browser was closed. But one day suddenly I couldn't reenter my translation. It starts as usual, starts loading the translation, but then the ending like "&draft=34828" in the adress bar disappears and it goes back to the "all translations" page and offers me to create new translation. Firstly I thought it was some local bug, probably caused by some actions I made (I don't really remember what I did then).

But today it happened again. I translated some text, and accidentally pressed "backspace" while outside of any editing field. The browser returned me to the "all translations" page and after that I couldn't reenter any of the translations. Whenever I try to, it sends me back to the page mentioned and offers me to create a translation from and to the names of the articles I've already started translating.

UPD: I saw this new task: T94567. I use Chrome (Chromium) and I think that the issue described in this task could be somehow related to the problem I faced.

Event Timeline

Piramidion raised the priority of this task from to Needs Triage.
Piramidion updated the task description. (Show Details)
Piramidion added a project: ContentTranslation.
Piramidion added a subscriber: Piramidion.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 30 2015, 12:59 PM
Piramidion updated the task description. (Show Details)Mar 30 2015, 1:00 PM
Piramidion set Security to None.
Ata added a subscriber: Ata.Mar 31 2015, 1:30 PM
Piramidion updated the task description. (Show Details)Mar 31 2015, 8:37 PM
Amire80 triaged this task as High priority.Mar 31 2015, 9:20 PM
Amire80 added a subscriber: Amire80.

Yes, I indeed opened T94567 when I was trying to reproduce this one. That one is self-contained and easy to reproduce. I'm not so sure about this one, it may be a separate issue. We'll keep investigating. Do you remember which articles these were?

Piramidion added a comment.EditedApr 1 2015, 12:53 AM

@Amire80: Yes, I haven't deleted these translations yet. I hope the access to them could be somehow restored. If not - I will have to delete them and start new ones. I will provide the names of the articles and links to the translation itself:

  • Ascraeus Mons → Гора Аскрійська (link)
  • Mr Selfridge → Містер Селфрідж (link) (I deleted this from translations)

Another user (@Ata) tried to take over the second one to finish the translation but says she couldn't for some reason.

Pginer-WMF lowered the priority of this task from High to Normal.Apr 1 2015, 9:08 AM
Pginer-WMF added a project: LE-Sprint-85.
Pginer-WMF edited a custom field.Apr 1 2015, 9:19 AM
Arrbee assigned this task to Nikerabbit.Apr 7 2015, 7:28 AM
Arrbee added a subscriber: Arrbee.

@Piramidion Can you confirm that this still happen when you try to open that draft at https://uk.wikipedia.org/wiki/Special:CX when logged in as user Piramidion? How about the two newer drafts you have?

The data is in the database, and I did not find anything suspicious about it. I am sure it can be restored.

Arrbee moved this task from Backlog to In Progress on the LE-Sprint-85 board.Apr 9 2015, 7:23 AM

@Nikerabbit Yes, it still doesn't load the translated text and throws me out to the "all translations" page. As for the other two translations, the small one I started just to play with and see if the issue occurs once more. But it didn't, no matter what my actions were. It could also be somehow connected with some "bigger" articles, but I don't know for sure.

As for the third one that I'm currently translating - I do it rather carefully and to leave that translation I press ctrl+s first, so it works fine so far.

Piramidion added a comment.EditedApr 9 2015, 6:14 PM

Today I did the next:

  • I entered my translation,
  • quickly clicked to add a paragraph for translation (just to see what happens)
  • and got the warning saying that I've got unsaved translation and asking whether I really want to quit without saving them.
  • I've pressed the "leave this page" button.

I did nothing else, except the above. By the way, this was the first time I saw this warning. And the blue bar beneath the translation image (on the "all translations" page) has changed somehow. I think I've changed the translation in someway, but still cannot enter and see what it looks like.

I did nothing else, except the above. By the way, this was the first time I saw this warning. And the blue bar beneath the translation image (on the "all translations" page) has changed somehow. I think I've changed the translation in someway, but still cannot enter and see what it looks like.

This is quite curious. Could you perhaps add a screenshot of the change you mention? It will help us identify the problem more easily. And if you see any JS errors we'd really appreciate if you add them too. Thanks.

Arrbee moved this task from Needs Triage to CX5 on the ContentTranslation board.Apr 10 2015, 9:51 AM

This is the error I get:

debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:140 
GET https://uk.wikipedia.org/w/api.php?action=query&format=json&list=contenttranslation&translationid=34778 
503 (Service Unavailable)

  load.php?debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:140 
  jQuery.ajaxTransport.sendload.php?debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:134 
  jQuery.extend.ajaxVM910:25 mw.Api.ajaxVM910:24 
  mw.Api.getVM917:92 
  ContentTranslationDraft.fetchVM917:95 
  (anonymous function)load.php?debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:45 
  jQuery.Callbacks.fireload.php?debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:45 
  jQuery.Callbacks.self.addload.php?debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:49 
  jQuery.fn.readyload.php?debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:41 
  jQuery.fn.initload.php?debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:1 
  jQueryVM914:53 
  (anonymous function)VM914:53 
  mw.loader.implement.cssload.php?debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:160 
  runScriptload.php?debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:161 
  mw.loader.checkCssHandlesload.php?debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:161 
  mw.loader.cssHandleload.php?debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:45 
  jQuery.Callbacks.fireload.php?debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:46 
  jQuery.Callbacks.self.fireWithload.php?debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:46 
  jQuery.Callbacks.self.fireload.php?debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:156 
  addEmbeddedCSSload.php?debug=false&lang=uk&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T2…:155 
  (anonymous function)

Navigated to https://uk.wikipedia.org/w/index.php?title=%D0%A1%D0%BF%D0%B5%D1%86%D1%96%D…E%D1%80%D0%B0+%D0%90%D1%81%D0%BA%D1%80%D1%96%D0%B9%D1%81%D1%8C%D0%BA%D0%B0

Don't know if I did everything right (I didn't use the console earlier). And there are many warnings of deprecated parameters like

Use of "wgAction" is deprecated. Use mw.config instead.

And today another problem occured: the other my translations seem to be deleted: they didn't load text (but didn't throw me out) and the blue status bar now is empty (it is grey). There was some error, but I didn't save it. I started another translation to see what happens and I can see that the tool saves the page while no changes are made (I entered my new "test" translation and wanted to go back but chrome didn't let me since "save" was in progress). I think it could somehow save my earlier translation as empty before it was loaded but I'm not sure.

As for the first case, the screenshot is irrelevant, the blue bar earlier showed ~70% done, now it shows 40%, all of which is "from machine translation".

Trizek added a subscriber: Trizek.Apr 13 2015, 8:49 AM

Yes, similar issue concerning the deleted translation. This issue seems fixed : I've translated a new text, and it is still available (but not my old one).

I have looked at the database again and the only interesting thing I found about "Ascraeus Mons" was that it has been updated at 20150409-181601. @Piramidion Do you remember accessing or trying to access that translation on Thursday last week?

I also checked our access logs for the HTTP 503 but did not find anything obviously related to ContentTranslation.

Today I did the next:

  • I entered my translation,
  • quickly clicked to add a paragraph for translation (just to see what happens)
  • and got the warning saying that I've got unsaved translation and asking whether I really want to quit without saving them.
  • I've pressed the "leave this page" button.

I did nothing else, except the above. By the way, this was the first time I saw this warning. And the blue bar beneath the translation image (on the "all translations" page) has changed somehow. I think I've changed the translation in someway, but still cannot enter and see what it looks like.

@Nikerabbit: This comment I did post on Thursday last week. Now the blue status bar shows only 40% translation done all of which is "from the machine translation", while earlier I had over 70% finished. And in the console I still get this 503 error.

Piramidion added a comment.EditedApr 14 2015, 8:34 PM

I get Wikimedia Error.

Request: GET http://uk.wikipedia.org/w/api.php?action=query&format=jsonfm&list=contenttranslation&translationid=34778, from 10.20.0.108 via cp1067 cp1067 ([10.64.0.104]:3128), Varnish XID 270298074
Forwarded for: 94.231.180.23, 10.20.0.165, 10.20.0.165, 10.20.0.108
Error: 503, Service Unavailable at Tue, 14 Apr 2015 20:34:41 GMT

I think I was able to reproduce.

  1. Pick a long page from https://en.wikipedia.org/w/index.php?title=Special:LongPages (I avoided lists because tables are problematic)
  2. Select it for translation, e.g. https://uk.wikipedia.org/w/index.php?title=Special:ContentTranslation&page=Greek+government-debt+crisis&from=en&to=uk&targettitle=Greek_government-debt_crisis , and wait for the page to load
  3. Click some paragraphs to have the machine translation added (which is still in English here because there is no en-uk pair)
  4. Get the ID at https://uk.wikipedia.org/w/api.php?action=query&format=jsonfm&list=contenttranslation and enter it, e.g https://uk.wikipedia.org/w/api.php?action=query&format=jsonfm&list=contenttranslation&translationid=35887

Observed: the request takes a while and eventually I get a Wikimedia error:

 Request: GET http://uk.wikipedia.org/w/api.php?action=query&format=jsonfm&list=contenttranslation&translationid=35887, from 10.20.0.114 via cp1065 cp1065 ([10.64.0.102]:3128), Varnish XID 123863407
Forwarded for: 81.243.128.126, 10.20.0.105, 10.20.0.105, 10.20.0.114
Error: 503, Service Unavailable at Wed, 15 Apr 2015 06:07:51 GMT

Change 204224 had a related patch set uploaded (by Nikerabbit):
Optimize draft content loading query

https://gerrit.wikimedia.org/r/204224

Nikerabbit added a subscriber: ori.Apr 15 2015, 6:36 AM

Thanks to @ori who connected this to the error Fatal Error: request has exceeded memory limit I was able to figure out that we had one very very inefficient sql query. P522 has some more details.

Change 204224 merged by jenkins-bot:
Optimize draft content loading query

https://gerrit.wikimedia.org/r/204224

@Piramidion The above fix is now deployed. You should be able to access your draft now.

Yes, now it doesn't throw me out, though I've lost my translation (there's only one paragraph saved which I added on Thursday). Thank you for fixing this! At least I won't be afraid of losing my translations again.

Nikerabbit renamed this task from Unable to reenter the ongoing translation in ukwiki to Unable to reenter the ongoing translation.Apr 17 2015, 6:38 AM
Nikerabbit closed this task as Resolved.
Nikerabbit moved this task from In Progress to Done on the LE-Sprint-85 board.


Discovered 5 minutes ago on 17 april. I am in Chrome. I had been writing this over a few days, and saved multiple times. And I tried to add the external-links templates, and since it changes them to plain-text, I wanted to change the 'foo on website' to 'foo på website' by pressing backspace, which got me go page in the browser, losing my progress. Alll of it, but it says I have done ~70% is it this bug or T94567: in Chrome it's possible to leave the content translation interface without warning and without saving?

What is "go page"? Can you try accessing your draft through your dashboard? translationid is required in the url to access saved drafts.

The issue of backspace going to another page might be issue of T94567, or then it might be that all the current content was saved in the draft database.

Drafts are private so I can't see what you see. Can you check that there are no JavaScript errors or other failures in the developer console? I also checked and the source article has changed today which might affect our algorithms ability to re-match things: that would be a separate bug.

I copied the plain text content (excluding references) of the draft at P527. Can you say whether it contains everything you had translated or is it missing sections?