Page MenuHomePhabricator

reflinks.py crashes in ru.wiki
Closed, InvalidPublic

Description

Please, see traceback:

Traceback (most recent call last):
  File "core/pwb.py", line 213, in <module>
    run_python_file(filename, argv, argvu, file_package)
  File "core/pwb.py", line 82, in run_python_file
    main_mod.__dict__)
  File "core/scripts/reflinks.py", line 846, in <module>
    main()
  File "core/scripts/reflinks.py", line 843, in main
    bot.run()
  File "core/scripts/reflinks.py", line 519, in run
    for page in self.generator:
  File "/data/project/rubinbot2/core/pywikibot/pagegenerators.py", line 1239, in RedirectFilterPageGenerator
    for page in generator or []:
  File "/data/project/rubinbot2/core/pywikibot/pagegenerators.py", line 1574, in PreloadingGenerator
    for page in generator:
  File "/data/project/rubinbot2/core/pywikibot/data/api.py", line 2229, in __iter__
    self.data = self.request.submit()
  File "/data/project/rubinbot2/core/pywikibot/data/api.py", line 1554, in submit
    headers=headers, body=body)
  File "/data/project/rubinbot2/core/pywikibot/tools/__init__.py", line 930, in wrapper
    return obj(*__args, **__kw)
  File "/data/project/rubinbot2/core/pywikibot/comms/http.py", line 261, in request
    r = fetch(baseuri, *args, **kwargs)
  File "/data/project/rubinbot2/core/pywikibot/comms/http.py", line 358, in fetch
    request._join()  # wait for it
  File "/data/project/rubinbot2/core/pywikibot/comms/threadedhttp.py", line 375, in _join
    self.lock.acquire(True)
  File "/usr/lib/python2.7/threading.py", line 323, in acquire
    self.__cond.wait()
  File "/usr/lib/python2.7/threading.py", line 243, in wait
    waiter.acquire()
KeyboardInterrupt
CRITICAL: Waiting for 1 network thread(s) to finish. Press ctrl-c to abort

Event Timeline

Rubin16 created this task.Apr 1 2015, 12:45 PM
Rubin16 raised the priority of this task from to Normal.
Rubin16 updated the task description. (Show Details)
Rubin16 added a project: Pywikibot.
Rubin16 added a subscriber: Rubin16.
Restricted Application added subscribers: Aklapper, Unknown Object (MLST). · View Herald TranscriptApr 1 2015, 12:45 PM
jayvdb updated the task description. (Show Details)Sep 3 2015, 1:41 AM
jayvdb set Security to None.
jayvdb added a project: Pywikibot-Scripts.
jayvdb added a subscriber: jayvdb.
jayvdb closed this task as Invalid.Sep 3 2015, 1:48 AM
jayvdb claimed this task.

I cant reproduce this now. Which generator were you using?

[jayvdb@localhost core]$ python pwb.py reflinks -family:wikipedia -lang:ru '-start:!'
Retrieving 50 pages from wikipedia:ru.
No changes were needed on [[&RQ]]
No changes were needed on [[(10) Гигея]]
No changes were needed on [[!]]
No changes were needed on [[!Action Pact!]]
No changes were needed on [[(10054) Соломин]]
No changes were needed on [[!!!]]
No changes were needed on [[!T.O.O.H.!]]
...

I notice the exception is KeyboardInterrupt, which suggests that you pressed Ctrl-C.

Perhaps it was hanging rather than crashing?

Note that we have switched from httplib2 to requests, which may have helped overcome some network related issues.

Reopen if you can reproduce it.