Page MenuHomePhabricator

Convert all skins and extensions bundled with the tarball to use extension registration
Closed, ResolvedPublic

Description

Extensions should be checked off once it is merged in master and backported to REL1_25 and REL1_26 (if it was fixed after branching)

  • extensions/Cite
  • extensions/CiteThisPage
  • extensions/ConfirmEdit
  • extensions/Gadgets
  • extensions/ImageMap
  • extensions/InputBox
  • extensions/Interwiki
  • extensions/LocalisationUpdate
  • extensions/Nuke
  • extensions/ParserFunctions
  • extensions/PdfHandler
  • extensions/Poem
  • extensions/Renameuser
  • extensions/SpamBlacklist
  • extensions/SyntaxHighlight_GeSHi
  • extensions/TitleBlacklist
  • extensions/WikiEditor
  • skins/CologneBlue
  • skins/Modern
  • skins/MonoBook
  • skins/Vector

Related Objects

StatusAssignedTask
Resolvedhashar
ResolvedLegoktm
ResolvedJdforrester-WMF
ResolvedPaladox
ResolvedPaladox
ResolvedJdforrester-WMF
ResolvedLegoktm
ResolvedFlorian
ResolvedJdforrester-WMF
ResolvedPaladox
ResolvedNone
ResolvedLegoktm
ResolvedLegoktm
ResolvedLegoktm
ResolvedLegoktm
ResolvedLegoktm
ResolvedPaladox
ResolvedLegoktm
ResolvedKrenair
ResolvedLegoktm

Event Timeline

Legoktm created this task.Apr 1 2015, 9:10 PM
Legoktm updated the task description. (Show Details)
Legoktm raised the priority of this task from to High.
Legoktm added a subscriber: Legoktm.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 1 2015, 9:10 PM
Legoktm updated the task description. (Show Details)Apr 1 2015, 9:11 PM
Legoktm set Security to None.
Legoktm updated the task description. (Show Details)Apr 30 2015, 5:09 PM
Legoktm updated the task description. (Show Details)Apr 30 2015, 6:56 PM
Legoktm updated the task description. (Show Details)Apr 30 2015, 7:12 PM
Legoktm updated the task description. (Show Details)May 4 2015, 7:57 PM
Legoktm updated the task description. (Show Details)May 4 2015, 8:23 PM
Legoktm updated the task description. (Show Details)May 4 2015, 8:27 PM
Legoktm updated the task description. (Show Details)May 8 2015, 8:26 PM
Legoktm updated the task description. (Show Details)May 20 2015, 7:01 PM
Legoktm updated the task description. (Show Details)May 20 2015, 7:19 PM
Legoktm updated the task description. (Show Details)May 23 2015, 1:34 PM
Legoktm closed this task as Resolved.

DONE!

Paladox reopened this task as Open.Jul 12 2015, 2:33 PM
Paladox added a subscriber: Paladox.

Reopened since one last blocking task to solve.

Florian updated the task description. (Show Details)Oct 5 2015, 12:19 PM
Paladox closed this task as Resolved.

Final patch has been merged.

Paladox updated the task description. (Show Details)Oct 31 2015, 7:46 PM
Paladox reopened this task as Open.Oct 31 2015, 7:49 PM

It says backport to REL1_25 which one extension needs to do.

Paladox updated the task description. (Show Details)Oct 31 2015, 7:50 PM

Change 250276 had a related patch set uploaded (by Paladox):
Add extension.json, empty PHP entry point

https://gerrit.wikimedia.org/r/250276

Change 250278 had a related patch set uploaded (by Paladox):
Add extension.json, empty PHP entry point

https://gerrit.wikimedia.org/r/250278

Change 250278 abandoned by Paladox:
Add extension.json, empty PHP entry point

Reason:
Abandoning florian did the patches.

https://gerrit.wikimedia.org/r/250278

Change 250276 abandoned by Paladox:
Add extension.json, empty PHP entry point

https://gerrit.wikimedia.org/r/250276

demon updated the task description. (Show Details)Nov 2 2015, 5:44 PM
demon updated the task description. (Show Details)
demon added a subscriber: demon.

What's left to be done here?

The only thing left is to backport confirmedit to REL1_25 and REL1_26 which florian is doing.

Legoktm updated the task description. (Show Details)Nov 25 2015, 4:15 PM
Legoktm closed this task as Resolved.
Legoktm removed a project: MW-1.25-release.
demon moved this task from To be backported to Done on the MW-1.26-release board.Nov 25 2015, 4:19 PM