Page MenuHomePhabricator

$wgChatSocialAvatars: MediaWikiChat not working without SocialProfile in default configuration
Closed, InvalidPublic

Description

As of version 2.12.8 of MediaWikiChat the config option $wgChatSocialAvatars is set to true per default. This causes an empty chatroom to appear in installations without SocialProfile Extension The problem is described in the extensions's discussion page and can be reproduced with current stable MediaWiki 1.24.2.

Possible solutions:

  • add SocialProfile as a dependency
  • set $wgChatSocialAvatars to "false" by default
  • give advice in documentation

Event Timeline

S.schiffleithner raised the priority of this task from to Needs Triage.
S.schiffleithner updated the task description. (Show Details)
S.schiffleithner added a project: Social-Tools.
S.schiffleithner added a subscriber: S.schiffleithner.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 2 2015, 10:54 AM
lcawte added a subscriber: lcawte.May 22 2015, 3:08 PM

Changing the configuration variable's default sounds like the best (see: easiest) option to me.

lcawte triaged this task as Normal priority.May 22 2015, 3:08 PM
ashley assigned this task to lcawte.May 22 2015, 3:45 PM
ashley added a subscriber: ashley.

Changing the configuration variable's default sounds like the best (see: easiest) option to me.

Yep, sane defaults are sane; in this case, the extension should "just work" with the default config, without requiring anything else.
So let's set this variable to false by default and update the on-wiki documentation page (+README, if any) to note that you need SocialProfile if you want pretty avatars. Also Brickimedia's configuration will likely need to be updated since Brickimedia uses this extension and SP is available there.

With MediaWikiChat loaded only

With MediaWikiChat and SocialProfile loaded

lcawte closed this task as Invalid.May 24 2015, 1:39 PM

Can't reproduce.